Jump to content

Error -1017 (insufficent permissions) is driving me crazy!


phenixj

Recommended Posts

I've been using Retrospect for years and last week my backup to a remote windows client suddenly stopped working and gave an error -1107. I tried reinstalling Retrospect on both my windows box and the remote client and it didn't fix it. Eventually I decided to upgrade to version 7.5 to see if it's fixed there.

 

I installed 7.5 and it didn't fix it. Then I rebooted the client and the backup worked. Then I tried to run another backup on the same client and it fails!! I am definitely accessing the remote windows machine using a client and not windows drive mapping.

 

Can anyone help. Right now I want to ditch the lot and try something else!

Link to comment
Share on other sites

I've had the same problem over the years also. Each time (5x now) I have had to reinstall the operating system and start over to get the system settings back to normal. It seems to me that Windows is vulnerable to settings changes. Either registry or permissions settings or something changes for whatever reason. Although I do not believe it to be the fault of Retrospect, I feel Retrospect should have resolved this issue and have an exact and easy fix for this problem. I know this problem is widespread. I like Retrospect, but I am actually considering something else just because of this. Not that something else will work, but I am really tired of uninterested and unresponsive level one answers to a problem that should have been addressed long ago. I'm going to poke around and waste a bunch of time doing trying to get a fix for this when I know that 5 minutes of a goo Retrospect techs time would discover the problem and post a simple fix for this. If you or anyone can resolve this, I would be all ears.

Link to comment
Share on other sites

Here's the log output...

 

+ Normal backup using Maggie at 26/11/2006 21:01

To Backup Set Maggie Disk...

Can't use Open File Backup option for Local Disk (C:) on MAGGIE, error -1017 (insufficient permissions)

Can't use Open File Backup option for Local Disk (T:) on MAGGIE, error -1017 (insufficient permissions)

26/11/2006 21:02:00: Execution incomplete

Total duration: 00:00:28 (00:00:28 idle/loading/preparing)

Link to comment
Share on other sites

What operating system are you running? If you are running Windows XP, take a look at Windows Event Viewer to see if there are any errors related to VSS. This is what Retrospect uses to perform open file backups and if there's something wrong with VSS, you'll see similar errors to what you're getting.

Link to comment
Share on other sites

I'm running XP Pro.

 

I am getting the following VSS error:

 

Volume Shadow Copy Service error: Error calling a routine on the Shadow Copy Provider {b5946137-7b9f-4925-af80-51abd60b20d5}. Routine details Cannot ask provider {00000000-0000-0000-0000-000000000000} if volume is supported. [0x8000ffff] [hr = 0x8000ffff].

 

I think it may be because the second drive (T: above) is a FAT32. Drive C: is NTFS. I see in the Retrospect manual that it has to be NTFS. I removed the second drive (T:) from my backup script and now the open backup on C: works!

 

Is there anyway I can backup a FAT32 drive?

Link to comment
Share on other sites

Mayoff requested the exact text of the error. Here is the text that I get in my Operations Log.

 

+ Executing Immediate Backup at 11/25/2006 9:45 PM

To Backup Set Web Sites...

Can't use Open File Backup option for WebSites on Local Disk (C:), error -1017 (insufficient permissions)

 

- 11/25/2006 9:45:47 PM: Copying WebSites on Local Disk (C:)

11/25/2006 9:46:01 PM: Snapshot stored, 1,375 KB

11/25/2006 9:46:03 PM: Comparing WebSites on Local Disk (C:)

11/25/2006 9:46:05 PM: Execution completed successfully

Completed: 24 files, 657 KB

Performance: 38.4 MB/minute (38.4 copy, 38.4 compare)

Duration: 00:00:18 (00:00:15 idle/loading/preparing)

 

Exit at 11/25/2006 9:54 PM

Link to comment
Share on other sites

I experience this same problem on several machines, and I am infuriated by EMC's helpless response--they continually blame Windows XP Pro and tell me to call Microsoft.

 

SYMPTOM: If I do an Immediate or Script Backup that contains ANY volume that does not support VSS (mine happens to be an NTFS-formatted PGP encrypted disk), then the shadow copy service fails for ALL volumes in the backup.

 

EMC RETROSPECT'S FAULT:

--a VSS failure on one volume in a backup (either Immediate or Script) should NOT affect use of VSS for other volumes. This failure may be caused by several things, including FAT, FAT32, or PGP disk.

--This has been a bug for some time, and EMC has refused to fix it.

--EMC (and Dantz before them) support is NOT WELL TRAINED ON THIS ISSUE and continually sends users on a wild goose chase to find answers.

 

NOT EMC RETROSPECT'S FAULT: it is not their problem that the PGP encrypted disk does not support VSS.

 

Thank you to this thread for finally helping me understand what was causing the failure.

Link to comment
Share on other sites

I wouldn't say this is a bug per se, more along the lines of a design error. Since the option for Open File Backup is a script based option it will attempt to enable VSS for open files on every source volume for that script.

 

A simple workaround would be to separate your sources into two scripts - one that can use OFB, and one that cannot. For the second script, disable the option to backup open files, and this error will disappear.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...