Jump to content

retroclient.exe running wild


Recommended Posts

Seemingly at random, retroclient.exe will start using 100% of my laptop. I have client version installed, and it is running on XP Pro. I can't figure out what it's doing or why it starts, but I have to kill it with the task manager before my laptop overheats.


If I open the RetroClient control panel, the (lame) log window shows nothing about this activity. I also see nothing in the Event log.


There is no backup activity occuring --- I am looking at the only backup server on the network, and it's just sitting there.


What's up with this

Link to comment
Share on other sites



I'm not quite sure how this could be possible. Retroclient doesn't really do much except sit there and wait to be accessed. can you give some more details on the network setup you use? What happens if you turn the client off in the control panel? Have you tried uninstalling/ rebooting and then reinstalling the client?



Link to comment
Share on other sites

As you can imagine, this isn't an easy problem to debug since it occurs at random. I don't actually recall what effect the Retro Client control panel might have had. I haven't tried reinstalling the client, but that's a good idea.


My setup is as follows: Backup server is PowerPC Mac OS 9.1 running Retrospect 5.1 (latest), and this Dell laptop running Win XP with Retro Client 6.5.latest.


This problem has only happened twice so far, but I'll see if I can get more evidence if it happens again.


Link to comment
Share on other sites

Pardon me for jumping in but I too have the same problem and it happened again this morning (Sunday, 14 September 2003) with retroclient.exe going to 100% processor usage and sticking there. (To be exact Task Managers shows retroclient.exe at 98-99% and taskmgr.exe at 1-2%.)


My home network consists of four computers. The Backup Server [castoridae], which is only powered up when a backup is to be run as this is all it is used for, is running Retrospect Professional 6.5.319 under Windows 2000 Professional SP3. I have two computers running Windows XP Professional SP1 -- a desktop [procyonidae] and a laptop [mustelidae] -- which both exhibit this problem. The fourth computer [felidae], not used by me, which is a desktop running Windows 2000 Professional SP3. As far as I can tell this computer does not exhibit this problem. All the computers are setup to access the Internet via dial up connection but only the two WinXP machines actually access the Internet.


In this morning's incident my WinXP desktop was the only machine on so this I think would eliminate a local network/machine problem as a possible cause. Whether or not I am connected to the Internet appears to have no relevance to this problem.


In another thread it was speculated that resuming a machine from hibernation can cause this to happen. In this mornings incident the machine had been in hibernation but this did not happen until some three hours after the machine was started so I don't think this is relevant either. I'm also fairly certain that this has happened after a full boot.


When it happened this morning I did the following:


Firstly I tried turning the client Off and then On again, exiting between changes, with the Retrospect Client control panel but this had no effect.


I know that I can clear it by manually stopping and restart the Retrospect Client service so before doing this I decided to turn on the Backup Server and see what happened if I tried to access the client. Accessing the client from the Backup Server has caused the client to crash at times in the past.


With Retrospect running I went to Configure > Clients and double-clicked on the offending client. On the General tab I clicked the Refresh button. The information updated but there was no change in the client's processor usage.


Next I ran a file selection against the client. Using Backup > Backup I clicked the Source button and selected the client as the source, clicked OK then clicked Preview. When the selection started the processor usage dropped back to normal and stayed there. The selection preview completed without incident. I had expected the client to crash as it has in the past.


In the past when the client has crashed when accessed the following has happened:


As soon as the client was accessed the pcpds.exe program started then retroclient.exe crashes with an error message (I did write down the error message at the time but can't find it at the moment). No error messages appeared at the Backup Server other than to say the client couldn't be found.


Following is the event log entry from the client computer when this last happened if it is of any help:


Event Type: Error

Event Source: Application Error

Event Category: (100)

Event ID: 1000

Date: 2003-07-16

Time: 13:25:37

User: N/A



Faulting application retroclient.exe, version, faulting module retroclient.exe, version, fault address 0x00003ef0.


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


0000: 41 70 70 6c 69 63 61 74 Applicat

0008: 69 6f 6e 20 46 61 69 6c ion Fail

0010: 75 72 65 20 20 72 65 74 ure ret

0018: 72 6f 63 6c 69 65 6e 74 roclient

0020: 2e 65 78 65 20 36 2e 35 .exe 6.5

0028: 2e 31 33 31 2e 30 20 69 .131.0 i

0030: 6e 20 72 65 74 72 6f 63 n retroc

0038: 6c 69 65 6e 74 2e 65 78 lient.ex

0040: 65 20 36 2e 35 2e 31 33 e 6.5.13

0048: 31 2e 30 20 61 74 20 6f 1.0 at o

0050: 66 66 73 65 74 20 30 30 ffset 00

0058: 30 30 33 65 66 30 003ef0


After this crash in July I went back to the 6.0 client on this computer and have only gone back to the 6.5 client in the last few days. However the laptop has had the 6.5 client all along and exhibited this behaviour throughout.



I have noticed another oddity with the 6.5 client which may or may not have something to do with this.


My firewall, ZoneAlarm Pro 4.0, reports that retroclient.exe is trying to connect to my ISP's DNS servers of my current or last Internet connection around every 2-8 seconds. This goes on whether I am connected to the Internet or not Whether retroclient.exe is allowed to access DNS or not has no effect on the first problem.


After a full boot and before an Internet connection is made retroclient.exe will be banging away at instead. Do you know why retroclient.exe 6.5 needs to continually try accessing a DNS server when retroclient.exe 6.0 did not? I have it blocked from accessing the Internet as I can see no reason why it needs to. (I have the broadcast IP address in the Trusted Zone.)


What I am wondering is whether retroclient.exe is going to the 100% processor usage because it never gets a reply from a DNS server after a certain number of attempts.


John F Legg

Link to comment
Share on other sites





This appears to be some type of problem in the client but the cause is not yet known. I have asked our engineers to investigate your reports.




This may seem basic, but please check for viruses on your computer that could be contributing to this type of problem




We will update you when we know more.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

I have experience the same problems with the CPU usage climbing to 100% for retroclient described above with an IBM A30P Thinkpad with XP Pro SP1. I hibernate frequently and have not noticed the problem occurring when I have not yet hibernated after a reboot. This problem is new to the 6.5 client; I did not experience it with 6.0.


The most reliable way to fix the problem for me has been to reboot the machine.

Link to comment
Share on other sites

I have the same trouble on Single server 6.0 on W200 Server + XP Pro client. In my case it works to 100% because backup speed is less than 0.6Mo/min.

So I just want to know if you have this low speed too.




If you understand French, and want more explanation you can go to French forum and look to "ça marchait, ça marche plus..."



Link to comment
Share on other sites

  • 2 weeks later...



This problem has also reared it's ugly head on 2 of my Home PCs'. The Client, and the Server backups are automated. But the scripts are not scheduled at this moment. The Server script executes with no problem. The Client script will on occasion run with 99%, to 100% CPU performance on the Server. The only cure is for me to try to reboot, and break the process. The backup destination is a WD 120 external. Both of the machines are PC. No error reports are generated on the Server.




I will attempt to create an external script for the Client only. This script will reside on the Client. It is my intention to shutdown any nonessential Service on the Client machine. The Services' stopped will include, "Virus Software", ETC.


This process should determine if any Service on the Client is effecting the backup, or ...... smile.gif


This is only a theory. smile.gif




Link to comment
Share on other sites

I have successfully shutdown my VS on the Client. The full backup was a success. But any attempt to do an incremental backup resulted in a failure.


I then removed Retrospect 6.5.336, and reinstall Retrospect 6.5.319. Both full, and incremental backups were successfully completed. I then installed RDU 4.5.101. Please note that the RDU is part of Retrospect 6.5.336. An Assert error accured, and I assume that this error msg was sent to Dantz.




Retrospect 6.5.319 with RDU 4.5.100 = GOOD

Retrospect 6.5.319 with RDU 4.5.101 = BAD

Retrospect 6.5.336 with RDU 4.5.101 = BAD


Well it least on my 2 machines. smile.gif


Hope that this helps.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...