Jump to content

Searching old storage sets fails: Assertion check at "elem.c-918"


Recommended Posts

Searching storage sets created with versions of Restrospect prior to 6.0 always results with:

 

Trouble in Retrospect

 

Internal consistency check failed:

Assertion check at "elem.c-918"

 

Is there a way to convert an older storage set to a version 6.0 storage set without transferring all the files to new tapes?

Link to comment
Share on other sites

Retrospect lists three devices though I only use two, they are:

 

Sony AIT1 Turbo DC, Firewire-A

DLT 20.0 DC, Firewire-A

Phillips DVD DL, Firewire-A

 

I am running OSX 10.4.5, Retrospect 6.1.126 with RDU 6.1.4.103

 

These tapes were created in 2001 so I expect we were using version 2 or 3 of Retrospect and OS8. They were written to the DLT drive.

 

I've also attempted to search storage sets created in Retrospect 4 with the same results. The error occurs during the search, before the tape is ever involved.

 

I began to do a transfer and was able to get to the point where it asked for a new tape (past the search part). When I realized I was going to have to transfer 125GB to new tapes, I stopped. I have about 20 of these storage sets in all.

 

I had the same problem with Retrospect 6.0 on a different system (OSX 10.3.9) but I also had version 5.1 on that system and was able to launch it instead and search my storage sets fine. I don't have that option now.

Link to comment
Share on other sites

I missed one point, sorry.

 

 

 

I have not tried to rebuild the catalog. I assume you mean create a new catalog from the tapes. I believe that would take involve a few too many hours (or days) and would prefer to avoid it if possible.

Link to comment
Share on other sites

Unfortunately I don't have time to do a lot of testing on this. I'd hoped there was an easy solution. I have managed to restore my file in this case by using the "Restore files from a backup" option instead of the "Search for files and folders" option. Since I've had the problem on two different operating systems with two different versions of Retrospect on multiple storage sets, I expected it to be a common problem. I will have to revisit this at a later date.

 

Thanks for your help!

Link to comment
Share on other sites

I would be glad to upload my file for testing. I'm having the same problem.

This is a storage set created under Mac OS 9 from a DAT drive. I've tried to rebuild the set but a computer crash stopped it. (Unrelated to retrospect) I attempted it again last night but retrospect wouldn't recognize the first DAT tape.

The backup copy transfer function seemed interesting but I get the error message as before.

Unfortunately this set is 33 mb, someone elses bright idea to do nightly backups for over four years onto the same backup set.

A rebuild, even if it starts to recognize the tapes, will be daunting. I've 88 of them.

Let me know

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...