Jump to content

Proactive Backup failing

Recommended Posts

We run Retrospect on a mixed network of Mac and PC clients, and it's normally reliable (apart from Mac clients randomly switching off by themselves). About a week ago however, our Proactive backup scripts stopped running completely or would fail after backing up one or two clients. The log doesn't report anything unusual.


I went to the Run menu to see if Proactive Backup needed re-starting, but it appeared to be still running. Tried to click "Stop Proactive Backup" so I could re-start it - no luck. I've tried numerous times - it asks if I want to stop Proactive Backup, I say Yes, but it doesn't stop. If I try to quit Retrospect it again asks if I want to stop Proactive Backup, I say Yes, and the app won't quit - I've left it there for ages and end up force quitting from the Task Manager. Even after re-booting the PC and re-launching Retrospect, it's not working. Most clients not now backed up for a week, which is serious. Other scripts appear to be running fine.


Anyone else had this problem?


We run Retrospect Multi Server 6.5.336 from a Windows XP Pro machine, v2002 SP2 with 1GB Ram. Backup media is an Idealstor hard disk setup (very good incidentally- way less trouble than our old Ultrium tape based set up).


Clients are mainly 6.5.140 for PC or 6.1.130 for the Macs.

Link to comment
Share on other sites

Right. That pane must have made its first appearance in 7.0. Sorry about that.


OK, the 6.0 manual says: "When Backup Server is running, the status window shows you what it is doing. Click the triangle icon to expand the window for more information."


Now, there is a "Status" column. What does it say?

Link to comment
Share on other sites

Hi Lennart, I can't find any status window or triangle icon to expand. The only place to view any activity as far as I can tell is the Activity Monitor, and in v6.5 there doesn't appear to be any view options for Proactive Backup. The only way to manage or view Proactive Backup is;


1) Under the Manage Scripts menu: just used to create the script in the first place, set sources, schedule etc.

2) Under the Run menu, you can start, stop or disable Proactive Backup. My menu won't respond when I try Stop.

3) If it's actually running, you can see what Proactive Backup is doing under the Executing pane of Activity Monitor. Even though I can't get Proactive Backup to stop, the Executing pane shows no active scripts.


To make matters worse, my online help refers to menu options I don't have! It refers to the Proactive Backup pane in Activity Monitor that you referred to. Our copy of Retrospect was an upgrade from an older version, not a new install. Obviously something wrong there. Perhaps we're getting v7 help! I can't see any reference in the help to a version or issue number.


I think to partly solve this I'll set up normal scripts to run overnight. Problem is we don't normally get around all clients due to the time available, which is why I used a proactive script in the first place.


I just tried to exit Retrospect again, it asked me if I wanted to quit Proactive Backup, I said yes, and 15 minutes later the application is still "Quitting...." in the lower left hand pane.


Task Manger reports that Retrospect is "Running". There must be a locked or stalled process at work here? The only way I can escape and re-boot is to force quit from Task Manager.

Link to comment
Share on other sites

This is more and more puzzling. I didn't find a 6.5 manual online, so I tried the 6.0/6.1 manual. I quoted page 88 in my previous post..

I downloaded from here:



I looked in an old cabinet and found our 6.5 package, with the printed 6.5 manual. On page 95 it says to look in "Activity Monitor". It's called "Retrospect User's guide, version 6.5, first edition" and is from 2003. The CD contains 6.5.319. I haven't used 6.5 in years...


EDIT: Try the 6.5.350 as well as Driver Update 5.4.110 from here:



EDIT (again): I see there is also a 6.5.350 security update.


TIP: To download, click on the size in the right column, otherwise you will just get "read me".


Edited by Guest
Link to comment
Share on other sites

Hi there, thanks for the links - I'll update to the latest possible version from the archive to see if that fixes it. In the meantime I've set up some normal backup scripts to get most of the machines done, and I've disabled the Proactive scripts completely.


I'll post an update after I've upgraded to 6.5.350. If that doesn't do it, I suppose I should consider upgrading to 7.6, but it was working fine until a week ago.

Link to comment
Share on other sites

Hi Lennart - no luck here. I upgraded our copy of Retrospect to 6.5.350 and it still won't run any client backups.


To see if the problem was just with Proactive Backup, I disabled my old scripts and just set up some new normal backup scripts. The overnight client backup script started as planned at 7:30pm and got stuck after getting part way through one client. The client got a message saying it had completed with 2 errors, but the Activity monitor showed that 2 files were remaining and the server appears to have spent all night trying to finish off the one client. Very helpful! So nobody else got backed up.


While the script was still running I tried looking at the status of various clients, just to see what Retrospect thought they were doing. Each one I tried to check reported a -843 error (resource is in use by another operation).


So I can't backup any clients now whether I use Proactive Backup or a normal backup script.


Any idea what could be going on?

Link to comment
Share on other sites

It seems as each Retrospect client "thinks" it's in use by another copy of Retrospect. I suggest you restart a few clients and see if that helps. If it does, restart all of the others. That should help both the proactive backup as well as the "normal" backup.


It is strange that you can't see the "Proactive" status anywhere. That would have been helpful.


EDIT: Restart the server, too, just in case...

Edited by Guest
Link to comment
Share on other sites

Thanks for responding to my post. To solve the stalling problem I've had to force quit the application and reboot the server.


A old datafile backup script has since run perfectly, and the clients are visible again.


So I postponed the schedule for the stalling client backups and started one manually so I could observe it running. It finished 2 clients no problem, skipped 4 claiming that the client was not installed/not available, completed my own with one error, then appeared to get stuck again when it reached a client that I had deliberately turned off (because it seemed to have stalled on that same client twice before).


Am I making a basic error here with client versions? It not that obvious which client versions to use, especially running a mixed Mac PC platform. I now have quite a few Mac clients on OS 10.5.x and I'm using Retrospect client 6.1.130.


There apparently nothing wrong with Retrospect Multi Server 6.5.350, or the backup PC - it just doesn't like some clients. I always disable energy saver on the Macs so the drive doesn't sleep, and users log out at night.

Link to comment
Share on other sites

More problems. I upgrade to 7.6 and on launching get a serious error on startup, error file "assert_log.utx". I call tech support in the US and we end up uninstalling and reinstalling, and in the process lose all my scripts and client database.


So I can't run any of my old scripts now, I'm going to have to start from scratch.


I'm told the problem was probably my external hard drive (Idealstor SATA -worked fine for over a year on Retrospect 6.5).


I'm not going to write anything more right now because I'll struggle to avoid using bad language.....




Link to comment
Share on other sites

Hi Mayoff, thanks for the suggestions. We did re-boot the machine at one point during the tech support phone call, so maybe that was why the errors stopped, but I can't remember the sequence of events now. I've had to force quit and re-boot quite a few times in the past few days.


I think I may take the opportunity to put the new version of Retrospect onto a newer PC, and I'll see if I can find the old config file. It may have got trashed in the uninstall, but we did rename the old Retrospect folder as Retrospect_old before we did anything so maybe I can get back some settings and save some work.


Are client data and scripts all stored in one file? If so, can it be copy and pasted into a v7.6 folder?

Link to comment
Share on other sites

I think we're up and running again. Most clients got backed up over the weekend and I did manage to restore my settings from the old config file.


So we're now running v7.6 on a newer PC, the client software has been updated, and everything seems to be OK. I don't suppose we'll ever know why Proactive Backup just stopped working, but this could be a useful lesson for the "if it ain't broke don't fixit" approach.


Time flies by when you're having this much fun, and it's easy to postpone upgrades - they take some time and money.


We hadn't touched Retrospect for 5 years since we did the 6.5 update. We had to replace the HP Ultrium tape drive for a second time, and Retrospect seemed stable, so it got left alone.


Thanks for the suggestions and support.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...