Jump to content

update 7.5.508 tstring.cpp-441 error


Recommended Posts

I downloaded and installed update 7.5.508, now every time a scheduled backup executes I receive the following error message...


Retrospect has encountered a serious error:

Assertion failure at 'tstring.cpp-441"


A log of this error has been written to the file "assert_log.utx".


Please tell EMC about this problem.


We have created an error report that can help us improve EMC Retrospect.

We will treat this report as confidential and anonymous.

Send the error report? Yes or No


Prior to the update backups were performed successfully.

Link to comment
Share on other sites

If this is a client, I would forget the client from the client database and add it back to Retrospect again.


If this is not a client, then unlicense and relicense the exchange add-on in Configure>Volumes.


Is this a 32 bit or 64 bit system?


Does this happen when it tries to backup the C drive, a mailbox or storage group?

Link to comment
Share on other sites

I am having a similar problem after updating to 7.5.508 on one server only. The error I am getting is memutil.cpp-273. The server in question is running 32bit Microsoft Server 2003 Small Business as its OS, it is my domain controller as well as my Exchange 2003 server. This server does back up one other client that is our web server. Most of the backups are set up with proactive scripts, there is only one managed script running at the end of each day and one running every Sunday. The managed scripts do not seem to be a problem, both of my daily script and the Sunday script executed fine - the problem seems to be with the proactive scripts or what the proactive scripts are trying to backup.


BTW, I did unlicense and relicense the exchange add-on and then removed the client proactive scripts but I still got the error.


Like i said, my other server is doing fine after the 7.5.508 update. The working server is running 32bit Microsoft Server 2003 and its only function is to back up clients, it does not control a domain nor does it have Exchange running on it.


Tonight I will try to back up the local volume by itself without the Exchange backup to see if I can separate which one it has a problem with.

Link to comment
Share on other sites

Two nights ago I removed the backup for the exchange server and tried to use a proactive script to backup just the local C drive. Got the same failure the next morning. Once I started Retro again it proceded to do a differential backup I had scheduled for the night before on a separate local volume that goes to tape, instead of a disc. That ran fine so I decided that I would skip all executions except for the differential to tape and a full backup of the same local volume to disc scheduled for last night. I came in this morning and found that it failed again, I did not write down the new error code because I figured that it all boiled down to the same problem. Much to my chagrin, when I restarted Retro, it wanted my licensing keys. Once I input the keys as well as the add-on license keys it all comes up as a new install. I had to do this once before by manually adding all my clients and scripts back in. Only to find out later that there is a method to restore the configuration files. I have done some reading but did not find a process to do this. Anybody out there who could help me restore the configuation files from a previous install/use?

Link to comment
Share on other sites

Yeah that ould have worked for me this morning. Unfortunatley I already entered the license codes, thereby getting rid of my previous config files. Thankfully this server did not have a ton of scripts running and should not be too hard to recreate. Hopefully I will not have the error problems once I get it running again.

Link to comment
Share on other sites

I am still having my crash problem after the 508 update. After rebuilding some of my proactive scripts and recatalogging my backup scripts, things seemed to be ok for a couple of hours but when I went back to check on it, I am greeted with a failure notice: module.cpp-256. After I tell it to send the error report the next screen says that the 'Execution Terminated unexpectedly, possibly due to power failure or system crash. I know that this statement is erroneous becasue this server acts as my domain controller and there was no iterruption with the rest of my network. There were no active managed or proactive scripts running at that time.

Link to comment
Share on other sites

  • 2 weeks later...

Robin, is there any chance of a wider release of this patch? We're hitting the same problems with 7.5.508 on SBS with any Proactive backup, while normal backups complete just fine. We've tried unlicensing/relicensing the Exchange add-on and rebuilding the scripts, but with no luck. Very consistently, Proactive backups will crash with memutil.cpp-273.


We'd rather not pay $70 for a support incident if possible, especially if it's not a guaranteed solution. Alternatively, can we downgrade to an earlier version? I can't find any previous 7.5 updates on the site. Thank you!

Link to comment
Share on other sites

Retrospect version 7.5.512:


- Assertion failure at 'tstring.cpp-441"

- Assertion failure at 'wrapper1.cpp-3019"

Both errors are gone for now.


Backup to Tape (LTO2 and LTO3) are fine


Backup from System Harddisk to 'Disk Backup Set' (128bit encryption).

are stil 150Mb/min compared to the normal 1500-2500Mb/min




Link to comment
Share on other sites

  • 3 months later...

This discussion of assert errors sounds very similar to my problem.


Running SBS Standard, with Retrospect 508 running on the server. The server is running Exchange 2003.


Everytime I try to back up the server (to a hard disk on another machine on the network), Retrospect just hangs and there is nothing written to the operations log.


The "assert_log.utx" has grown fairly large, with several different errors: tstring.cpp-2214, tstring.cpp-414, tstring.cpp-416, memutil.cpp-273, memutil.cpp-174, wrapper1.cpp-3019, tmd5.cpp-621111, glyphco.cpp-2845, tmonitor.cpp62.


All the other backups (automated scripts) run just fine.


The KB articles haven't suggested a fix that works (un- and re-licence the Exchange add-on, uninstall and re-install Retrospect). Any other suggestions?


Edited by Guest
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...