Jump to content

Retrospect does not see internal DVD drives under Vista


Recommended Posts

I recently moved my Retrospect 7.5.387 Professional over to a new computer. I took the DVD-RWs from the old machine. I copied the devicexx.rdi files from the old to the new machine. The new machine runs Vista Business 32-bit, the old one ran XP Professional. When I fired Retrospect up, it did not recognize the internal DVD-RWs (known good in previous machine). It did see my two external USB DVD-RWs.


As an experiment, I moved one of the two identical internal NEC DVD-RWs to a USB case. Retrospect recognized it just fine. I did not have to re-Configure. It found it properly in the devicexx.rdi files I copied over.


Actually, it does seem to see the internal drives but has some reason it does not fully recognize them. Before I removed one of the internal drives, under ID 0:0:0 and 0:1:0 it showed “bullets” (like when a password is written) for Vendor, Product and Version.


ID Vendor Product Version

0:0:0 ••••••••• •••••••••••••••••• ••••

0:1:0 ••••••••• •••••••••••••••••• ••••


When I removed the one drive, it only showed one such line strongly suggesting that when I went from two drives to one, I went from two lines of “bullets” to one. I therefore sees the internals but does not allow me to do anything with them. The menu items for Properties, Configure Optical Drive, and Find are all grayed out. I am also guessing that 0:0:0 refers to the IDE channel. My motherboard has only one IDE port to which both DVDs were connected, other 8 available ports are SATA. Looking over the remainder of the list, all of my 6 hard drives are accounted for; therefore, I further presume that it is the DVDs that are showing up as:


0:0:0 ••••••••• •••••••••••••••••• ••••


I also tried “run as administrator”, no difference.


Windows sees the drives just fine. The are assigned letters and I can see disks put into the drives.


If anybody could help, it would be much appreciated. At least under XP, the internals were far faster than the external USB drives.

Link to comment
Share on other sites

I'm using the latest version and the latest driver update. I downloaded both of them earlier this month.

Professional 7.5.387 & driver


Under Environment I have:

ID Vendor Product Version

0:0:0 ST350063 OAS• 3.CH <--My hard drive c:

1:0:0 ••••••••• •••••••••••••••••• ••••


The second line is my DVD drive: TSSTcorp CD/DVDW TS-H653L ATA Device

Vista sees it ok and I've used it to install software and burn dvd's so I know it's working. Retrospect won't let me configure it....

Link to comment
Share on other sites

Need help with getting Retrospect to display/use the optical DVD device as a storage device.


Retrospect Professional Version 7.5.387

Driver Update and Hotfix, version

DELL XPSM1330 w/ MATSHITA DVD+-RW UJ-857G ATA Device running Windows

Vista Home Premium 32bit version


Disabling the launcher service/automatically start retrospect

Set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Aspi32\Parameters\ExcludeMiniports to null

Running as either a standard and administrator



Could not find exact string match for DVD in KB; however, version 7.0.326 could display/use the optical device. Unfortunately it did not have permission to exclusively lock some files. Purchased the upgrade version to run under Vista and ended up with less DVD capability. Retrospect has saved my data from hardware malfunctions in the past - please help me to get it reading/writing to DVD.

Link to comment
Share on other sites

  • 3 months later...

[color:purple][color:black]It seems I am not the only one having this problem recognizing internal DVDs under Vista. The external USB cases do work but are slow and make much more noise than my main (well silenced) computer. At this point it would be worth it to me to spend the $70 EMC charges for a single incident if I knew that they would either solve the problem or refund me. After all, I spent over $400 for a big case to hold 6 water cooled hard drives and 4 DVDs. I would hate to spend $70 to be told “known problem – we keep your money thoughâ€.

Does anybody know if EMC acknowledges this problem or if anybody is successful at getting internal DVDs to work under Vista?



Link to comment
Share on other sites

  • 2 weeks later...
I would hate to spend $70 to be told “known problem – we keep your money though”.


Calling our customer service is always free.


When you call tech support, we will always give a refund when an issue is a Retrospect bug (as identified by technical support). If you pay for an incident and the call turns out to be a very simple issue, tech support will often issue a refund. Every situation is different.


If we give you troubleshooting recommendations toward fixing a problem, then we typically will not issue a refund.

Link to comment
Share on other sites

  • 2 weeks later...

I had the same issue and it took some time to find a solution. In my case changing an BIOS entry helped. I went to "Devices -> IDE Drives Setup -> Native Mode Operation" and changed it from "Automatic" to "Serial ATA". After that Retrospect worked fine.


Maybe this will help you, too.



Link to comment
Share on other sites

  • 1 year later...

Well done Markus!!! I've had this issue for over two years now. I'd given up and was using XP for backups. Now, I've upgraded to Windows 7, I thought I would re-visit this issue. No joy! Same problem. But, taking your suggestion, I changed my Dell laptop's BIOS settings. They're a bit different than yours: Onboard Devices-->SATA Operation--> change from AHCI to ATA (you may get a warning about shutting the Flash Cache off first). SUCCESS!


It's too bad that EMC2 were not more helpful. Big companies, eh.


warm regards,


Link to comment
Share on other sites

I have just moved to Windows 7 from XP. I am now getting the same problem (several blobs). Just before upgrading I did a custom configuration for the newly fitted DVD drive I added. The contents of the devicenn.rdi generated under XP is below:









Product=DVD-RAM GH22LP20














Retrospect and RDU are the same versions.

I tried changing the BIOS but it made no difference. Anyway the BIOS settings caused no problems when running under XP. Is there a Windows 7 specific problem?

Link to comment
Share on other sites



Does your motherboard have any BIOS updates available? You may want to check with the manufacturer and download and install any available updates. Also, Microsoft does have an official Windows 7 Support Forum located here http://tinyurl.com/9fhdl5 . It is supported by product specialists as well as engineers and support teams. You may want to also check the threads available there for additional assistance and feedback.



Microsoft Windows Client Team

Link to comment
Share on other sites

I got the latest BIOS for my system before moving to Windows 7. As I said earlier all was fine when running on XP. The DVD drive was new and I successfully ran a custom configuration on it. I did try changing BIOS options for the drive but that made no difference.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...