Jump to content

Firewall configuration for backup to FTP question


Recommended Posts

Hi all,

 

I'm sure this is really basic but I couldn't find an answer to it in my searches.

 

I'm trying to use Retrospect 6.1 Workgroup to backup to an FTP site from Mac OS X Server 10.4 Tiger. When I turn the firewall in Server off, it executes just fine. When I turn firewall back on it fails. I get a dialog that stays open for a couple of minutes that says "waiting for reply" and when that finally closes returns Error 225.

 

Port 497 is open in the firewall and I've tried rebooting the server after making changes but nothing seems to work.

 

Thanks in advance for any help offered.

Link to comment
Share on other sites

I just went through and enabled every port that has a listing on OS X Server and it still won't work. But if I turn off the server's firewall, the backup script completes execution successfully.

 

Hopefully this might give you a clue...for me, I'm even more puzzled ????

 

Thanks for the help!

Link to comment
Share on other sites

Quote:

What do you mean by "Note that FTP is an insecure protocol and sends passwords in the clear."?

 


 

I mean exactly that. FTP is an insecure protocol and sends passwords in the clear.

 

Quote:

Sorry, but my knowledge of networks is basic (at best).

 


 

Sorry, but a tutorial on networking and FTP operation is beyond the scope of this forum, which is for Retrospect help. I suggest that you read the FTP specification: RFC-959

Wikipedia has a rudimentary discussion, too.

Wikipedia - FTP

 

And Google is your friend. It's clear that your problem isn't a Retrospect issue because everything works if you disable the firewall. Hint: it's ports 20 and 21 that Retrospect will use as its destination ports, not source ports, to contact your FTP site (i.e., ports 20 and 21 are on your FTP site).

 

Russ

Link to comment
Share on other sites

  • 6 months later...

Hello

 

I am having the same issue...but I have no problem using FTP with programs like Dreamweaver and Transmit with the firewall on. I turned the firewall off and it seemed to be working. It says:

Remaining 19671 files 14.9G

Completed 11 files 11.6M

Performance Source 7.3MB/min

 

Then it just stopped. Here is the new error message:

Device trouble: “Backup Set A”, error 220 (FTP: server is not responding).

 

I FTP'd into the server and the 11 files are not there. Still just the 0-data file - size 0B.

 

I tried again, this time 0 files, 14.0M.

 

Any suggestions? This is the only reason I purchased Retrospect and it would really suck if it won't work. I see this has been an issue on these forums for years now. The only solutions I have been seeing on these forums make life much more difficult, when it should be automating these tasks, making life easier. I should not have to shut down a system that protects my Mac, the firewall. I should not have to shut down Airport to use this software. These are two features that have become very important, which we now depend on.

 

Please let me know if there is a logical solution.

Cooch

Link to comment
Share on other sites

"By default FTP access is off, and the Firewall is on. Users must configure both for proper access. "

 

I just don't buy this. The Services tab of the Sharing preference pane enables the unix ftpd daemon, turning the machine into an FTP server.

 

"Classic" Mac OS had no such built-in ftp server abilities, yet Internet backup sets worked fine there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...