Jump to content

Assertion failure at elem.cpp-1131

Recommended Posts

OS: Windows Server 2003 R2 version 5.2 (build 3790), Service Pack 2, (64 bit)

Version 7.7.562

Exception occurred on 4/19/2012 at 10:38:08 PM

Error info: Assertion failure at "elem.cpp-1131"

Exception code: E0000000 ASSERTION

Fault address: 77D4DD50 0001:0000CD50 kernel32.dll


Thread ID: 00001700, Name: Execution thread

RAX:000000000A6B2958 CS:0033 RIP:0000000077D4DD50 EFlags:00000202

RBX:0000000000000000 SS:002B RSP:000000000A6B2960 RBP: 00000000062C5410

RCX:000000000A6B2480 DS:002B RSI:000000000A6B3AC0 FS: 0053

RDX:00000000000000D0 ES:002B RDI:000000000000000C GS: 002B



I tried recreating the script that the backup fails and I still get the same result. I havent tried to reinstalling Retrospect or updating to 7.7.620.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

I am getting the same error now for the last week every time I run a script. I was running 7.7.620 and I have also re-installed it. The error persists on a system that has been running Retrospect for 2 years.

Is always the same script? Or any Script? Backing up any local disk? Backing up any disk on any client?

What is Retrospect doing when this happens? Scanning? Copying files? What?

Link to comment
Share on other sites

I ran each script and it turns out that only one script produces the error. It is a backup script to local disk. Once it gets past the first "Matching CSI2" it starts another matching process and gives the error there. I think the simplest thing to do would be to (1) Verify the media, and if that fails, (2) Create a new script.


I rebuilt the Catalog for CSI2 a few days ago and got two of these: "Backup Set format inconsistency (9 at 3)."

Link to comment
Share on other sites

I was rather hoping it was during the scanning process, since a CHKDSK on the source volume would probably cure that problem.


I don't really think it would help, but maybe run a CHKDSK on the "catalog" volume.


Maybe you should contact Retrospect Support? (This is just a user-to-user discussion.)

Link to comment
Share on other sites

  • 2 months later...

It seems I am getting this as well.


It happens when I try to stop a backup of a particular client for a specific set.




Seems a groom on the set is causing an issue....as the error just happened - again.


OS: Windows Server 2008 version 6.0 (build 6002), Service Pack 2, (64 bit)

Application: C:\Program Files\Retrospect\Retrospect 7.7\Retrospect.exe, version 7.7.620

Exception occurred on 8/7/2012 at 11:51:56 AM

Error info: Assertion failure at "elem.cpp-1131"

Exception code: E0000000 ASSERTION

Fault address: 773470CD 0001:000160CD kernel32.dll Thread ID: 0000027C, Name: Immediate execution thread RAX:000000000A63BD60 CS:0033 RIP:00000000773470CD EFlags:00000202 RBX:0000000000000000 SS:002B RSP:000000000A63BD20 RBP: 0000000000000000 RCX:000000000A63B830 DS:002B RSI:00000000002E0031 FS: 0053 RDX:00000000000000D0 ES:002B RDI:00000000002E0031 GS: 002B

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...