Jump to content

Removing systems from a backup set

Recommended Posts

  • 1 month later...

Back after a month out of the office... There has to be a better way... I just counted it up and I've got 127 snapshots to delete from this particular backup set. Each takes ~15 minutes to process and each *completely stalls* retrospect for that entire period (stalls as in windows says (not responding) in the title bar and based on watching other executing tasks, nothing happens). If my math is correct, that's 1905 minutes (or just over 31 hours), assuming I was able to start 1 "forgot" as soon as the previous one finished. Surely there's a better way...

Link to comment
Share on other sites

We've had the same pain for years. The work-around I found was basically to create a "test" backup set ("TempWorkSpace"). Then I run a "transfer Snapshots" job, selecting only those snapshots I want to retain (ironically, the "transfer snapshot" tool does allow selection of multiple snapshots), and I transfer them to "tempworkspace". Then I check visually to make sure the snapshots I expected to transfer did transfer. Then I "recycle" the source backup set to clear it out, then I run the Transfer Backup Sets tool to copy the contents of tempworkspace back to the original backup set, visually confirm that the transfer worked, then I recycle tempworkspace to prep it for the next such operation I may want to do.


Tedious, yes, but still a time saver over what would normally be the more sane approach.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...