Jump to content

Scanning Incomplete, Error -1124 ( Invalid Ntfs Data)

Recommended Posts

Can anyone shed any light on what causes this or how to avoid or fix it?? I now am getting this error when scanning a volume which is formatted HFS+, but is in use by a PC using the paragon driver. It's similar problem to the -1100 error I used to get on these PC/HFS+ volumes. The backup machine is all mac so I am basically backing up all HFS+ volumes on a mac; via iSCSI.


This error comes up from time to time and there seems to be no fix other than deleting everything and then reformatting the volume, and then put it all back.


System is a Mac Pro 2x2.66 dual core, 2Gigs RAM, running 10.5.8 and the latest Retrospect 8.2.0.(399). Storage is attached via iSCSI and all of the volumes are formatted HFS+.



Anybody have any words of advice?


Thanks in advance.



Link to comment
Share on other sites

- What are the other things you tried that did not help?


- Does "reformatting the volume" mean partitioning a physical device, or erasing a logical volume?


I tried deleting the files that were created between two known backups, one backup that was successful (1am in the night) and the other that failed the scan (12:30 in the afternoon). Deleting the files didn't solve the scan error (invalid NTFS data). I haven't tried any directory repair programs like disk warrior yet. I need to offload the data and get it backed up before I do that. Is Disk Warrior the best at doing directory rebuilds?


Reformatting means erasing the logical volume.



Link to comment
Share on other sites

ok. Nothing else? Recycling the client software? Rebooting the client machine? Recycling the Engine?



In this setup, there is no client. The storage is mounted locally and appear as local disks on the desktop of the backup machine. So in affect, there is no client software in the picture and no need to reboot the client machine. I have tried to reboot the backup machine but that gave no improvement.


thanks for the help.



Link to comment
Share on other sites

  • 2 months later...
Guest didrik

One of these two "solutions" worked for the same message (Error -1124) in the Windows Vista / Windows 2003 Server environment. I solved this problem a few minutes ago, so I haven't really analyzed which action was "the solution." In either case, though, it's much easier than doing anything like what has already been described in this forum topic. Maybe you can adapt it to the Mac environment.


(1) A folder that failed to restore with its 1280 sub-folders and files turned out to have a space at the end of its name. It appears to have backed up properly for a year or more, yet would not restore to a different drive as part of a massive restore operation. Hundreds of thousands of other files in the same restore operation restored properly the first time, without error, to neighboring folders in the new target drive. When targeted as a separate folder restore, the problem folder failed multiple times, yielding Error -1124.


(2) The restore that worked was based on the help file in Retrospect. In some place or other, it notes that only using a snapshot or session restore can set the permissions properly. From the session / snapshot restore context, you can still use selection criteria to target what you're looking for within a session or snapshot.


Hope this helps, someone.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...