Jump to content

Upgrade to 7.5.285 and email notifications now fail


Recommended Posts

Hi Joe,


Do you get the same message when you hit the Test button?


Would you be able to try and verify this with new configuration files? These are located in C:/Documents and Settings/All Users/Application Data/Retrospect. Move config75.dat and config75.bak to a different directory and launch Retrospect again. Enter your license then try to reproduce this error.


I'm interested to see if anyone else sees this too.

Link to comment
Share on other sites

I removed the files and entered the license code. I still get the same results. I have rentered the email address again and still have the same results. And yes I I have rebooted the computer as well. I suspect the new revision broke something. Since I do not have a support contract I guess I am stuck until someon else reports it with a conract.

Link to comment
Share on other sites

It does not use a client. It sends a email via my pop server which is optimum online. I have other apps that perform the same "under the covers" email without any problem. Also I have varied the email addresses and server used and still get the same result. It worked fine until I loaded the upgrade.

Link to comment
Share on other sites

Hi Joe,


I played around with email settings for a while and the only way I could get it to report error -591 was to send a test email with a 'from' address that was not in the correct format of 'user@domain.com.' While the subject line may have formatting issues with certain servers, there doesn't seem to be any common problem with email notification failing altogether.

Link to comment
Share on other sites

hi joe,


i think amyj wants to know what client you check your email with so she can try to reproduce the problem. we all know that Retrospect doesn't use a client to 'send' the email.


for example, in another thread 1ka says he recieves email through GMail. well, ok, there a test case for amyj or anybody who wants to give it a go.


so what client are you using?

Link to comment
Share on other sites

Has anyone found a solution to this problem?


I am having the exact issue. Immediately after installing the 7.5.285 update, my email notifications started failing. The email does not get sent. In the log, the error is "Email Notification Failed: error -591 (invalid email address)". When I test the email settings, I get the same error. I tried to change email addresses (different server), same error. Nothing has changed except for the upgrade.


Maybe I could I back out this update? Any input would be appreciated.

Link to comment
Share on other sites

I have the same problem. My mail server is Mdaemon v9 and I really like the email notification, I'd like for this to work again. I've used it for a long time and it has stopped working only since I upgraded Retrospect to 7.5.285.


I can provide some details from Mdaemon's logs on the mailserver, if anyone's interested and can help provide a solution. Thanks.

Link to comment
Share on other sites

No, I've never used authentication before but I've now tried it both with and without and they both fail. Here's the detail from my mailserver when trying to send a test message without authentication:

Tue 2006-07-11 10:47:37: ----------

Tue 2006-07-11 10:47:47: Session 284; child 1; thread 200

Tue 2006-07-11 10:46:34: Accepting SMTP connection from [ : 1973]

Tue 2006-07-11 10:46:34: --> 220 parmanlubricants.com ESMTP MSA MDaemon 9.0.4; Tue, 11 Jul 2006 10:46:34 -0500

Tue 2006-07-11 10:46:34: <-- HELO wle_server

Tue 2006-07-11 10:46:34: --> 250 parmanlubricants.com Hello wle_server, pleased to meet you

Tue 2006-07-11 10:46:34: <-- MAIL FROM:<acovington@parmanlubricants.com>

Tue 2006-07-11 10:46:34: --> 530 Authentication required

Tue 2006-07-11 10:46:34: <-- RCPT TO:<acovington@parmanlubricants.com>

Tue 2006-07-11 10:46:34: --> 503 Unexpected command or sequence of commands

Tue 2006-07-11 10:47:47: <-- QUIT

Tue 2006-07-11 10:47:47: --> 221 See ya in cyberspace

Tue 2006-07-11 10:47:47: SMTP session terminated (Bytes in/out: 111/250)

Tue 2006-07-11 10:47:47: ----------


And with authentication:

Tue 2006-07-11 10:48:34: ----------

Tue 2006-07-11 10:48:48: Session 319; child 2; thread 3380

Tue 2006-07-11 10:48:47: Accepting SMTP connection from [ : 2192]

Tue 2006-07-11 10:48:47: --> 220 parmanlubricants.com ESMTP MSA MDaemon 9.0.4; Tue, 11 Jul 2006 10:48:47 -0500

Tue 2006-07-11 10:48:47: <-- EHLO wle_server

Tue 2006-07-11 10:48:47: --> 250-parmanlubricants.com Hello wle_server, pleased to meet you

Tue 2006-07-11 10:48:47: --> 250-VRFY

Tue 2006-07-11 10:48:47: --> 250-EXPN

Tue 2006-07-11 10:48:47: --> 250-ETRN

Tue 2006-07-11 10:48:47: --> 250-AUTH=LOGIN

Tue 2006-07-11 10:48:47: --> 250-AUTH LOGIN CRAM-MD5

Tue 2006-07-11 10:48:47: --> 250-8BITMIME

Tue 2006-07-11 10:48:47: --> 250 SIZE 0

Tue 2006-07-11 10:48:47: <-- AUTH LOGIN

Tue 2006-07-11 10:48:47: --> 334 VXNlcm5hbWU6

Tue 2006-07-11 10:48:48: <-- QUIT

Tue 2006-07-11 10:48:48: --> 334 UGFzc3dvcmQ6

Tue 2006-07-11 10:48:48: Connection closed

Tue 2006-07-11 10:48:48: SMTP session terminated (Bytes in/out: 35/280)

Tue 2006-07-11 10:48:48: ----------


Note the HELO vs. EHLO response from Retrospect after the mailserver accepts the connection. I don't know if this is important or not, but the HELO response seems to initiate a "response required" from the mailserver, while the EHLO does not. Is this maybe backwards? Summary:

With Retrospect's authentication option UN-checked, the mailserver responds with HELO and demands authentication, then fails when it's not received. With Restrospect's authentication checked (on), the mailserver doesn't appear to expect authentication and fails when it gets data it doesn't expect.


I've used Retrospect's email reporting for a long time, with the same mailserver and never had any such problems. Something significant changed with 7.5.285 and I hope it's easy to fix.


Thanks for any help you can offer.

Link to comment
Share on other sites

Hi... I am the original writer. My email is now working. My server requires an id and password to connect to outbound server. I guess the upgrade somehow lost that part of the information although I thought I tried it several times with and without verifiaction... probably a typo

In any case, my email is again working.


As an aside, how did you get the email details from your pop server? It would have saved me some time if I could have seen the conversation between retrospect and the server.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...