Jump to content

Sony CD drive cannot be configured; does not appear


Recommended Posts

New user with fully patched Windows 2000 with backup device: “SONY DVD RW DRU-500A.” I’m trying to backup with a blank CD-RW disc in place. I'm using Retrospect Backup Professional for Windows 6.5


When I tried to configure this backup device, it does not appear under the ‘Environment Tab’ although it appears fine in Windows Device Manager, and it is functioning fine.


I have a new home-assembled computer with a modern motherboard and a serial ATA hard drive (which does appear in the ‘Environment Tab’). The only other drives are an ‘A drive’ diskette and the aforementioned Sony CD-R/RW DVD drive which is set up as the Primary Master.


The Retrospect help menu says something about: “. . . Also make sure your computer's BIOS is set to correctly enable all devices connected to the IDE bus. Refer to the documentation that came with your computer for more details.


I don’t know whether this advice applies to me, or if so, how to check my BIOS.


Thanks in advance for any help!

Link to comment
Share on other sites

I just updated the firmware for the SONY DVD RW DRU-500A (Firmware Upgrade 2.0H).


I am assuming that any patches are included here, since I didn't see any other downolads on Sony's web page: http://sony.storagesupport.com/dvdrw/dru500adwn.htm




I have all the patches from Microsoft Windows 2000 updates, but for some reason I was unable to install from there the driver: Silicon Image storage software update released on February 03 2004 (This is Silicon Image SiI 3112 SATARaid Controller Silicon Image SiI 3512 SATARaid Controller ATI 436E Serial ATA Controller).


However, the only serial ATA device I have is my hard drive, so I assume this is not related to my Sony CD/DVD storage device. (I downloaded the current driver for the hard drive last month when I installed it, but I don't think this is relevent).


(I even temporarily uninstalled my ATI video software, but that didn't help either).


In Retrospect, in Configure Drivers, it still can't find any backup devices.


Next steps would be (1) to try another backup software or (2) buy a new CD burner ????


Any more ideas?

Link to comment
Share on other sites



In Retrospect open the configure-Devices-Environment window and see if it says "devices visible using NT passthrough."


If it says "ASPI" instead type ctrl + ALT + P + P at any screen in Retrospect. Then tick the "use NT passthrough" box under the execution heading. Relaunch Retrospect and check the device.


If that fails you can go the opposite route and try to install ASPI using the ASPIINST.EXE installer located in the Retrospect program folder.


Are there any errors in the Retrospect log about ASPI failing to load?




Link to comment
Share on other sites

You have solved my problem with my LiteOn 411s as well. I couldn't get it to recognize DVD+RW media, only CD-RW. On the cdfreaks.com forum, someone suggested it might be an ASPI problem. I tried your hidden configuration change, and now my drive is working perfectly.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...