Jump to content

Retrospect: how to eliminate error -1017 (insufficient permissions)?


Recommended Posts

Hello, 1-4-4


I bought Retrospect-Pro 6.5, see 1 error message, merely starting a normal (recycled) backup to another partition. The error log states:


"Can't use Open File Backup option for Drive C (C:), error -1017 (insufficient permissions)"


I'm new to WinXP, (...10 days new, it's much different than W98). and need a reliable disaster-backup a.s.a.p.


Can't get past that lone -1017 error message. Read forum posts about it, still don't know what to do.


I have Retrospect Pro 6.5 for Windows, latest update 6.5.336, running XP-Pro with FAT-32 partitions.


Thanks, Matt


p.s. I 'replied' to another post with the same problem, but not sure if it's still viewable. or archived.

Link to comment
Share on other sites


I forgot to add one more thing, about the 'error -1017' I keep seeing:


Right after installing Retrospect-6.5, every time I boot the computer, floppy-disk drive A: does a seek, although nothing's in the floppy A: drive. It did not do that before the install.


When doing any type of backup, right before the 'error -1017' message appears, Retrospect does another floppy-disk A: seek, then the error-message appears.


Don't know if this is part of the error problem, but they happen almost simultaneously (A: drive seek, quickly followed by -1017 error).



Link to comment
Share on other sites



Until you can get shadow copy up and running again your best bet is to turn off open file backup in your backup options.


Shadow copy is run by the Volume Shadow copy service. I believe just starting the service will re-enable shadow copy for you.



Link to comment
Share on other sites

Nate, 1-5-4



Thanks for responding, I could use the help, switching from W98 to

XP-Pro about 7 days ago (big learning curve with XP, then Retrospect).


I checked (using WinXP's own backup/Advanced settings), the "Disabled

Volume Shadow Copy" setting is un-checked, so I'm guessing it's enabled

and set proper? As you mentioned, it probably reset itself.


Tried a simple incremental backup with "open file backup" disabled, and

the error-message is gone, thank goodness the error stopped, no error

messages! One step closer.


Then tried (drive-C:) disaster backup (.iso) to another drive, and it

copied about 7100 files to the backup, although the C: drive has over

12,000 files. Although I think a CD/.iso 'full-system-restore' uses the

WinXP CD for many (restore) files?


After Retrospect installation, I can't understand why a normal XP

bootup causes a floppy A: seek. The A: floppy also does a quick seek, right

before the Retrospect -1017 error message occurs.


Also, when attempting a disaster-backup, Retrospect cannot find my CD

drive (drive I:) to search for XP's i386 folder. I must close

Retrospect, eject then re-insert the XP CD, then quickly load Retrospect

again. Then it will see the XP CD, and disaster-backup works.


Since Retrospect can't find the CD drive, but keeps looking at floppy

drive A: (with that lone error), perhaps I installed the program

incorrectly, or it sees drive A: as CD-drive J: ?


Wow... Retrospect reminds me of Forte's 'Agent' news reader. Very

difficult to get settings right, but very powerful once things are set



Thanks again for your help, I really appreciated it.



Link to comment
Share on other sites




By default Retrospect ignores any drive named a: or b: so your floppy should not be being accessed. Is your floppy drive also a LS-120 drive? If so go into the configure/devices window in Retrospect and tell Retrospect to ignore the device.


The disaster recovery CD (.iso) does not contain any of your personal data. It is a custom windows install disk that will get you up and running just far enough to start Retrospect and restore your data.


What other burning programs do you have running on this machine?




Link to comment
Share on other sites

Hello, 1-6-4


Thanks for responding.


I have a simple floppy disk drive, ('standard floppy disk controller' listed in Device Manager).

Checking Retrospect's Configure/Devices setting, it shows only my CDRW drive. Refresh still shows the CDRW, and hard-disk drives.


No other burners on the drive, just a Liteon 40X CDRW, 3.5" floppy, and 3 hard-disk drives.


I un-installed Retrospect. After rebooting, there was no floppy A: seek, when XP's main desktop screen was up, a normal XP loadup.


Re-installed Retrospect, and the floppy A: seek appears again (when XP's main desktop appears). Run Restrospect Backup, and it still checks (seeks) Floppy A:, followed by -1017 error.


I'm fairly convinced backups are working, but with the -1017 error message, I still can't rely on Retrospect for backups (I'd format C:, and test the backup to make sure it did, but not with the existing error message).






Link to comment
Share on other sites



Retrospect starts one service when the computer launches but other than that it should not be interfering with the drive (at least until Retrospect is launched).


Try this:

Open the services control panel (control panel->computer management->services) and verify that

a)the Retrospect launcher service is set to automatic and is running

b)the Retrospect helper service is set to manual and is _not_ running

c)the Removeable storage manager is set to manual and is running - it should automatically stop when you launch Retrospect.


If all of that looks good try this:

Open configure->preferences in Retrospect and uncheck the "use Retrospect laucher service" box under startup. Then close Retrospect and restart the computer. If that fixes the problem try re-enabling the launcher service and restarting the computer again.



Link to comment
Share on other sites

Hi Nate, 1-7-4


I tried all instructions you listed (above), and now XP does not seek floppy disk A:, when XP's desktop screen appears. This problem seems to be fixed.


Your settings also fixed CDRW drive I:, it is now functioning with Disaster-Recovery, easily finding I386 folder on XP CD. It not function before running your steps.


Trying all your steps above, I tried a simple backup, and still see the -1017 (open-files error) message. Same floppy drive A: seek occurs...


If I turn off 'Backup open-files', there is no Drive A: seek, all backups work, no errors.


I even disabled floopy drive A: in Device Manager, and still see the -1017 error message running a simple backup (with open-files enabled). In this state, as before, CDRW cannot be found when open-files is enabled, during Disaster-backup.


I have no idea why this error occurs. Device Manager reports all is fine (no conflicts), and Administrative Tools reports only 1 removable media (my CDRW drive).


Do I even need to enable 'open files', to make (full) recovery backups, and disaster backups to a CD-Boot .iso ? I'm using Retrospect to backup a single computer/drives.


When I disabled Open-Files, more files were actually found (and backed up), compared to when Open-Files are 'enabled'.


Whatever, I've spent too much of my own time trying to find some sort of setup error with my computer/Retrospect, and none to be found.


I need a solid backup of (at least) my Drive C: partition very soon, and will purchase/try another backup program if needed (probably True Image).


Any other ideas, please post.


Thanks, Matt


p.s. Disk Fit Pro for Windows XP, I wish! smile.gif

Link to comment
Share on other sites



You don't actually need to use open file backup to get a full system backup. I would run the backup that way. Let us know if there are any errors in the log. If not you are good to go.


This is really a strange problem - My best quess is that something is funny with the OS install. Unfortunately it will require a resinstall to prove it...




Link to comment
Share on other sites

Hi Nate, 1-8-4


Backups with 'open-files' disabled produces no errors.


I tried another diaster-backup (after normal backup) today, and it could not find the XP CD, while searching for XP's I386 folder. Exiting Retrospect allowed access to the XP CD, a reload of Retrospect, and it found the I386 folder again; The *.ISO backup worked.


Double-clicking on the *.ISO backup, and I get another error message, stating it cannot read file: 'nres_eng.msg', Nero's CD burner data. So that failed too.


Needing a backup of drive C:, I downloaded another well-known disaster/backup program (evaluation copy). The 1st/initial disaster backup reported no errors. Looked fine, so I tested the restore feature with new software. XP formatted drive C:, 18 minutes later XP was restored to original condition.


I like the way Retrospect looks and works (the other backup program requires floppy disks), but I cannot get things working correctly.


None of the errors (at least that I have) with Retrospect make any sense, and I know the program works very well.


Thanks for all the help.




p.s. If (when?) I have to re-install XP again, I'll give Retrospect another try.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...