Jump to content

Retrospect 5.6 Won't Recognize SCSI Tape Drive

Recommended Posts

I have been using Retrospect 5.6 for over a year now without problems on a Windows 2000 machine. Recently, I got a new computer and installed Windows XP Professional w/ SP1 and then installed my same hardware with Retrospect and, again, it worked fine, so I know the hardware is good. I then proceeded to change my hard drives to utilize an Intel Raid controller, for which I had to rebuild most of the hardware, to include BIOS settings and to reinstall Windows. Now I can't get Retrospect to recognize my OnStream SC-50 tape drive (or SCSI card... I'm not sure which it looks for). Windows can see the drive in it's device manager, so I assume that it's setup correctly, but when I use Retrospect to look for "Devices", it continually scanns through ID's 0:x through 2:x, but doesn't find anything. When I tell it to stop, the entire program closes. My SCSI card is utilizing PCI Bus 3, Device 7 so I was wondering if this is too high of a bus for Retrospect to recognize? But my tape drive is being reported that it is on Bus Number 0, Target ID 4, so is that normal? Please note that I do not know too much about PCI slots and busses, I am just proving this information in case this is the culprit. I have tried enabling and disabling both the card and the tape drive, as well as installing and uninstalling drivers for my tape drive, both of which to no avail. The only thing I can think of is that the PCI Bus is causing the conflict, but I don't know how to change it. I will research how to do so if anyone believes that this is the problem, or how I can find out why Retrospect can't see the drive when Windows can.


Here is my configuration:

Windows XP Professional with SP1

Restrospect 5.6.132 Workgroup Edition with Driver Update 3.1.103


OnStream Echo SC-50 Tape Drive

Dual WD Raptor 36GB Drives in RAID 0 utilizing Intel 875 Chipset RAID Controller

System has been tried with Echo Drivers installed and uninstalled


Any help is greatly appreciated. I like the Retrospect program, but I just can't get it to run.

Link to comment
Share on other sites

By the way, if I do install the OnStream driver, when I start up Retrospect, it says it needs to disable some functionality of the drive in order for the application to operate correctly. I tell it to proceed and reboot the computer, but it still fails to recognize it and it just continually loops through looking for devices. I am only mentioning it so that you know Retrospect sees the existance of the drive in order to give this error, but not to find it in the devices section.

Link to comment
Share on other sites

- Run ASPICHK (in the Retrospect Program Files folder) to make sure ASPI is "green" and all components are at version 4.60 or higher. If not, try a reinstall (ASPIINST.exe). Retrospect will install 4.60. Later versions may be obtained through the vendor website (www.adaptec.com).


- Enable NT SCSI Passthrough to bypass ASPI: From the Retrospect Directory hit Ctrl-Alt-P-P. Under "Execution," check "Enable NT SCSI Passthrough." Click OK. Quit and relaunch.


- If Retrospect is having trouble seeing a device using ASPI, you can try running a 3rd party utility called id.exe to search for all available devices supported by ASPI. If id.exe can not see your backup device, Retrospect will also have trouble finding the device.





Link to comment
Share on other sites


Thank you for the reply, but your suggestions have not worked so far. I have found that the problem is probably NOT with the SCSI card or tape drive, becuase I have physically removed both from the system and I am still having the same problem. When I go to devices, it either continually scanns, or hangs while scanning, and I can't even setup a file based backup device. I have a sneaking suspicion that it is due to the Intel RAID controller that I am using for my computer. I ran the ASPICHK.EXE program, and it displayed the following:


I also used the SCSI ID program, and it provided the following information
when the SCSI card was in the system:

for WIN32

ID0 Disk: Intel Raid 0 Volume A 0.1. Fixed


ID7 Adapter: INI910U ASPI for WIN32

ID4 Tape: OnStream SC-50 1.09 Remov

And it provided the following information when I removed the SCSI card from
the system:

for WIN32

ID0 Disk: Intel Raid 0 Volume A 0.1. Fixed

When I use your shortcut to get to the "Secret" preferences, when
I have the NT SCSI Passthrough disabled (unchecked), it just says "Checking
Device ID 0" and the timer moves, but it doesn't loop through any other
devices. When I hit "stop" the entire program closes.

When I have NT SCSI Passthrough enabled (checked), it starts with displaying
"Checking Device ID 0:0" and loops through "Checking Device ID
2:0", and repeats continuously. When I hit "stop", again the
entire program closes.

I have also tried to uninstall and reinstall the entire application to no avail.
My guess is that the Intel RAID controller is the problem. This is a standard
controller, on an ABIT IC7-MAX3 motherboard, utilizing the 875 chipset with
the latest drivers directly from Intel. Do you think this could be the problem?
If so, what can I do to fix it. Again, the SCSI card and tape drive have been
eliminated from the equation.

Thanks for your time.

Link to comment
Share on other sites


Thank you very much for your post. That was the culprit. I had the Intel Application Accelerator RAID Edition version 3.0 installed, which is the version that came with my new motherboard, but as soon as I downloaded version 3.5 and installed it, Retrospect started working. I hate that I wasted hours troubleshooting such a simple fix, but your help was greatly appreciated!


Dantz Support Personell,

You might consider adding this fix as an item to your standard troublshooting or FAQ lists. I know it would have saved me tons of time if I had found it there.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...