Jump to content

Duplicate dirids under Retro 5 and OS X

Recommended Posts

I have Retrospect 5.0.238 running on a Beige G3/233 with Mac OS X 10.2.6 connecting to a Red Hat 8.0 server running netatalk 1.6.3. The Retrospect machine has 512, maybe 786 MB of RAM. And it's the only thing running on the machine.


I have like 9 different shares served up on the same server, and in the same directory. For example:


/home/shares/test is a AppleTalk share called "Test".

/home/shares/Stuff is a share called "Stuff" etc.


so, I have one share that Retrospect gives me this error:


"While scanning volume Admin,

Folder Admin/Press/,

> Duplicate dirid detected: 0x00000079

Volume root Admin/,

> Scanning incomplete, error -127 (volume corrupt?)"


It also gives the same error when just browsing a volume. Via the volume browsing feature in Retrospect.


Once it happens, I can delete the folder that it's happening in (/Admin/Press) and then it starts flagging the error in a different directory.


I've done various things, copying the files back and forth, and moving the files around, creating fresh copies of the files, the duplicate dirid error keeps moving from folder to folder, and eventually loops back around to the original folder. The hex code for the error is not always the same, it sometimes seems to increment, and sometimes it picks a whole new series of numbers to count with.


Is there any idea what needs to be done? The other 8 shares served from the machine are all fine. It's just this one. I've even tried copying all the files in the share to a new, fresh share, and it follows the files.

Link to comment
Share on other sites



You could try tarring up the files in this problem share, deleting the originals and then untarring the data again. That should reassign dir ID data for good.


Your best bet in the end is to use Retrospect 5.1 and the linux client. It gets around these nettatalk Dir ID issues quite nicely.



Link to comment
Share on other sites

  • 3 weeks later...

I have the same thing happening ... and I am not using Linux w/netatalk, but Helios EtherShare.


Helios is running on Xserve w/ OSXS 10.2.6.

I used to back up the data from the Xserve but was having problems so assessing backup across the network. (If only I had Gbit Enet!)


Anyway, it worked perfectly well directly from Xserve to Tape via SCSI - reason I changed was Retrospect 5.0238 and the Adaptec 39160 driver dont quite like each other enough.


Immediately i started backing up across the network I started getting these Duplicate Dirid errors.


Personally, I think it is Retrospect & network shares - and yes 5.1 may do a better job, but I unable to purchase 5.1 until next year (too far away for comfort & peace of mind) so it is a critical concern.


I will have to go back to direct b/up and I am sure Retrospect will get their upgrade money next year!

Link to comment
Share on other sites


Personally, I think it is Retrospect & network shares



The upgrade Nate suggested was so the user could use the Retrospect Linux client on the source machine.


You weren't clear about your setup; is your source data on the Mac OS X machine (XServe) and your Destination another Macintosh on your networks somewhere? Or on a PC?


Have you attempted to backup the XServe as a Retrospect Client, instead of sharing out volumes?



Link to comment
Share on other sites



Thanks for your interest.

There is a lot I can say about why I use this particular setup, please trust me it's best way for now.


Sources are internal shares created by Helios from data n Xserve HDs & Xserve RAID, then mounted on backup server.


I havent tried using Retro Client because I only recently managed to get that working on a non-critial machine. (In case you wonder, our server is critical - most are - and recent problems have created downtime that i do not wish to experience until we have a standby server. It's gets more complicated, just believe me ;-)


So, that's why I do this way, AND it's also the recommendation from our Helios support provider, as we use OPI server.


With respect to Retrospect and network shares - what speed Enet is minimum. We will go to Gbit eventually, but it's currently 100Mbps.


C. confused.gif

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...