Jump to content

failure to complete backup - 6.5 multi-server


Recommended Posts



been having problems with getting retrospect to do a backup. Having spent the last week struggling I thought I'd give the forum a go.


Just trying to do an initial backup and every time retrospect crashes out with a problem. I am attempting to backup about 300 gig (296,095 files) onto AIT-1. The files are local to the machine - The backup starts fine and I sometimes get the the 3rd or 4th AIT tape (estimating about 8/9 to complete) before it bombs out.


various errors including:


assertion errors in: module.cpp-457

assertion errors in: elem.cpp-661

various access violations

ran out out memory (!?!)


The machine has been running fine otherwise (just fileserving). Clean windows 2003 server install - no other software apart from retrospect.

Done an extensive memory test (all ok). Ran Sandra burn in test overnight (all ok). Done check-disk (all ok). I do reboots between retrospect falling over. CPU is cruising at about 5% during write to tape operation.


So far I have tried:



- pulling it off the network for the duration of the backup, incase writing to the disk was causing the problem.

- installing ASPI (is that compatible with win2k3 server ?) - used the 4.6 release shipping with retrospect and the 4.7 release from adaptec.

(using 4.6 made retrospect use aspi (still crashed) and complain about the CD writer on the machine- using 4.7 retrospect went back to NT passthrough ?)

- tried with verification off (never gets to the verification stage so I don't think it's that)

- tried with "copy security settings" off

- disable the tape drive in device manager.



It takes about 2 1/2 hours per AIT and sometimes crashes 10 hours in, so it is getting very time-intensive to sort out. Been throught the FAQs and knowledgebase but coming up blank


Machine spec:


win2003 server

Retrospect v6.5.319 multi-server

sony ait-1 drive/adaptec 2940u2w scsi card

768Mb memory

data drive is on adapec 1200A raid controller

netgear 302 gigabit card (tried swapping this for a 3com, still falls over).


any suggestions what to do next.






Link to comment
Share on other sites

nope...that made it worse...


I can't erase a tape now...as soon as i hit <ok to erase> I get:


Assertion failure at "arc.cpp-3542"


After 1 1/2 hours on the phone to dantz support - and lot of fiddling, dantz tech support decided that it was the scsi card that was faulty. They suggested I buy another - unconvinced I swapped it out with a card from another machine....suprise suprise...no difference.


I was asked to uninstall aspi, even though retrospect wasn't using it, same problem.

I was eventually asked to install on a winXP machine to see if retrospect was working ok..I drew the line at this - I couldn't quite see the point of that. Dantz are gonna think about it and get back to me. (glad I'm not paying for this support call !)


In the meantime I have used NT backup - ships free with win2k3 server - this completed without errors.


Interestingly I then opened retrospect and tried to erase this "NT backup" tape with"unknown format"..this worked fine. I then tried to erase a tape that was part of an old incomplete backup set - crashed -so I deleted/forgot the old catalog file. then the erase worked ok.


Seems the latest crash is related to erasing tapes that are part of other (possibly corrupt) backup sets - something that wasn't happening in 6.5.319.


time to attempt another 20hour backup marathon and see if this latest version fixes my problems.


any more suggestions welcome.



Link to comment
Share on other sites

tried it both ways - disabled and enabled - same results.


As I said in the previous posting, I circumvented the erase issue (something new in 336? - but probably due to a corrupt catalog file) and am now attempting a full backup with 6.5.336 - looking more promising - but its such a big backup (for ait-1) that it takes ages to find out if it is going to be successful or not (4 tapes in equates to about 10 hours).






Link to comment
Share on other sites

Sorry for the long post, but here we go:


Installed 6.5.336


All the mystery crashes seem to have vanished (hurray). Completed a backup but on verification it gave a lot of compare/verification errors.


Simple, I thought, SCSI bus issues. So I changed a few things and did a backup after each change.


1. removed all other devices from the scsi bus (still had verification errors - errors are always on different files - all static data files and machine has been temporarily pulled off network)

2. used new scsi cable (more errors)

3. new terminator (ditto)

4. new scsi card (ditto)

5. scsi card in different pci slot (ditto)

6. new scsi id for tape drive (yep ditto)

7. new firmware for scsi card (you get the drift)

8. termination power off on tape drive...

9. reinstall aspi

10. remove aspi

11. remove raid controller and try backup from local disk

12. Pull scsi card and do backup to file ... still had compare errors !!!!

13. Do yet another disk check (all ok)


At this stage machine is just motherboard/system drive/single ide data drive/memory/PSU/clean win2k3 install with retrospect


14. give up and get a spare drive - swap out system drive and install XP pro and retrospect 6.5.319

15. backup same data from data drive using 'file backup' - all ok

16. install scsi card and tape - backup all ok !!!!

17. go back to win2k3 disk and same hardware configuration.

18. backup to file ..crashes on verification.

19. backup to file again - verification errors.

20. backup to tape - verification errors.

21. use NTbackup with verify against original file verification/compare NO ERRORS

22. several NTbackups later no errors whatsoever.



conclusions....retrospect has some issues with win2k3 - whether that is MY install of win2k3 or all installs I don't know - but certainly 336 cured a lot of problems that 319 had (DESPITE the 'suitable for windows server 2003' that was on the box).

Either NTbackup is a lot more forgiving of errors - or doesn't verify correctly - or 6.5.336 still doesn't work properly on win2k3.


I have ordered a high end 64bit scsi card for the tape drive - if that doesn't work I give up - worst $1000 I spent.




Link to comment
Share on other sites



verify errors are offset in stream 'data' - always in different files.


When I tried doing the disk backup it was from the raid controller to a seperate disk on the internal IDE contoller (VIA chipset - 2nd master). Only crashed once (with error in arc-cpp I think - not in front of machine at the moment) - completed second time - with file compare errors. Tried the same thing from this internal disk to internal disk - file compare errors. Tried updated VIA drivers (I think only the AGP driver has been udated for win2k3). File compare errors.


I stress that using 336 retrospect has only crashed once during backup -as described above. All the mystery crashes that plagued me before (see initial post) have disappeared. In some senses it is nearly working, but as a backup solution 'nearly' is near enough.


I am using NT backup to the AIT drive successfully for the time being - absolutely no file compare errors so far (300 gig copied) and test restores have worked fine.





Link to comment
Share on other sites





I imagine you are tired of trying things by now but...




The cpp errors can also be memory related. Any chance you can pare down the memory on this machine a bit and see if things improve? You may have a flaky RAM chip that does not get used heavily in day to day operations.




That could explain why NT backup is working - it may be less memory intensive?




How about saving the catalog file on a network share or a USB drive? Maybe Retrospect is fighting with the Hard disk controller drivers?





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...