Jump to content

Sony AIT2 SDX-520C generates file compare errors

Recommended Posts

I recently upgraded to a Sony AIT2 SDX-520C (50/130GB) from an OnStream 15/30GB.

This is an EIDE/ATAPI device.


When running Retrospect I receive numerous file compare errors.


+ I am running Windows XP Professional complete with all recent updates, patches, service packs, etc.

+ This is a new upgrade and I previously experienced exactly the same with Windows 2000 Professional.

+ I upgraded my disks at the same time as installing Windows XP. I therefore cannot attribute the source of the problem to disk hardware.

+ I am running Retrospect v6.5 Professional and the v4.3.102 driver update.

+ I have been running this since before my switch from Windows 2000 to Windows XP.

+ Retrospect 6.5 worked fine with my previous OnStream device.

+ The Sony SDX-520C is connected as a master to a Promise Ultra133 TX2 IDE interface card.

+ The OnStream was connected exactly the same.

+ I have upgraded the Promise Ultra133 TX2 onboard firmware and am using the latest Windows XP driver.

+ I am running the same type of backup as I did with the OnStream from which I never received any file comparison error whatsoever.

+ The backup is of a "cold" disk: I boot into a secondary partition on a second disk where I have Windows XP "Lite" installed -- i.e. without any superfluous applications and from which I then backup my primary disks.

+ The comparison errors include .doc and .xls files which are totally static during the backup process: I don't even have MS Office installed on my "Lite" partition.

+ I have also run "hot backups" of the live Windows XP system and received similar comparison error warnings.

+ I installed the TapeWare 30-day demo software I received with the Sony drive and this runs flawlessly (backup and compare) in exactly the same configuration as I am using Retrospect.


What to do?

Link to comment
Share on other sites

Here is a short extract from the start and the end of the relevant log file section. Please advise if you had something else in mind. I have been playing around with and without the Windows driver (although it does not seem to make any difference). I had not installed the Windows driver when this problem first manifested iself. At the moment the Windows driver *IS* installed. I will remove it, re-run a backup tonight and will post the resultant log file extract tomorrow.


--- Log file extract -------------------------------------------------------------------

+ Recycle backup using WinXP + Documents + Archive at 4-09-2003 23:30

To Backup Set Backup Set A...

4-09-2003 23:30:36: Recycle backup: The Backup Set was reset


- 4-09-2003 23:30:36: Copying PC_THEODOCUMENTS (D:)

5-09-2003 00:30:34: Snapshot stored, 15.3 MB

5-09-2003 00:30:41: Comparing PC_THEODOCUMENTS (D:)

+ Recycle backup using WinXP + Documents + Archive at 4-09-2003 23:30

To Backup Set Backup Set A...

4-09-2003 23:30:36: Recycle backup: The Backup Set was reset


- 4-09-2003 23:30:36: Copying PC_THEODOCUMENTS (D:)

5-09-2003 00:30:34: Snapshot stored, 15.3 MB

5-09-2003 00:30:41: Comparing PC_THEODOCUMENTS (D:)

File "D:\My Documents\...\Technology jitters expected to exacerbate weak local IT market - Sep 1999.doc": didn't compare at offset 606,937 in stream "Data"

File "D:\My Documents\ARCHIVE\Ixchange revenue analysis Aug 2000.xls": didn't compare at offset 3,566 in stream "Data"

File "D:\My Documents\ARCHIVE\Outlook Files\...\BI Project Internal.mpp": didn't compare at offset 191,657 in stream "Data"




File "C:\Documents and Settings\All Users\Application Data\Retrospect\RtrExec.dir\Exec\State\RetroSnp.dat": didn't compare at offset 12,093,484 in stream "Data"

5-09-2003 01:33:25: 78 execution errors

Completed: 70918 files, 24.1 GB

Performance: 416.7 MB/minute (422.7 copy, 410.9 compare)

Duration: 02:02:48 (00:04:34 idle/loading/preparing)


Link to comment
Share on other sites

+ I have now run a backup with the Windows driver uninstalled and have experienced pretty much the same.

+ When uninstalling the driver I deleted the driver using Device Manager.

+ I also deleted the driver file (sxpait.sys) from system32\drivers and the corresponding oemxx.inf and oemxx.pnf files and rebooted.

+ Whilst Windows notifies me of new hardware detected when I reboot (which I then cancel), Windows XP seems to have some default support for the Sony as it listed in Device Manager without the customary yellow "?".

+ Or is there something else I need to do to get the device *fully* uninstalled?

+ I am again posting the log file extract below although it is for all practical purposes identical to my previous post.

+ I have recorded the list of execution errors in the hierarchical view + sorted descending by size as screen shots (I didn't know how to export this in any other way).

+ I can submit the full logfiles and the screenshots directly by e-mail if relevant.

+ I notice that these errors are predominantly with large files (100MB+) although there are the exceptions to the rule which are only a few kB's.

+ I also noticed one specifically file (not particularly large) which featured in both the previous and this log as having failed.

+ A final observation: I see that the tape retensioning function is not available for the Sony drive. Any specific reason for this?


--- Log file post -----------------------------------------------------------------------

+Recycle backup using WinXP + Documents + Archive at 6-09-2003 21:30

To Backup Set Backup Set A

6-09-2003 21:30:52: Recycle backup: The Backup Set was reset


- 6-09-2003 21:30:52: Copying PC_THEODOCUMENTS (D:)

6-09-2003 22:31:24: Snapshot stored, 15.3 MB

6-09-2003 22:31:38: Comparing PC_THEODOCUMENTS (D:)

File "D:\ ... \Archive\AB ~ Cost Accounts by Month Data.xls": didn't compare at offset 96,958,240 in stream "Data"

File "D:\ ... \Additonal data.csv": didn't compare at offset 193,896,295 in stream "Data"

File "D:\ ... \XYZ provisions - Combined.csv": didn't compare at offset 498,896,456 in stream "Data"

File "D:\ ... \Sales by channel.csv": didn't compare at offset 263,878,838 in stream "Data"

File "D:\My Documents\CONSULTING\VxP Installation\TTF16 (v6.1.5.12).ocx": didn't compare at offset 1,037,988 in stream "Data"

File "D:\My Documents\Hardware Archive\Scanner Test Images\Scanner Test Image -- B&W.JPG": didn't compare at offset 2,126,869 in stream "Data"

File "F:\WIN2K SP-4\I386\LANG\CHT\MINGLIU.TT_": didn't compare at offset 617,557 in stream "Data"

7-09-2003 02:06:05: 57 execution errors

Completed: 45232 files, 24.4 GB

Performance: 374.0 MB/minute (367.9 copy, 380.3 compare)

Duration: 02:17:14 (00:03:48 idle/loading/preparing)


7-09-2003 02:06:05: 152 execution errors

Total performance: 399.3 MB/minute

Total duration: 04:35:13 (00:10:09 idle/loading/preparing)

Link to comment
Share on other sites

Further feedback: I ran a restore from the tape and then did a detailed file-by-file comparison using Beyond Compare 2 on a subset of the files (approximately 500 files / 5GB) using BC2's binary file comparison mode. This exercise identified 11 files as being different and which correlated 100% with the comparison errors detected by Retrospect.


I can therefore only conclude that the "errors" are being introduced during the file backup stage and is not an artefact of the backup comparison process.

Link to comment
Share on other sites



Have you tried running the tape drive off of your onboard IDE controller rather than the promise card? I have an IDE tape drive myself (It is junk compared to yours though) that just plain didn't work on my Promise controller.


I suspect you will still get fast enough throughput on your standard controller.


The other thing you can try is installing ASPI but I recommend trying the other controller first.



Link to comment
Share on other sites

Hi Nate,


I had in actual fact done this yesterday (with my thicket of cables I can't wait for serial ATA to really become ubiquotous...) and ran a backup last night. The easiest for the trial run was to connect the Sony as the slave to my master disk. The results were promising:


+ There were *NO* file comparison errors!

+ Initial throughput was about half (200MB per minute) of what I had otherwise achieved (400MB per minute).

+ This is to be expected since both devices were sharing the IDE channel? Yes/no?

+ BTW, one of the reasons why I installed the Promise card initially was to be able to connect the primary data sources/sinks to a dedicated IDE channel.

+ The not-so-good news is that 9 hours later the verification had not yet completed (backup with verify usually takes say 2-3 hours with the Sony).

+ Whilst there was tape and disk activity, it seemed to be very lethargic.

+ I am, however, not fussed as I think there could have been a jumper setting problem causing/contributing to this.

+ I have now properly redone the plumbing and will run a backup later this evening to see if this will now work.

+ If successful, then I will reconfigure my machine with the motherboard secondary IDE channel dedicated to the Sony and I'll connect my second disk to the Promise card.

+ If not, then I'll need some sake from you!



Link to comment
Share on other sites

Hi Nate,


I have now completed my replumbing and my machine now looks as follows:


+ Motherboard primary IDE: Primary disk as master + no slave device

+ Motherboard secondary IDE channel: Sony as master + DVD-R/CD-RW as slave device

+ Promise IDE controller first channel: Secondary disk (which contains my "WinXP Lite") as master + no slave device

+ Promise IDE controller second channel: DVD-R as master + no slave device


Feedback from my backup job run during the early hours of this morning is as follows:


+ In backup mode I achieved throughput of some 175MB per minute which is roughly comparable with what I achieved the first time round with the Sony connected to the motherboard IDE controller.

+ Speed *is* therefore an issue as this is less than half of what I achieved with the Sony connected to the Promise controller.

+ BTW as reference, I achieved some 100MB per minute with my old OnStream device connected to the Promise IDE controller.

+ The biggest speed issue, however, is with the verification cycle.

+ I cancelled the job after it had only completed about 35% of the verification as I had run out of time and had to restore the machine to fully operating mode.

+ Average verification throughput achieved was only some 70MB per minute and based on visual observation, was dropping steadily. The Sony's "Busy" indicator would flash once and then remain off for at least 10+ seconds, give another flash, etc. I'm not sure who was doing what as CPU loading never exceed 10%.


The bottom line: 1 step forwards and (unfortunately) 0.9 steps to the side. But at least we are winning!


+ You make mention of installing ASPI drivers.

+ I know of the ASPI drivers published by Adaptec (ostensibly only for use with Adaptec products but, as far as I know, these work fairly universally).

+ I have also seen on the Nero (as in Burning ROM) site and possibly elsewhere as well.

+ From where should I source such?


Nevertheless, thanks very much so far. I had at one stage seriously considered returning the Sony drive and/or switching away from Retrospect. Neither of these options are even remotely necessary now.





Link to comment
Share on other sites



Glad to hear we are making headway. You can install ASPI with the ASPIINST.EXE utility located in the Retrospect program folder. After you install that version you are going to want to also run the 4.71 ASPI update from adaptec`s web site.


You can tell if ASPI is loading properly if you go to configure-> devices -> environment in Retrospect. It will say devices visible using aspi.




Link to comment
Share on other sites

Hi Nate,


+ I have now installed and run Retrospect with the ASPI v4.60 in the Retrospect folder.

+ The aspichk.exe reports everything OK.

+ I have not done the upgrade to Adaptec's v4.71 but will do so.

+ I have also had to create the empty \\HKLM\System\...\ExcludeMiniports registry key as per the help file.

+ Retrospect now recognises the Sony under "Devices visible using ASPI...".

+ I could only do a short backup run but for the 15 minutes or so which it ran, throughput was around the 190-200MB per minute mark.

+ This is about the same as in direct ATAPI mode. Did you expect it to be higher?

+ I will only be able to do a full run again tonight.



Link to comment
Share on other sites

Hi Nate,


Feedback from yesterday evening's backup job: Everything went OK and there were *NO* errors. Note the accompanying smiley icon!


The only matter for discussion is that of throughput. Aggregate throughput on last night's job was some 140MB per minute (backup + verify) which is obviously a far cry from the 400MB per minute previously achieved -- albeit with errors.


+ What are my options to push up the 140MB per minute?

+ What are the dependent system bottlenecks in this that one could do something about?

+ Is the principal bottleneck my PC and its hardware/software or the Sony?

+ Why the big performance differences between the onboard IDE and the Promise controller?

+ Is there any likelihood that the RDU drivers for the Sony have not been fully tuned, etc?

+ Should I rather consider swapping the IDE/ATAPI Sony and the Promise card out for a SCSI version of the Sony + a SCSI card?

+ What throughput is this likely to give me?

+ I can run some throughput benchmarks with SiSoftware SANDRA (unfortunately I only have the 2002 version), will this be of any value?

+ Any other ideas or suggestions?





Link to comment
Share on other sites

Hopefully my swansong for this thread.


Yesterday evening I ran a backup after having installed the Intel chipset and application accelerator tools for my motherboard. As I am running my backups from an unadulterated Win XP "Lite", I didn't install these as a matter of course.


Having installed these I am now truly smiling!


The backup completed with *NO* errors but more importantly, at an average throughput of some *400MB* per minute. Yippee!


Thanks Nate!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...