Jump to content

Open File Backup - Retrospect 6.0 Single Server


Recommended Posts

I have the Retrospect Single Server Edition with licenses for unlimited clients and open file backup, I have successfully done one open file backup (Windows XP Professional), ever since then I get the following error, and calls to you Dantz and re-installing etc, etc, it never gets fixed and I find the US$600 paid somewhat worthless!


This is the error message in the log, my disk has 34.5 GB used, 21.3 GB spare and I backup only around 6 gig of this drive?


"Can't use Open File Backup option for Drive C (C:), error -2147418113 (unknown)"


I have had all sorts of advice from Dantz about roff.sys, (it is never installed in my system despite requesting this option in the custom install screen)


Anyone have ANY ideas?


Geoff. mad.gif

Link to comment
Share on other sites

  • 2 weeks later...

If you are running 6.0 and are experiencing crashes or freezes on restart or shutdown, it could be an issue related to the Open File filter software that gets installed (ROFF).


Or if you are getting errors like, "can't use open file backup", sign up for our notification mailing list and you will be notified when this issue is resolved:



Link to comment
Share on other sites

Under Windows XP, Dantz uses the MS Shadow Copy API's for open file backup. ROFF is not installed or used under XP, but the open file features of Retrospect should still be working.


The error being reported could be the result of a problem directly related to the operating system on that computer, specifically a problem with the Shadow copy functionality on your system. Have you successfully used this specific XP system with other backup utilities that take advantage of open file on XP?


Make sure you have at least one NTFS volume, and about 100MB of free disk space, minimum.

Link to comment
Share on other sites

Thanks for the info, I run NTFS only and and havd several Gbytes free, it has worked ONCE only and yes perhaps something is wrong with this system regarding shadow copy, the system is a single Laptop running Windows XP professional and I am only trying to back it up to a Tape Drive connected via SCSI (VXA-1).




How do I check Shadow Copy, I don't have any other software?




This was the last E-mail I got from Dantz support and it was completely on the wrong track it seems, Geoff.








Dear Pablo,




I have been away and just uninstalled Retrospect 6 and re-installed from scratch, I do not have a roff.sys in the \system32\drivers directory and rofftest fails, what do I do next. I am dead sure that open file backup option was installed in the installation options,




Regards, Geoff.




-----Original Message-----


Sent: Monday, February 24, 2003 3:28 PM


Subject: RE: Rofftest






Hello Mr. Allison,




Please uninstall Retrospect and re-install it again being logged as admin or




using a user with administration rights.


After that check again regarding the roff.sys file I mentioned on my


previous email.










International Technical Support Engineer


Dantz Development Corporation














Thnaks very much, I did not have roff.sys in the drivers directory (or


anywhere on the PC) nor the registry entry, I have added both but rofftest


does not work after a reboot, this is the error I get:




C:\Windows\Temp>rofftest c




rofftest - copyright 2002 by Dantz Development Corporation




This tool tests the Retrospect Open File Filter (ROFF) by


snapping and unsnapping a specified disk volume




roffttest: Error opening the control device [0x00000002]






As there was no regisrty entry, do I have some other entry missing?




Please advise and thanks for your help so far,








-----Original Message-----


Sent: Thursday, February 20, 2003 4:55 PM


Subject: Rofftest






Hello Mr. Allison,,




Thanks for your email. Please check first that one of your partitions is




as an NTFS volume and not FAT32.




Check that you have the following file:




-roff.sys in winnt\system32\drivers


And also the following entry in the registry (if possible check it also):


HKLM\system\currentcontrolset\services\roff\enum\count key is 1




If you still have problems, verify that Retrospect Open File Backup is


working using the


attached rofftest utility.




For example to verify Open File Backup on Drive E,




E:\temp>rofftest e




rofftest - copyright 2002 by Dantz Development Corporation




This tool tests the Retrospect Open File Filter (ROFF) by


snapping and unsnapping a specified disk volume




Snap volume: OK


Access snapshot volume: OK


Unsnap volume: OK








Feel free to contact us again if you still have questions,


Best regards,






Technical Support Specialist


Dantz Development Corporation









Link to comment
Share on other sites

I just now checked the affected machine (a domain controller/echange server on a small and simple 4-server network - a quick glance and it appears every drive on the machine is affected.).


I noticed the service "Retrospect Helper" was not turned on, even though its startup was "automatic". Then I noticed that the "helper" was set to use the "System" account.


I changed the retrospect "Helper" Service settings to use my "Super Administrator" account name (basically the account I use when administering anything on the network, which has rights to everything.)


I don't know if that will make a difference. Do you?


Is this error also a known bug in the program affecting some machines for unknown reasons, despite its error code difference?


I noticed the error code itself is not listed in Retrospect's help file.

Link to comment
Share on other sites

I noticed the service "Retrospect Helper" was not turned on


The Retrospect Helper Service is used in the event of a Windows 2000 or XP registry

restore. After executing an initial restore, the Retrospect Helper Service will ask you to boot up in registry restore mode so that the restore can complete. The Helper Service then completes the restore of the Windows 2000 and XP "System State" data. The service may not necessarily be installed or turned on all the time or on all computers.


Retrospect only uses the helper service during the Windows 2000 and XP restore process.


I have a similar problem... -1017 insufficient permissions


Can you provide more information? What kinds of files? Are these errors on network machines or the local machine? What is the full text of the error message? Which verison of the client software are you using? Without any information about your setup, it's not possible to effectively troubleshoot this.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...