Jump to content

Recommended Posts

the catalog (as well as the backup data) is stored on a firewire drive that is attached directly to my computer. This backup schema has been working well up till a few days ago, the fact that I updated to OS 10.2.4 may or may not be a factor. When this first occured I deleted the backup script and created a new one but still get the same error.

This morning I did an attended backup and did not get a "catalog locked error" but instead the log indicates 204 execution errors! Yikes!


P.S. thanks for your prompt response

Link to comment
Share on other sites





Since I did the attended backup I no longer get the "catalog is locked" when autmated script is run, but in checking the log last night I get:




File ?servermgr_afp.lock?: different data size (set: 110,666, vol: 110,723), path: ?OSXServer/private/var/servermgrd/servermgr_afp.lock?.


File ?servermgr_info.lock?: different data size (set: 114,604, vol: 114,663), path: ?OSXServer/private/var/servermgrd/servermgr_info.lock?.


File ?servermgr_qtss.lock?: different data size (set: 109,089, vol: 109,146), path: ?OSXServer/private/var/servermgrd/servermgr_qtss.lock?.


File ?servermgr_smb.lock?: different data size (set: 110,651, vol: 110,709), path: ?OSXServer/private/var/servermgrd/servermgr_smb.lock?.


File ?servermgr_web.lock?: different data size (set: 195,438, vol: 195,527), path: ?OSXServer/private/var/servermgrd/servermgr_web.lock?.




how can I correct this?

Link to comment
Share on other sites


When trying to backup an OS X server (10.2.4) with Retro Backup (latest ver and latest driver) I get the message error -45 in report and in the log I get the message "Catalog is locked"



Always include the version of the program; saying "latest version" won't stand the test of time (and is sometime simply not accurate).


Confirm you are using a File Backup Set stored on an external FW hard drive?


I just took an existing Catalog file and locked it from the Finder's Get Info panel (checked the box). When I tried to use it for a backup the log reported:

"Can't add to backup set TestBackup: The catalog is locked."


No error -45 though.


What are the permissions of your Catalog and/or Data files when viewed from the terminal?




Link to comment
Share on other sites

so we are using Retrospect 5.0 driver 3.1.105

I will check to see if the get info on the catalog has been locked.

strange how retrospect automatically locks the catalogs, if this actually the problem.

I am not using a Fire Wire hard drive like the other post, I am just having the same problem with the catalog locked. as far as permissions I am logging into the terminal as admin, with full control.




Link to comment
Share on other sites

  • 3 weeks later...

I have had this same problem, "catalog is locked." The file for the catalog is definitely not locked in the finder. It is an intermittent problem, about every two to three weeks.

My only solution is to start a new tape, but I would like a better solution.

I am using a Mac with OS 10.2.4, and Retropect v 5.0.236 (I just upgraded to 5.0.238, but previous upgrades have not solved this problem.

If I go to Configure / Backup Sets / and then select the current backup set, click configure, and then the Option tab, everything is greyed out.


I hope you have some suggestions for this problem.


Thanks, David

Link to comment
Share on other sites


Does the disk containing the catalog file, have available free space?


No, it has 20 GB available!



Is the catalog getting encrypted or compressed by something outside of Retrospect?


I don't think so.

I realized there is potentially another contributing problem. When in retrospect, I tried to Configure / Devices, and I could not see the device!

I restarted the machine, and now I could see the device, and I could also see the catalog for the tape! The tape was nearly full, and when I manually started a backup, it quickly asked for a new tape. Could this be involved?


Or could it be a communications problem with the tape backup?

I am running a G4 Mac (733 MHz) with a SCSI card, and the the tape backup (OnStream SC30e) is connected via a SCSI cable.

I am using Driver Update v 3.1.105.





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...