Jump to content

Conflict with special characters in folder/filenames


Recommended Posts

We are running a MacPro under Leopard Server 10.5.8 (french version) with Retrospect 8.1 installed on this server. We backup our datas, which are located on a 1Tb internal HDD, to another 1Tb internal HDD, dedicated to Retrospect backups. The OS and Retrospect are installed on a third HDD.


As we explain in this thread , we have problems with files/folders with special characters causing the backup to duplicate unchanged files.


The result is that we backup everyday more than 30 Gb of unchanged files...


This issue was logged as bug 22034 and "fixed" with the update of the end of June, but it is not...


This problem is sly because it seems to concern only accentued files/folders located in share points and with ACL permissions active.


Removing the ACL permissions on the share point (wich is not a solution...) eliminates the problem.


Storing the same datas on the startup disk or on a unshared volume eliminates the problem too.


To isolate the problem, I made the following test :


- Created a new share point on a other volume than the startup disk

- Created in this share point 4 folders with all 2 files in

- 2 folders with accents in their names, one with 2 accentued filenames in, the other with 2 filenames without accents in

- 2 others folders without accents in their names, one with 2 accentued filenames in , the other with 2 filenames without accents in


I first tried with read and write POSIX permissions only, with propagation. OK, backup doesn't duplicate.


Then, I tried with POSIX and ACL permissions on (for the same group than POSIX) , with propagation of these permissions.


The result is that all the combinations are OK (3 files completed, then 0 files completed) except for the combination "folder with accents and files names with accents" (3 files completed, then 2 files completed for every following backup). Log is here .


So, it seems clear that Retrospect 8.1 has a bug with this combination of foldername/filename with ACL permissions.


As we are running a french Leopard server, could somebody reproduce this problem with a non localized server OS ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...