Jump to content

8.1.148 Fails on Fiber Exabyte Library

Recommended Posts

Running 8.1.148 on a dedicated Mac Pro connected directly via Fiber to an Exabyte Magnum 448 LTO-3 Library.


This Mac Pro is also connected to a QLogic Fiber Switch and is a node of the XSan.


Had set up 2 backup jobs to run. First went off as planned, 6PM start for about 2 TB of Data. Completed before the next job was scheduled to start.


Second job was set for 10:00 a.m. to backup about 5 TB of data during the work day as an impact test against the XSan and video capture capabilities.


The log shows the job starting as scheduled but then shows a -205 error (lost access to storage medium).


Any ideas on what I can change? The host machine is a clean install Mac Pro w/8GB of RAM running 10.4.11. Have to run Tiger until we can upgrade the XSan. A successful complete backup is the first step in the upgrade process and we are having zero luck with Retro 8 so far.

Link to comment
Share on other sites

Update on my situation:


No change to my situation after moving the Library to the Fiber Switch. Started a 2TB backup on time and got 38GB into it then Retrospect "Lost Connection to the Drive".


Ran the Exabyte tools on it and everything comes back fine. I then did the Exabyte ltoTool Full Tape test where it writes up to 1TB (or until it fills the tape) and then reads it all back. The unit passed with flying colors.


So I have to conclude that the issue is back to Retrospect 8.


Time to go try BRU.


Maybe EMC could buy the Tolis Group and then use the BRU Engineering Team and the Retro User Interface Team and fire everyone else.

Link to comment
Share on other sites

  • 1 month later...

Well, going to give the latest Retro 8 a shot. Tried BRU for 2 months and while it was able to happily give us a full backup it has had many issues with the subsequent incremental backups.


Also I'm fairly certain that the interface was designed by monkeys in funny hats.


So I am crossing my fingers that Retro has resolved some of the issues that I kept having while using the first release version.

Link to comment
Share on other sites

Tried BRU for 2 months and while it was able to happily give us a full backup it has had many issues with the subsequent incremental backups.

Note that BRU requires that you set your drive up for sequential access of the tapes in the library because BRU cannot manage the autoloader, and relies on the autoloader to automatically switch the tapes as if the tape drive held one big long tape.


If you had your autoloader working with BRU, then you would have had to change the autoloader from its default configuration (used by Retrospect) to sequential access. Change the control mode to SCSI (from sequential) so that Retrospect can send commands to the autoloader, and change the emulation mode to Native (if it's not set for that already).



Link to comment
Share on other sites

Thanks Russ.


Do you have any info on where I would go to check that setting? Exabyte LtoTool? Front panel of the library?


The unit is at a client site so I have limited access.


For what it's worth I received a report from my client that the backup failed. She sent me a screen shot but I have no way of knowing what happened until I can get in there again.



Link to comment
Share on other sites

Well, I don't have the LTO autoloader; instead, we have an Exabyte VXA-2 1x10 1u PacketLoader (SCSI) with the Ethernet Admin interface. Attached is a screen shot showing where the setting is for our unit (some settings have been redacted for obvious reasons), and the LTO autoloader is similar (see below).


Basically, it was an early hack for those software packages that didn't support autoloaders, such that the software would start writing to one tape and the autoloader would then eject that tape when full and load another, making appear to the software that there was just one big long tape.


Here's the manual for your autoloader:

Magnum 448


See page 93 of the manual regarding configuring the library for "random" (what Retrospect wants) or "sequential" (what BRU wants) access of tapes in the library. Random mode means that the program has to cycle the library, load and unload tapes, etc. This setting can be done from the front panel (see page 124) or from the ethernet admin (see page 93).


The Exabyte LTOtool utility only manipulates the drive, not the library. The Exabyte LIBtool utility only manipulates the library but can't configure it.


Hope this helps. If you have network access to the ethernet admin interface (and if that interface has been set up), then you could do this remotely and wouldn't have to visit the client. VPN is your friend (we use VPN Tracker from Equinux).



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...