Jump to content

Wit's End

Recommended Posts

I'm at my wit's end. I simply can't get Retrospect to use my network drive to do any backups anymore. I tried erasing all memory of the media set and creating it from scratch. I tried deleting the script and creating a new one. I even removed all security from my network drive so it's writable by anyone. Each time I add the network drive to the media set, it creates a Retrospect folder, a folder called "Daily Set AA" beneath it, and a folder under that called "1-Daily Set AA". This obviously indicates Retrospect has access to my media. But when I run the script, it refuses to run, asking me for media. I tried this 5 or 6 times and just don't know what to do.


Is there a hidden log somewhere that will tell me why the daemon can't access my media set while the console can?

Link to comment
Share on other sites

Other users have reported a similar issue, which we have had a hard time reproducing internally.


We have a new version being released early next week. That version contains a lot of bug fixes including some that may help you. Update to the new version and try a new Media Set at that time.

Link to comment
Share on other sites

I'm using an Iomega StorCenter on my home Ethernet. It has a "Backups" folder and a public folder. My Mac insists on mounting the Backup folder twice, for some reason. This is the output from the "df" command:


//admin@storcenter2tb/Backups 3872210528 98985648 3773224880 3% /Volumes/Backups

afp_35BeZX35BeZX35BeZX35BeZX-3.2e000006 3833180936 59227920 3773953016 2% /Volumes/Backups-1


When I have Retrospect add this member to the media set, it only shows me the option of using Backups-1, not Backups. Also, for some reason, in the Finder, my StorCenter2TB shows up inside of itself. When I open the StorCenter drive in the Finder, I see these items:






and within the StorCenter2TB folder it shows me once more, the Backups and public folders, but not yet another StorCenter2TB.


It kind of looks like my Mac is confused, mounting both the whole StoreCenter device as a remote volume, and the Backups folder itself as another volume. Perhaps this is the cause of Retrospect's confusion, too, but in fact Retrospect does create the proper directories on the volume when I add the Backups folder to the media set. It's just the file copying part that it won't do.

Link to comment
Share on other sites

When I click Add Share and specify smb://ip..//backups, it just adds another entry called Backups-3 to my choices of members (which already has Backups-1 and Backups-2). Then when I select Backups-3 and click Add, I get a red message "An error occurred". Actually I get this message no matter what member I click on.


So I deleted the media set and created a new one (now called Daily B) and added the Backups-1 member to it (the one I had originally, not the -2 or -3 versions). Finally! :banana: It's running! I won't know whether it finishes for a while, because it will take 3 days to backup my 1 TB, but the fact that it started is a very good sign.


I have to say, I don't know what I did different this time. I had already tried to delete the media set and create a new one with a different name, but that didn't work. It's clear the problem had something to do with Retrospect's saved state of the media set, because I added exactly the same member to this new set as I tried to do to the old set.


This is the second time in 2 months that I've had to destroy all my backed-up data and create a new one on the same media, because Retrospect refused to do anything with that old media set. Before I destroyed the old data, I even tried rebuilding the catalog from the media set (which took days). The recatalog seemed to work, but when I tried to back up...same old problem where it couldn't find the media.

Link to comment
Share on other sites

My Mac insists on mounting the Backup folder twice, for some reason


Well, your Mac isn't insisting on anything; it's just a machine that does what you tell it (or configure it) to do.


When you add a network share to Retrospect, that share point will be mounted on the Engine machine, but not in a way that is visible in the Finder to a user who may be concurrently logged into that machine.


If that Finder user should then also take the steps necessary to mount the same volume (so that user _can_ see it in the Finder) Mac OS X will append a sequential number to the volume's name (as seen by unix tools; the Finder appears to suppress that information for Desktop or Computer views).


OS X has always done this, but over the years I usually only saw it when some communications hiccup caused the machine to loose track of a currently mounted share, and when the volume was remounted (either manually or by some other method) the name got the appended serial number.


Retrospect does not appear to have any method to unmount ("umount") one of these volumes; quitting the Console Application, Stopping the Engine, has no effect. I haven't tested with scheduled Scripts to assure that such needed volumes get auto-mounted when the Script runs and to learn what, if anything, happens to those volumes after a Script has completed successfully (an elegant implementation would have the volumes unmount when done, the way Retrospect "Classic" did).


So when the machine running the Retrospect Engine is also being used by a human in the Finder there's a chance that this name changing is going to occur.


Robin, if the documentation is not going to address how this is supposed to work (assuming it's working as intended) then a KB article is going to be needed to address what is surely going to be the cause of numerous tech support requests.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...