Jump to content

Asking for new media on network drive

Recommended Posts

I'm backing up to a network drive (an Iomega StorCenter -- an EMC product). Every once in a while my backups stop happening because (I guess) it can't find the network drive and asks for new media. Even though I got the network drive back, it's stuck wanting new media. Over time (due to pilot error, no doubt) it has led to this structure on my network drive:


-- Retrospect

---- Daily Set A

------ 1 Daily Set A

-------- Retrospect

---------- Daily Set A

------------ 2-Daily Set A

------------ 3-Daily Set A


Now today it happened again, my backup is stuck and say "Needs Media". When I click on the "Choose Media..." button, it says "Select folder: 4-Daily Set A". There is no 4-Daily Set A and I don't want to create a new folder. What's wrong with 3-Daily Set A that it has been backing up to? When I select 3-Daily Set A and click "Add", nothing happens. Apparently once it has given up trying to write to 3-Daily Set A, it refuses to use it again. How do I get out of this mess?

Edited by Guest
Link to comment
Share on other sites

Also, I notice that for the "Daily Set A" media set, it wanted to put the member 4-Daily Set A on a completely different volume (a removable drive, not my network drive). I tried to remove this member from the media set, but when I click the "-" button at the bottom of the window, and the remove dialog pops up, clicking the "Remove" button does nothing. The button goes blue momentarily when click it, and then Cancel gets highlighted and the dialog stays put. How do I remove that member?

Link to comment
Share on other sites

This is a terrible option. My backup is > 1 TB so I can't use a file. Are you saying then that in order to continue to be able to do my daily backups, I have no choice but to recycle my backup drive, thus destroying all prior backups? For the time being, can't I tell it to create another member, 4-Daily Set A, on the same drive?

Link to comment
Share on other sites

All right, after a great many tries, I figured out that the reason it just ignores my attempt to remove the bogus 4-Daily Set A member from my backup set, is because an activity was running waiting to access that nonexistent member. Similarly I could not add new members to the set either while the script was running, but it just ignored my button presses without telling me why. Please add some warning dialogs in these cases in the future.


I was able to delete the member after stopping the script, and then when I restarted the script, it said it was grooming Daily Set A, but then it hung, waiting for media. When I clicked the Choose Media button, it asked me to choose the folder "1-Daily Set A". So I browsed to that folder on backup drive and clicked the Add button. The dialog closed, but the script didn't budge. It was still hung, wanting media. I tried this 3 or 4 times. Is it possible to extricate myself from this mode?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...