Jump to content

RetroPro6 hangs on Validate Scripts


Recommended Posts

Doing a "Validate Scripts":




With RDB5.6, selecting this option could take a while, but usually less than a minute or two. I *shouldn't* take this long, but at least it ended.




With RP6.0, doing a Validate seems to cause RP6.0 to hang. I waited several minutes before I decided to kill RP6. Even then this was difficult--the Windows XP task manager was unable to kill the RP6 task and I was forced to power-cycle reboot the PC.




I don't know why Validate, for both of these versions of Retrospect, takes so long--what is the program doing? Check the script, ping the disks & files, check login permissions, etc. should *not* take that long and should not hang Retrospect6.



Link to comment
Share on other sites

In the RP6/XP case, I'm backing up from my IDE C: HD to a File backup on a second E: IDE HD on the same PC (ATA100 or ATA133). So the catalog is on one of the two (probably the E: drive)... No LAN or clients are involved.




With RDB5.6 (from a W2K PC), I've backed up from local IDE HD->local IDE HD *and* local IDE HD->remote (over 100Mbps LAN) IDE drives (File backup) all on PCs. I do think it takes longer to Validate when going over a LAN but I haven't tried RP6.0 in this environment--it was bad enough just local HD to HD.




Perhaps you could tell me what Validate is doing--is it just checking for the *existence* of things and access permissions or is it actually scanning files and catalogs? It can't possibly *just* be checking the script itself--under both 5.6 and 6.0, it takes far too long and my network activity monitor shows that Retro is heavily accessing the remote File backup.




If it's going to thoroughly scan the File backup and if it's really going to take a while, you should provide a progress bar and a Cancel button.

Link to comment
Share on other sites

I ran some more tests with the Validate Script/Check functions. It's not correct to say that RP6/Validate causes RP6 to "freeze", at least not permanently, but the function is broken enough to not be useful.




For comparison:




800MHz PIII, W2K SP3, Retrospect Desktop Backup 5.6, RDU 3.0:


"Check" script (Normal File backup, C: to E:, both local IDE, ATA66 and 100)




----> Takes about 30sec to come back with a "Script appears valid" message (this is still too long and the program gives no feedback as to what its doing, how long it will take, if it's still running, etc. Someone could think it has frozen)






1.3GHz P4, XP, Retrospect Pro 6.0


"Validate script" (Normal File backup, C: to E:, both local IDE, ATA100 and 133)




---> Took between 10-15min [that's *minutes*] (I wasn't watching it that closely--I thought it was hung) for "Script appears valid" message to appear. During this the system showed an hourglass over Retrospect and the Task Manager displayed a "Not responding" message for Retrospect. CPU usage showed that Retrospect was doing something, with < 5% of the CPU.




This is far too long for a script validation. It couldn't possibly take that long to validate the script, and Retro has shown that it is doing something with the backup file, not just with the script--this *really* slows things down (if 10-15min isn't long enough...) if the backup File is across a network. Media checking is still a separate option.




Also, the function itself isn't very useful because it doesn't really check that the script will run correctly--as an example, it runs at the current login permission during the Validate/Check but doesn't check that the Retrospect Launcher service permission is adequate to allow the script to run later. And, as I stated before, we should get a progress bar, activity indicator and a Cancel option for this.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...