Jump to content

Retrospect Express HD will not run


Recommended Posts

Retrospect Express HD 2.0 and 2.5 no longer run on my system. They used to work beautifully and were a great back up system. It came with my external hard drive


Now when the program starts I immediately get the error message "RetroExpress.exe has encountered a problem and needs to close. We are sorry for the inconvenience."


I'm running on Windows XP with Service Pack 3


If any other information is needed, please let me know.


Thank you,



Link to comment
Share on other sites

After spending a long time going through posts on this forum, I found a solution!


I read that some people had success by uninstalling .net 2.0 and reinstalling it. When I tried this, Windows would tell me it couldn't uninstall or repair right after the initial startup.


I tried downloading .net 2.0, but the installer would have the same issue. Finally, I searched .net and found the latest version (2.5 SP1) from http://www.microsoft.com/net/ and after installing that, Retrospect is backing up! It didn't even require a reboot.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...