Jump to content

path too long (error 1128)


Recommended Posts

I'm using Retrospect Express HD version 2.0.145. I have a backup from XP SP2 that I'm restoring to Vista x64 SP1. Both are NTFS file systems.


Works great except for the *thousands* of files that I get a "can't write, error - 1128 (path too long)" error for.


NTFS has a filename limit of 255 characters (for the ascii chars that I use) and a path length limit of 32767. http://en.wikipedia.org/wiki/NTFS


Either way, I am trying to restore a backup from an identical file system and it should work. I am absolutely surprised and shocked that Retrospect has this bug. I cannot believe that I have trusted it for all this time with critical data.


Is there a work around?


Dantz/EMC may reply "it is an error from an OS system call to make the folder". Well, clearly Dantz/EMC don't know what they are doing then. One has to make each folder in the path separately for paths longer than the system call limit.


Biggest lesson for me: I have to do complete restores on a regular basis to test backup reliability if you are using EMC/Dantz "backup" software.




Link to comment
Share on other sites

HD 2.0.145 is not compatible with Vista 64 bit. You should be using HD 2.5. You are not even using a version that is vista 32 bit compatible.


We know that Retrospect can handle this error better then it does and we will be making a bug fix to prevent the restore from failing in this situation. The restore should never stop just because of this error.


Either way, Retrospect is displaying an error message reported to Retrospect by the operating system when a file system call is issued to create a file in this long path.

Link to comment
Share on other sites

32 bit applications run on 64 bit Vista will run in WOW (Windows on Windows), which is designed to provide a 32 bit Windows environment to the application. As far as I can tell, Microsoft's WOW works.


Has this bug been fixed in v 2.5 of HD (and other retrospect products)?


If not, when will it be scheduled to be fixed?






Link to comment
Share on other sites

Searching the forum, I found this bug reported as far back as 11-19-04.


Dantz has had about 4 years to fix it. Instead, the repeated claim is that the users are doing something wrong or that Microsoft is broken.


The problem is that the Dantz programmer who wrote the code to do restores made a mistake.


These long paths are legal and nothing in the Microsoft system calls is broken. Retrospect needs to make the folder hierarchy in a recursive manner rather than attempt to make a long path in one shot.


When is Dantz going to fix this bug?


For the thousands of users of Retrospect HD software, they and the hard drive makers should know that Retrospect is not a suitable backup product, i.e. it will fail to restore backed up files (no error is thrown on the creation of the backup, only on the restore!).


Yeah, I'm pretty disgusted. (Will you edit/censor this post as well?)




Link to comment
Share on other sites

Doing a bit of research, it appears that the correct way to create long paths is to use the unicode versions of the system calls with a special character sequence prepended to the path. For more details (give this to the Dantz developers):






Quoting from the first link:


"In the ANSI version of this function, the name is limited to MAX_PATH characters. To extend this limit to 32,767 wide characters, call the Unicode version of the function and prepend "\\?\" to the path. For more information, see Naming a File."


"Naming a File" is the second link.





Link to comment
Share on other sites

Retrospect needs to make the folder hierarchy in a recursive manner rather than attempt to make a long path in one shot.


This might be true, but I am not a programmer and do not know what is possible and what the limitations are based on the actual file system calls available to Retrospect. Your research is appreciated and I will add it to our bug report. I can say for sure that no bug fixes will take place before our next planned product release. I do not know when that is scheduled to happen.

Link to comment
Share on other sites

  • 5 months later...

I have been encountering this error on my retrsopect HD recently when attemtpting to restore a file or a directory of files.


After reviewing the forums and knowledge base, it appears this is a known bug for some time on Restrospect HD, and has (apparantly?) been correct for full Retrospect users late 2008. If I read correctly, the bug fix skips over the files with the error, but does not actually restore those files (please correct me on this if Im wrong) for the full retrospect software.


Has this bug been corrected for HD users? If so does version 2.5 specfically fix this bug? What exactly is the bug fix? I tried to find release notes for 2.5 and was unable to do so.


I would agree with SurprisedUser that given the many years this has been around, if a fix is not available that it seriously undermines the value, integrity and usefulness of the product to users and hardware manufacturers that continue to distribute HD bundled with drives.


Please advise if version 2.5 will fix this particular bug or not. Also, if there are release notes indicating what 2.5 fixes/ updates are included, I would appreciate a copy.


PS I am running windows XP with latest service packs / updates. Error only encountered on restore.

Link to comment
Share on other sites

  • 3 weeks later...



i tried using retrospect express (and hd) both in the current version.


both randomly crash, and on retrospect express hd (2.5) im getting the same error as my precessor.


1128 - path to long. only difference, this happens when i try to create the backup -> copying from hd to backup.


im using vista 64bit. is there any solution avaible?

it's quite annoying, as i'd like to backup my harddrive.


cheers, gordon

Link to comment
Share on other sites

hi mayoff,


thanks for the information. im currently trying to install the update. i've to say its not to easy. the integrated update function does'nt work, as it apparently can't shutdown the process.


and for some reason the integrated download function got apparently a connection problem sometimes and just 'cancels' without any notification. quite annoying.


still im currently downloading the update with a download manager.



in any case - will the path problem be solved somewhat soon? if i understand the changelog correctly, the changes made, are only in the processing of the error, not preventing it.

i've to say, that i'd rather like to have my files completly backed up, instead of knowing, that some files could'nt be backed up as the software lacks the ability to process the path's correctly.


once again, thanks for your help - with best regards, gordon

Link to comment
Share on other sites

  • 2 months later...

Hi Robin,


We are using exactly the same version 7.6.123 and we still get those "path too long" errors under Vista.


Is there anything I can do or suggest to remedy this?


My colleagues are losing confidence in Retrospect as a trusted backup solution, and I have run out of answers.

Link to comment
Share on other sites

  • 1 year later...

I made a backup using Vista. Than changed to Windows 7. If I now try to rebuild the catalog, on saving, I get the error: folder inacessable, path is too long. Have tried everything, EMC says its an OS problem, MS does not agree. Please advise, thanks, Whisky(Andre)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...