Jump to content

Update to 2.5 issue

Mr Hyde

Recommended Posts

Hi. I"m hoping someone can help me out here. Today when I turned on my computer I got a notification that there was a Express HD upgrade available so I clicked the message and was brought to a download page. I downloaded the installer to my desktop then ran it and nothing happened. I ran it again and I was asked with two seperate boxes if I wanted to replace files that already existed so I said yes then nothing happened. I ran Retrospect Experss HD and it's still reporting that it is version 2.0(something)


any suggestions

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...