Jump to content

Topic Split: SQl Agent Authentication


Recommended Posts



I'm also having the SQL authentication problem. I'm using:


Retrospect MultiServer 7.6.111 on a Windows 2003 32bit R2 SP2 w/latest updates.


Restrospect Client is 7.6.106 on Windows 2003 32bit SP2 w/lastest update. SQL Server 2005 Std. SP2 w/latest updates.


The SQL Server is on a different Domain than the backup server and uses Mix Mode authentication. All servers on both domain's are able to be backed up without problem except the SQL databases. I'm relying now on maintenance plan backups and then retrospect backing up those files. I have a license for SQL Agent and have assigned it to this server.


I have tried most of the suggestion listed here except the one where I would have to use new Retrospect Configuration, I really wouldn't want to setup all of my backups again.


I forgot the client and added it back.


I removed the client again and the license from Retrospect, then added them both back.


I tired the Domain Admin account for that Domain and the sa account for the SQL Server. I can login remotely with any of these logins I just listed through SSMS (SQL Server Management Studio).


Never renamed the machine so that registry entry already has the correct machine name in it.


The SQL install was a full installation so there are no components missing for the SQL Engine. It also has Analysis and Reporting Services installed.


At one time there were 18 separate SQL Instances on the machine and all of them were being backed up through Retrospect. I consolidated all 18 instances databases into 1 instance (default) back in March. I then uninstalled all the remaining instances. It was at that time it seems that Retrospect stopped backing up the databases, I just noticed this a few days ago.


When I consolidated the instances into 1 I edited the the Managed Script for the machine and it seemed to work by pulling up the databases in the 1 instance.


Could all those instances installed and then removed have something to do with this? If so are there any suggestions on how to resolve this?


Is there something else I can try besides rebuilding the entire backup server or Retrospect Configuration?



Link to comment
Share on other sites

Thanks again for the quick reply and it turned out I was missing a component.


It was the SQL Server 2005 Backward Compatibility. It seems when doing a repair or modify installation of SQL this option doesn't show it head.


I tried our test sql server after setting the SQL agent license to it and it worked like a charm. So i set the license back to our production server and started to compare the two machines.


In Add/Remove Programs of the machine "Microsoft SQL Server 2005 Backward compatibility" should show up. It did on the test server but not on the production.


On the production server I opened the Setup folder on the install CD. Right clicked on the "SQLServer2005_BC.msi" file and selected repair. I got an error saying it wasn't installed so I then selected the Install option. After the install retrospect can login and see all of its databases.


FYI for anyone else having this problem. That component is installed when installing workstation components but not when trying to repair the workstation components. Like I said before it should show up in the Add/Remove Programs Control Panel. If its not there then something messed up it's registry settings or its not installed at all. That's why I tried to use the "Repair" option first.

Edited by Guest
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...