Jump to content

Retrosepct Server packed in!

Recommended Posts

Ugh! This will teach me to stop babysitting this system...


For some reason retrospect is refusing to kick-off anby backup routines right now, and it's starting to get frustrating!


I noticed a pro-active backup wasn't responding, so went to check the backup sets where it notified me that it was corrupt or seriously damaged. So I spent most of today repairing this thing (we back up ~400GB to a 500GB SATA drives).


Once done, tried again, still no use! So now I have wiped the catalogue file and the hard drive.. and guess what?! It's STILL not backing up.


My system is a fully updated Retrospect 7.5 Multi-Server with a value pack bolted on for exchange and sql plugins etc. It's running on Windows XP Professional.


The software is sitting on a 1U rack Supermicro server, which has 4 drive backs (all SATA). Two are RAID1 for the OS / programs. The other two are hotswapped daily to put the correct drive in for Retrospect.


Any ideas before I blitz this whole server and do a ground up rebuild?


It worked just fine until recently, so I guess something is corrupt 'somewhere'. I have uninstalled and reinstalled Retrospect too, to rule out anything funny there.


It's odd as both the catalog and destination files/drives are 100% clean.. Retrospect is also refusing to close, it hangs on 'Exiting'.. so I have to crash the app each time. Grr!



Link to comment
Share on other sites

Thanks for coming back to me so quick Mayoff.


When I fire off a 'normal' scheduled backup manually it seems to kick-off fine, although have not had time to get it to backup entirely yet due to the large amounts of data. To me, this rules out the destination drive as the culprit.


It's doing something strange though.. when you view what data is being backed up in the Executing tab it seems to 'jump out' of being selected after a while - like it's trying to do something elsewhere Sorry, this probably doesn't make much sense. I'm sure I could leave it clicked on te Execuring job and it would stay displaying the progress info..?


The proactive script isn't having any of it though, it's just sitting there saying 'Checking media'. These proactive backs go onto two drives.. a daily rotated drive and also a static drive for user self recovery. It's not backing up to either drive.


I've also now build a new proactive script (using same filter and destinations) and it still doesn't work :(


I'm not sure what defer mode is? There are no scripts in the waiting tab and I don't have the 'pause' button press...





Link to comment
Share on other sites

If the proactive backup reports "media" then the script is unable to find the catalog file, or it can not find a destination with free space.


You can try clearing the Backup Report under Reports>Backup Report. You will find an option to clear the report. This will reset a lot of proactive backup settings.

Link to comment
Share on other sites

Well that's me stumped then...


The catalogue files on both the destinations are brand new and the drives are wiped (I even manually deleted the catalogues to make sure they weren't hangingin around and corrupting the new one).


I'm now running server backups onto these drives just to check everything is A1 - which should identify something broken with the proactive process only (i.e. neither the drive or the catalogue files).


The only logs are "Script Proactive Backup: waiting for media".


Hmm, very odd.


edit: I've cleared the logs, although will restart Retrospect to see if makes any difference. With my understanding the proactive backup should be saying 'destination busy' or such like right now - but it's not, just 'chekcing media'?!



Edited by Guest
Link to comment
Share on other sites

Ah! I think I've spotted the culprit!


by going into the Proactive Activity Monitor and selecting 'Backup Sets' view.. it shows Fridays backup is wating for the Media!


However, my problem still remains, I can't stop proactive and I've even deleted the Friday Proactive script and it still remains :(



Link to comment
Share on other sites

If you have deleted the script (It does not show under Automate>proactive Backup) then you could have corrupt preferences.


Try picking the Pause/Defer button to stop all activity. If this doesn't work, force quit Retrospect. Reopen and immediately click the Pause/defer button. Make sure the script is still deleted.


Worst case, you may need to delete the config75.dat file.




Link to comment
Share on other sites

Spoke too soon.. this thing is shafted!


It's now backing up to my 'daily' disk.. however, as soon as I configured it to backup to my 'online_disk' is did the same thing 'checking media'.


If in the proactive tab I choose scripts, it shows:


Wed - Active

Thur - Inactive

Fri - Inactive

Mon - Busy


No thursday at all...


Only todays script is set to run, so I have no idea why Mondays script is 'busy'?!



Link to comment
Share on other sites

Ah! Right, I might be getting somewhere now - sorry for all these updates!


I removed all the Retro 7.0 files, and just restroed the config75.bak file which seemed to lauch fine in Retrospect 7.5 - with just the proactive settings missing.


I have rebuilt todays script now and it's look 'ok' thus far.


None of my drives are network drives, just one is a USB drive which holds the online recovery files (as the daily backup drives are taken away over night)



Edited by Guest
Link to comment
Share on other sites

Nope - broken again. It backed up two clients (perfectly) and then reverted to as it was - broken.


Crashed it and re-launched it. Clicked stop all operations... checked the correct names of scripts are in place. (All fine)


Then started the scripts again and the proactive tab says 'polling'.. then says 'Checking media' then flicks to the Executing tab (where nothing happens).


This is becoming VERY annoying now as I can't back up any client machines.



Edited by Guest
Link to comment
Share on other sites

The backup sets drop down shows


Monday - [nothing]

Tuesday - [nothing]

Wednesday -[nothing]

Thursday - [nothing]

Friday - Media

Online - Ready


I have no idea why it's trying to do something with the Friday disk! (Triple checked the schedule)


The Scripts drop down says:


Monday - Inactive

Tuesday - Inactive

Wednesday - Active

Thursday - Inactive

Friday - Inactive


Which is right. If I was in the office I'd shove the Friday disk in and see if that helps - but I'm at home ill right now :(



Edited by Guest
Link to comment
Share on other sites

config75.dat and its backup, config75.bak contain retrospect config info such as...


License, preferences, scripts, catalog file location, execution history, event history, auto-login info, and the info which retrospect uses to decide if it is your first time using certain functions to display wizards.(I may be forgetting some)


It will not delete the actual catalog files, or operations log, or any backed up data.


If you are starting from scratch, and are looking for your catalog files, than unless you chose other than default your catalog files should be in the following folder.



C:\Documents and Settings\(your user name)\My Documents\Retrospect Catalog Files



C:\Users\(your user name)\Documents\Retrospect Catalog Files\



Get well soon!


Link to comment
Share on other sites

"Then started the scripts again and the proactive tab says 'polling'.. then says 'Checking media' then flicks to the Executing tab (where nothing happens)."



When it goes into the execution tab it should create an operations log. What does this log say?

Edited by Guest
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...