Jump to content

Some databases show - others consistently don't


Recommended Posts

My apologies up front to any who are tired of answering this question - but...


Using 7.5 to back up the SQL server on my single SBS2003R2 server (with all appropriate licenses and permissions), the SQL container shows up only with Master, Model, and MSDB databases. The ones I care about don't show up on the list. I've tried many of the suggestions in other posts, but most of them seem to address the SQL container not showing up at all, which is not relevant in my case. I'm sure it's something I'm missing, and I'm sure somebody knows what it is...

Link to comment
Share on other sites

As I gleaned from another post, the Retrospect Backup User has been included as a domain admin, a domain user, a backup admin, and a local admin (which did enable the Exchange backup, which was good), and the authentication is by domain (using the Retrospect Backup User). The system databases show up, but not any others.

Link to comment
Share on other sites

So... In the event log, corresponding to the Retrospect backup attempt, this error shows up:


Event Type: Error

Event Source: SQLVDI

Event Category: None

Event ID: 1


Computer: SBSRV01

Description: SQLVDI: Loc=IdentifySQLServer. Desc=MSSQL$SBSRV01. ErrorCode=(1060)The specified service does not exist as an installed service...




And there is in fact no service MSSQL$SBSRV01 (where SBSRV01 is the server name). There are instead several MSSQL$[insert database name here] services. I can successfully back up any of the databases from within SQL Server Management. Is there a way to configure Retrospect to handle this?

Link to comment
Share on other sites

  • 3 weeks later...

Still trying to figure this one out - and something occurred to me while staring at the screen for the umpteenth time: The missing databases are all separate SQL instances. So now the question becomes whether I can back up separate instances, or if not (which would be "bad") how can I specifiy which one is included (there is one of these missing db's that I am most concerned about - if I had to, the others could disappear without much heartache).

Link to comment
Share on other sites

  • 1 month later...

Don't interpret me as being pushy - or anxious... But... Retrospect (with the most recent updates) is still only picking up the system databases "master", "model", and "msdb". I ran through the steps above, with no change in behavior. If anybody has any ideas where to go next, let me know (and go ahead and assume I'm missing something obvious - since I probably am :-)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...