Jump to content

Not enough application memory


Recommended Posts

Hi All


We are suddenly having a problem with one of our backups. Running Retrospect 5.15 on a win2k server.


Every night the server backs up 5 volumes (incremental backup). Its gets as far as counting(?) the files its needs to copy for the 1st volume and then stops. The error in the operations log is "Not enough application memory". The machine has 2.5GB of RAM and plenty of free space on the OS drive. At the last attempt, there were 8814 files needed to backup (9.8GB)


As a test I tried to backup the whole volume to a new set, again it counted all the files but stopped with the same error in the log (335616 files this time 339.4GB). As another test I tried to backup one of the other volumes on the server to a test set and it began backing up successfully. I have also restarted the server in case that was it.


Can anyone shed some light? There seems to be very little reports of this error in the forums.


Appreciate any assistance, if you need any more info please let me know.




Link to comment
Share on other sites

Hi Mayoff


I am just downloading the trial now. Problem is the tapes are 40/80 DLTs and there is over 400GB to be backed up so if I have to start all the sets over (5 sets, mon, tue, wed, etc.) it will take weeks before I have them all set up.


Also, if we upgrade and are unable to recover files from the old sets it will be a disaster! Any idea if this will work?


Thanks again


Link to comment
Share on other sites

  • 3 weeks later...

I got this problem the first time 20/02/08. The Catalog file went corrupt. Recreation of Catalog file failed. 3 weeks of backups were lost.


I am not sure if the problem is on the server to be backup up or the server where Retrospect is running.


Problem returned today. This time Catalog file is ok.


Added Microsoft Security pathes, IE7, Silverlight, 21/02/08, i.e. one day after the first time the problem appeared.


McAfee patch 16 is not recommended for servers, and is not installed on this server, only patch 15. And On-access scanner is not running.


Could it the large number of files for this partition: over 6,000,000 be a problem?


Any hint would be appreciated.

Link to comment
Share on other sites

  • 1 year later...

Retrospect has been tested with up to 4 million files in a single volume.


1) You should probably have at least 3 gigs of RAM. Retrospect is a 32 bit app so it won't use more then 2 GB for itself.


2) Retrospect will cache a lot of data to the hard disk when memory is low. I would suggest you have at least 20 to 30 GB of free space on the C: disk when working with a high number of files.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...