Jump to content

OS X Client always OFF after restart


Recommended Posts

I run the Retrospect Client 5.0.528 under OS X 10.1.5. The whole backup procedure runs smoothly, the only problem I have is that everytime I have to restart/start-up the client machine, the Client app’s radio button is reverted to OFF. If I then don't keep in mind to turn the Client back on, no backups are made.

 

 

 

Is this a bug?

Link to comment
Share on other sites

Check that you don't have the Retrospect client for older versions loading in your Classic system. Remove the Retrospect Client file from your OS 9 System Folder/Control Panel. Does this help?

 

 

 

If not, make sure that the first interface in your OS X Network Preferences pane is the one that you want to use with Retrospect.

 

 

 

Irena Solomon

 

Dantz Tech Support

Link to comment
Share on other sites

  • 2 weeks later...

I have the same problem.

 

 

 

I obtained Retrospect 5 Server almost the day it was announced, but I first installed and used it today. I installed it, upgraded it to build 205, put in the just-released RDU 2.8, launched it for the first time and gave it my license code, and allowed it to import from my 4.3 configuration. I then deleted the old client license codes from the configuration since they were shown as zero-packs.

 

 

 

The Server is running on a G3/300 Desktop (Gossamer) machine with ATA ZIP-100 drive and two disks, running MacOS 9.2.2, having a fast ethernet PCI card, 768 MB of main memory, and an Adaptec 3940 SCSI card attached to an AIT-1 Sony SDX-300C tape drive.

 

 

 

I have installed MacOS X 10.1.5 on two client system, which also are completely up-to-date via protected Software Update including QuickTime 6. Both systems exhibit this problem. (None of my Mac OS 9 clients have shown any trouble so far.) On both systems, I have dragged the Retrospect Client.app bundle from the directory /Applications/Retrospect Client to /Applications. The client version is 5.0.528.

 

 

 

The first system is a PB g3/400 Firewire (Pismo). I installed it logged in as admin, which at no time demanded that I reauthorize to make the installation as every other MacOS X installer of this sort has done. When I tried to launch Retrospect Client, it told me that it didn't have root privileges, and declined to run. I then fixed its privileges with the following command line

 

 

 

chown -R root /Applications/Retrospect\ Client.app

 

 

 

Thereafter, it runs fine, but it always comes up off after a reboot.

 

 

 

The second system is an earlier G3/266 Desktop (Gossamer) with SCSI ZIP-100 drive and only supporting one internal IDE disk. When I installed it, I first enabled the root account, using /Applications/Utilities/Netinfo Manager, then logged in as root. I then ran the installer. When I launched the application, without rebooting, I logged back in as admin (not root). It showed the Client as off, plus the server couldn't find it, so I turned the client on, and then ran a backup, which seemed to work just fine. But when I rebooted, once again, it was off.

 

 

 

1) The installer is not a standard Mac OS X installer. The thing it installs is a real Mac OS X application complete with subdirectories, not a Carbon file with a resource fork. It appears not to conform to the standards for a MacOS X installer.

 

 

 

2) I can't find anything under /System/Library/StartupItems or under /etc for that matter that looks like it would launch the pitond process. This probably just means I don't know where or how to look, but unless there is some initialization hook, it's clear I'll have to manually enable the client for every bootload.

 

 

 

I'm guessing this is an installer problem, but since I only installed it today after paying for it when it came out, a couple of months ago, a customer service prevention person gently explained to me that they will not help me unless I buy an incident. So I am posting this here in the hope that someone with more sense than that might realize that this is a real problem. (The first time I tried to look at this forum it didn't work, so I used the phone; the next attempt worked for no difference that I could see, so I found this thread.)

 

 

 

I'm going to be very unimpressed if it's because I moved the application to a different directory. I'll test that next on a third Mac OS X client. I think I want to put it in Utilities rather than in Applications, so it'll move again, most likely.

 

 

 

-- Spencer

Link to comment
Share on other sites

The client installer should install a startup script into the /Library/StartupItems/RetroClient/ folder. If you look at this script you'll see the path to pitond is hard-coded to the /Applications/Retrospect Client/... folder. Because it's hard coded, it makes sense that pitond does not startup if you've moved Retorospect Client.app to a different folder other than the default (I guess that's why you don't get the choice as to where the client is installed).

 

 

 

Cheers

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...