Jump to content

chronic -645 chunk file damaged during save. retro 7.5, with 'fix'

Recommended Posts

it went something like:


1. corrupt config75.dat - lost client and backup sets.

2. recovered previous config75.dat from backup.

3. all local HD backups then reported " -645 chunk file damaged during save" error.

4. removed config75.dat and .bak then rebooted. relicenced and started from scratch (one empty backup set, one new script). same errors only - no complete execution of backup of local HDs.


lots of KB reading and forum browsing later, still no solution. couple of gems in the KBs, which I might post for fun on another post, but not worth the effort re fixing this problem.


let filemon and regedit loose on the problem (www.sysinternals.com - now MS owned). showed a bunch of .dat files in the folder:


all users\application\retrospect\rtrsec.dir\


and "my computer.dat" being accessed extensively during each failed execution.


we had nothing to lose, as next step was full uninstall, wipe and reinstall, so we shut down retrospect, and dumped the rtrsec.dir folder, and the rtrexec.dir folder for good measure.


restarted and the script finally executed to completion.


seems the corruption was in the 'my computer.dat' file (310MB), and not the config75.dat as most of the KB and forum threads indicated.


I think I would be inclined to move this folder first in similar circumstances, rather than dump your client and backup set configurations (config75.dat). you can always put it back again if there is no joy.


hope this saves someone more time than the KB did me.




Link to comment
Share on other sites

  • 3 months later...
  • 2 months later...
  • 10 months later...
  • 2 weeks later...
Thank you - had the same error scanning a volume. Went to the directory and deleted the .dat file for that volume and it worked great


I'm suffering the same problem. I keep getting these emails from all but one of my four nightly backup sets:


"From Retrospect: Script "User DIR 2 tape" failed during automatic execution, error -645 (chunk file damaged during save). Please launch Retrospect and check the log for details."


Just to clarify. You guys are removing this file:

C:\Documents and Settings\All Users\Application Data\Retrospect\RtrSec.dir\machinename.dat


Then do you just re-launch retrospect and it recreates the file? Didn't their phone support used to be open until 4p.m. PST? I called today at 3:30 p.m. PST and was blown away to find them closed.


Any help would be appreciated, thanks.

Link to comment
Share on other sites

  • 10 months later...

Why is is so hard to find the -645 errors on the EMC support site. A google search brought me to this thread.


Yes it's not the CONFIGxx.dat that is the problem, it is the DAY that matches the backup set name. Delete it, make sure the backup set member is not set to ignore and boom, you are back in business.

Link to comment
Share on other sites

  • 1 month later...

This thread gave me hope, however purging my entire 'RtrSec.dir' and creating anew, the same "-645 chunk checksum didn't match" error continues to bomb on every volume and client.


Reluctantly I've resorted to clearing my entire 'ProgramData\Retrospect' dir, re-licensing and have began the process of recreating all our Exchange/SQL/server/workstation scripts, selections and disk/tape backup sets.


Any updates to this issue are greatly appreciated; from my history with this product, I

have a feeling we will be back here again soon.


Retrospect Server:

Windows Server 2008 R2 SP0 x64 running Retrospect v7.7.208 (64-bit)




Link to comment
Share on other sites

  • 1 year later...

After years of operation I recently got this -645 chunk file damaged error and as suggested deleting and recreating the config76.dat file did not help.


I also had a hard time searching in these forums for any other suggestions but after a lot of browsing I came across your post. THANK YOU! Your suggestion fixed it!


In my case it seems the issue was "My Network Places.dat" in the RtrSec.dir and it recreated it after moving all the files out of this directory (leaving it empty).


Now I wish there was a good fix for the random corruption of catalog files after grooming, I would be all set. :-)



  • Like 1
Link to comment
Share on other sites

  • 2 months later...

Congratulations to lewis for coming up with a great solution to that specific error! It worked out perfectly and saved me a lot of time. I deleted the dat file of the particular server with the error from the RtrSec folder and it corrected the problem. The first backup took a lot longer because of the rebuild, but no errors. My thread here http://forums.retrospect.com/index.php?/topic/147876-error-645/



Link to comment
Share on other sites

  • 7 months later...

Just happened to me too: yesterday, I found my trusty Retrospect asking for its licence code... In fact, it was the config77.dat file that got corrupted overnight. It was quite big (500 Mb) because of several failed backups with lots of errors on missing files during the last month.


I followed the instructions here : Retrospect is asking me to re-type my license code and was able to restart Retrospect with all my scripts and planned executions etc... I also removed the big log entries from the history view.


And then, I noticed that the backups of my server failed with a -645 error: I followed the instructions in this post, and everything looks well now: thanks a lot for the ideas !


I am using a Retrospect 7.7.620 running on Windows 2003 SBS.


It might be a good idea to have a separate storage file for scripts and log entries... plz Retrospect devs :-)


I also wonder what those files in the RtrSec.dir are for: what do they keep, and why do they grow up in time: the one I deleted was 1,3 Gb big !




Link to comment
Share on other sites

  • 10 months later...

This has been plaguing me for a while, thanks! Deleting the "My Computer.dat" file was the fix for me, as only the local computer was failing, not any of the others. It was over 2 GB in size. I also found a 4GB .dat file from a server that was decommissioned long ago, so I got rid of that as well. This has been added to my bag of tricks in Evernote. I manage Retrospect installations for several clients, so this is bound to come up again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...