Jump to content

Suddenly: No tape or optical storage devices found

Recommended Posts

I've been using Retrospect 7.5 on WinXP SP2 for quite some time - most of my backups are disk-to-disk, but I take a periodic archive to DVD. This has worked fine for quite a while, but today when I went to perform the archive Retrospect's Storage Device panel reports "No tape or optical storage devices found".


On the "Environment" tab it at least shows that it sees my "Toshiba DVDW/HD TS-L802A" version HP18, but it won't let me configure it. It does NOT show my USB-attached "TSSTcorp CD/DVDW SH-S182M" any longer. I've used both drives for backups in the past.


Nothing in my hardware configuration has been changed. From a software standpoint, the only thing I can recall changing recently was Retrospect itself - there were recent patches applied and it's now running at version 7.5.387 with driver update/hot fix at These patches definitely went on AFTER the last successful optical backup - I'm not saying they're to blame, but I can't think of anything else that's changed aside from Redmond's usual patch cycles.


Any suggestions on how to get Retrospect to see my two optical drives again?

Link to comment
Share on other sites

  • 2 weeks later...

I'm having a similar problem. I'm running Vista Premium and my device screen looks like this:




The dots are in the location where I would expect my IDE connected DVD drive to appear. Any ideas how to get this working again? I don't think I've used the DVD drive since installing Vista, but it worked fine with XP for quite a while...

Link to comment
Share on other sites

Just a random guess, K ... is it possible that something has latched onto the drive (perhaps even Vista itself)? Is Retrospect "ignoring" that drive? You can check for the latter by right-clicking the drive on the Device screen.


If it is simply being ignored, be aware that you can't just unignore it and refresh the screen - in another thread, TDUShane posted his discovery that when you change the ignore status you have to actually exit Retrospect and restart it for that change to take effect.

Link to comment
Share on other sites

I've resolved the problem, but it's not an ideal answer by any stretch!


I uninstalled and re-installed Retrospect 7.5, using my original install source file (Retro-EN_7_5_251.exe) and a recent but not overly recent update file (Retro-EN_7_5_324au.exe). That brings my install to 7.5.324 with Driver Update/Hot Fix Retrospect immediately saw both DVD writers fine - one needs to be configured, the other was already configured and ready to run, and it's doing a backup set transfer at this very moment.


It would appear I was right in my original post - the most recent patches I had applied to Retrospect which brought it to version 7.5.387 with driver update/hot fix at appear to have broken it. I don't like running below current patches if I can help it, so I'll try upgrading again one step at a time (after this backup finishes!) to try to determine exactly where the break occurs.

Link to comment
Share on other sites

Thanks for the reply. I did check those things. Vista may have it locked, but I wouldn't know how to unlock it - I don't have anything ready to be written to CD, it doesn't have a blank CD in it when I start Retrospect, etc. I am able to use the drive to write to CD/DVDs with other programs. I did ignore the drive, then exited, came back, unignored it, exited and restarted again and it does the same asterisk thing. Maybe if I get time, I'll do what you've done and uninstall to get back to an earlier version. Let me know how your testing turns out if you do it...

Link to comment
Share on other sites

KD7LRJ, I've struggled with the very same problem since my upgrade to Vista. I never had an issue under XP but, once I installed Vista, Retrospect stopped recognizing both of my optical drives. An e-mail to the kind folks at EMC Insignia has been left unanswered for a couple months now, and we have seen one update pushed which has not solved the problem.


I have only been able to find one solution to the problem on these forums. Unfortunately, I can't find the thread anymore to reference you there, but someone had discovered that switching the primary and secondary IDE channels resulted in Retrospect being able to detect their optical drives once more. In other words, connect your optical devices to the primary IDE and your hard drives to the secondary IDE channel. It does appear to work, however I find it extremely frustrating as I do not want to keep my hard drives connected to the secondary IDE channel all the time even though there aren't supposed to be any real issues in doing this.


Hope that helps, and if anyone out there has a real solution to the problem--I consider the above technique to be a workaround, not a solution--please share.

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...

I don't have an answer, but I do have some more information on this.


To recap: WinXP SP2, Retrospect 7.5, (update 324 I think, I'm not at the machine right now).


Symptom: Previously-working optical drives simply vanish off the device manager in Retrospect. The drives are still physically present and work fine with all other apps.


Here's what I've recently discovered: if I install the latest update, for which I saved the executable, I can run Retrospect EXACTLY ONCE and see/use the optical drives (with no configuration needed) during that session. Once I close Retrospect, the optical drives are never visible again in Retrospect until I re-install the latest update again. Then they'll work again, once. Lather, rinse, repeat!


To put it graphically:


Optical drives invisible

1) Run latest update

2) Run Retrospect

Drives visible! Usable for backup/restore!

3) Close & rerun Retrospect

Optical drives invisible (return to top!)


Note that no reboots are necessary anywhere in this cycle.


What I haven't been able to determine is what is changing between 1, 2 and 3. There must be something in either the file system or the registry that is being changed and causing the breakage, but using both active monitoring (SysInternals filemon & regmon) and before/after comparisons I haven't been able to determine what it is, yet.


I would certainly be interested if other people are seeing the same thing - if so, and you're willing to poke at it, maybe you can uncover whatever I've missed so far.

Link to comment
Share on other sites

  • 3 weeks later...

More info, and I've finally resolved this to my satisfaction so I won't be experimenting any further.


The problem turns out to be an interaction between Retrospect and the "Retrospect Launcher" service (retrorun.exe). Looking at this with Process Explorer I was able to see that the Retrospect GUI runs _under_ the launcher service, even if you start the GUI manually. When Retrospect runs under the launcher service, the optical devices vanish. Killing the launcher service (via task list, net stop "retrospect launcher", etc.) allows Retrospect to run on its own and the optical devices are visible.


The weirdness around installation is easy to understand now - the install terminates the launcher service. The first Retrospect run after that is running on its own, so it sees the devices fine, but it ALSO starts the service itself, so the next run occurs under the launcher and misses the devices.


Now, here's the fun part - the retrorun service was running under the SYSTEM credentials. I have Retrospect setup to always run under my administrator id. By switching the launcher to also run under my admin id, the problem is resolved - even running under the service, optical devices remain visible.


I would advise folks having problems with their optical devices vanishing or never being visible check the credentials under which Retrospect itself and the Retrospect Launcher service are running - therein may lie your problem!

Link to comment
Share on other sites

  • 6 months later...



You have done a sterling job in resolving the issue, thanks for such detailed posts. I had hoped it would work for me. Unfortunately I have the same problem of DVD writer and Quantum DLT-V4 not being recognised, but the solutions above don’t work on my system. Vista Ultimate SP1, Quantum DLT-V4.


I tried loading version 7.5.251 as suggested above – and the stars were replaced by the name and version of the DVD drive and the Tape drive. But it will not recognise either as a backup device, it is also not Vista compatible. Loading any later versions and the drivers are stared out, whether from clean install or an upgrade.


I have tried your trick with privileges but that has not worked for me.


I currently have Vista Ultimate SP1, Retrospect 7.5.08, Drivers installed.


Is there another solution to this problem, that anyone has found. It would be nice if EMC told us the solution or issued an update that makes the problem go away. Tape drive disappearing seems to be a regular problem after version updates.




Link to comment
Share on other sites

I decided to go back to XP Pro SP3 because other software worth many thousands of pounds sterling would not work on Vista because Vista does not allow direct access to hardware - Suddenly EMC works - so I guess when EMC says Retrospect is Vista compatible - they don't actually mean it.


Retrospect is fantastic, but even after you raise an issue after 5 days after purchase they enforce the 30 day support limit with vengeance, so on day 31 supports stops even though they have not fixed the issue and later I found they knew about 6 months before I bought the software.


Even their technical support don't know that my chipset is not supported 6 months after a forum post pointing it out. Retrospect works beautifully I love it – but then they do an upgrade and it is bust and they simply do not care and I am left worth no backups. I have it working again after 6 months of it not working becuase I bought a new PC – next time this goes wrong I will abandon Retrospect, and use USB disks instead.


My advice is if Retrospect works on your PC DO NOT, DO NOT download any upgrades they have a 90% chance of busting your PC and EMC DO NOT CARE.


They will not help you, they will not admit they know the cause they will no admit it is their fault, just expect you to buy the software again o get support. So EMC Retrospect is fantastic – but their support and care when releasing updates sucks big time.


So my DVD drive and Tape drive that EMC technical support says are faulty, Quantum diagnostic software after 20 minutes of details test says it is ok, I even paid to send it back to Quantium at EMC suggestion, returned it saying it was 100% working, and now I have gone back to an old version of Retrospect on a new PC and guess what they work again - I think Quantum know what they are talking about - EMC just want to shaft you.


So when EMC blame your hardware – tell them they are talking rubbish, and you want a refund - it is a fob off, and =once you have get o 30 days they will to talking to you.


This is not anonymous - my name is Eric


My aim is to make EMC wake up and support their software properly becuase it is a fantastic product when it works. I think it is fantastic, but I am not willing to spend days and days trying to get failed backups to work again, and buy new copies of retrospect just to get useless support. Hard disks are now so cheep I can easily back up to hard disk and do not need tape any more. A 1-tera byte disk that connects through eSata is under £100 inc VAT - and hard disks work - unfortuntley EMC retrospect dose not.


Retrospect - well if it works for you DO NOT, DO NOT, DO NOT upgrade it is likely to break your back up system.


This is so important I will say it again - if you have retrospect working on your PC DO NOT what ever you do upgrade to the lateste EMC release. I will never, never ever again do such a stupid thing.





Link to comment
Share on other sites

Your post is totally off base. As the manager of technical support, I have NEVER heard of an open support incident being close the on day 31 (30 days of free support is always included with the product). It is NOT our policy to end support at a specific day. Support ends when your issue is resolved.


EMC does care. Your original forum post doesn't really provide enough details to help troubleshoot the problem, so I can't even begin to comment what work working under Vista and what was not.


I don't know who you spoke with, but it doesn't sound like you talked to anyone in technical support. I suspect you may have been talking to Customer Service/Sales about a complex technical issue.


Vista vs XP. Most users who have upgraded to Vista have experienced some type of compatibility issue totally unrelated to Retrospect. With a little troubleshooting, any problem with device recognition can be resolved.


Telling users to not download an update to the latest version of Retrospect is just silly. Without the latest updates, you will be skipping bug fixes and improved support for new operating systems.

Edited by Guest
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...