Jump to content

Problems with HP Dat72 USB

Recommended Posts



we're having trouble running Retrospect:


Our hardware-setup:

Mac Pro 2.0, 2 GB RAM, Four Harddrives; HP Dat72 external USB Drive, Other USB-Devices: Apple Keyboard, Logitech Mouse



Mac OS X 10.4.10

Retrospect 6.1.131 (No ACL)

Driver Update


We are running into problems with the drive.

retrospect is saying: error 205 lost access to storage medium

system.log is repeating everytime you try to backup:

USBF: 2961.227 AppleUSBEHCI[0x2753000]::Found a transaction past the completion deadline on bus 253, timing out!


We are using original HP Dat 72 C8010A Tapes

The drive is a new one, we thought of a drive error and exchanged the drive with a new one with no effekt

HP TapeTools did not find any problems with the drive on windows

We used several new tapes


The problems above apeared since 10.4.8 Update. We can't go back because of other software. In times of 10.4.7 the server had problems with kernel-task using all the memory and sudden reboot. therefore i think the problem was existent before, now Apple has changed the handling of such conditions.


We tried several things:

Using older Driver Updates, Using USB Kernel Extensions of 10.4.7, Exchanged the drive as mentioned before, Using a Mac mini for Backup (Same Problem here)

We can't get Retrospect to run correct for more than a few days.

Last thing i've tried: Using another USB-port on the backside of the mac pro. It ran fine a few days, after that error 205 and the same system.log messages again...


Everything else runs fine, i don't know who's to blame: HP, Apple, EMC... frown.gif

Link to comment
Share on other sites

Three comments:


(1) I've seen this timeout message occasionally ever since about 10.4.4 Server on our USB port to which our APC rack-mount UPS is attached to our Xserve G5. Our tape drive and autoloader are SCSI, so this doesn't affect us. Headless, so there are no other USB devices.


(2) why don't you try a powered USB hub to eliminate the possibility that it has something to do with USB power. I have a hard time imagining that the HP DAT would be drawing power from the USB port, but that's the only thing I could suggest.


(3) a new firmware release for that drive was released last month. You don't say what version firmware is in your drive (it should appear in Apple System Profiler and perhaps in Retrospect Configure > Devices). Have you tried updating the drive's firmware?




Link to comment
Share on other sites

thanks for the reply


You're right several servers with direct attached APC UPS show up the same errors. We're selling equinux APC Tracker and it has no effect on functionality of the APC.


I thought of using a powered USB 2.0 Hub but I read several postings about other problems with this configuration. Will try this next time.


Todays setup is a mac mini with this drive and backup over network (instantly running in to "net wait" problem either :-( ). I had to change the kernel extensions regarding USB back to 10.4.7 and now it runs (and can be restarted with no effect to the server) the net wait problem is fixed with deletion of a log-file. crazy enough emc knows this since 2005...


The new firmware (currently ZU5A) for this drive mentions no changes to the USB part. it only changes media and error handling an this was not the problem, but in my desperation i will try this too.



Link to comment
Share on other sites


the net wait problem is fixed with deletion of a log-file. crazy enough emc knows this since 2005...


You need to uninstall and reinstall the Retrospect client, if you are talking about the same bug I also saw and reported over two years ago. A fixed client was distributed almost two years ago at the beginning of October 2005 - I worked as one of the beta testers with Walter Reed at EMC to diagnose/test. There's even been another client update since then. Update your clients and this problem, if it's the same one I saw, should be fixed:

Retrospect Mac updates


Also note that the Client installer still has a SERIOUS security bug that has persisted for several years, and leaves the client "setuid root" with world-writable permissions. See this thread here:

Installer leaves setuid root client world-writable


and my post here with a simple fix to run after installation:

Terminal commands to remove permissions on client



Link to comment
Share on other sites

  • 2 months later...


Any idea how you would downgrade the kernel extension?


The way to downgrade the kernel extension would be either to:


(1) use Pacifist to extract the older kext from the 10.4.7 updater (or the 10.4.4 install DVD), or

(2) use Retrospect to extract the older usb kext from your backups.


While the top level looks fairly old:


rhwimac:~ rhwalker$ ls -ald /System/Library/Extensions/IOUSBFamily.kext

drwxr-xr-x 3 root wheel 102 Mar 26 2005 /System/Library/Extensions/IOUSBFamily.kext

rhwimac:~ rhwalker$

the contents seem to have been modified by the 10.4.10 update:


rhwimac:~ rhwalker$ ls -al /System/Library/Extensions/IOUSBFamily.kext

total 0

drwxr-xr-x 3 root wheel 102 Mar 26 2005 .

drwxr-xr-x 230 root wheel 7820 Sep 21 10:20 ..

drwxr-xr-x 7 root wheel 238 Jun 20 23:18 Contents

rhwimac:~ rhwalker$



Any idea if 10.4.10 has "known" usb issues that Apple is reviewing?


Those who know are probably covered by NDA. I have an open RADAR issue on the Apple Hardware RAID back to 2005 (doesn't flush write cache on graceful power down, only known workaround is to disable write cache). Seems that the bug fixes are prioritized by how many people are complaining and how important the complainer is.


Way to tell would be to file a RADAR report and see if it comes back as a duplicate.

Apple Bug Reporter



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...