Jump to content

Retrospect HD won't connect without password


Recommended Posts

I have Retrspect HD 2 on my laptop with XP Home. I am trying to backup to an external drive (HD) on my desktop (also XP Home).


This has worked for me for a month but a recent backup failed with an error that the connection couldn't be made. When I go through the setup I get an error, "Can't save setup, check the selected drive to make sure there is enought free space and that the user name and password is correct."


This happens no matter which folder on the HD I try to backup to. I don't have password security set up there (nor know how to do it). On the desktop I've set "share to network" and "allow to change files" or whatever. There is plenty of space on the HD.


I can access (and change) the HD backup folders and files with Windows Explorer.


I've unmapped and remapped the HD and folders. Prior to this the HD was mapped to a drive I selected (U). Now it shows up on the desktop as local disk F. From the laptop I've mapped the desktop F drive as U. I've rebooted both machines. I've disconnected and reconnected the HD.


any advice would be greatly appreciated.


Link to comment
Share on other sites

  • 1 year later...

I'm having the same problem with my One Touch III connected via Linksys StorageLink. It was working fine until I replaced my motherboard. I can still access the drive via Explorer, but now I'm getting that password error.


Alternatively, how do I change the password that's been stored.



Link to comment
Share on other sites

Many thanks for your quick response. I finally managed to get another backup to run.


I changed 2 things at the same time so I'm not sure which fixed the problem. Here are the steps I went through:


1) I created a new account in the "admin" group in my Linksys StorageLink app and then did a "Safe Remove" of the hard drive from the router software.

2) Shutdown my computer

3) I turned my One Touch Off

4) Restart the computer, then the One Touch.

5) Went into Retrospect Express and though the setup routine. It asked me for user/password to access the drive (this didn't happen previous to step 1) and I used the new user/password.


I could then start a backup.


My guess is that the problem was solved simply by restarting the drive. I should have tried that sooner in my troubleshooting.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...