Jump to content

Intel Xserve and error -519


Recommended Posts

Hello,

 

This is my setup:

Retrospect Server (6.1.126): running on PowerMac G5

Retrospect Client (6.1.130): the new Intel Xserve. It has two volumes, the startup volume and File sharing volume (using AFP).

the rest of the clients are PPC.

 

When retrospect runs the first volume (startup) has been backed up with no problem, but the second volume (AFP) can not and give us the error -519. this is the only machine and volumes that give me this error. Anybody has any idea what is wrong?

 

thank you,

 

-Popak

Link to comment
Share on other sites

- If you define a small folder on the problem volume as a Subvolume, and use that as a Source, do you get the error?

 

I can not define small folder as when I try to do that, it gives me error 519 as well.

 

- Are the two volumes on different physical hard drives?

 

Yes and the AFP volume is mirrored as well.

 

-Popak

Link to comment
Share on other sites

I just want to add my logs for error 519 that I get, in case anybody can help me with that:

 

This is the log that I recieve from client side and It was in /Library?logs/CrashReporter/retropds.23.crash.log

Date/Time: 2007-01-05 10:54:46.918 -0800

OS Version: 10.4.8 (Build 8N1215)

Report Version: 4

 

Command: retropds.23

Path: /Applications/Retrospect Client.app/Contents/Resources/retropds.23

Parent: pitond [168]

Rosetta: Yes

 

Version: 6.1.130 (6.1.130)

 

PID: 1520

Thread: Unknown

 

Exception: EXC_BAD_ACCESS (0x0001)

Codes: KERN_INVALID_ADDRESS (0x0001) at 0x00505000

 

Thread 0:

0 retropds.23 0xb808a9fc 0xb8000000 + 567804

1 retropds.23 0xb814b703 CallPPCFunctionAtAddressInt + 62193

2 retropds.23 0xb814bbb2 CallPPCFunctionAtAddressInt + 63392

3 retropds.23 0xb80a6073 0xb8000000 + 680051

4 retropds.23 0xb809f925 0xb8000000 + 653605

5 retropds.23 0xb80bd24e 0xb8000000 + 774734

6 retropds.23 0xb811de0d spin_lock_wrapper + 1985

 

Thread 1:

0 retropds.23 0xb82336ab strchr + 72

1 retropds.23 0xb81cef17 pthread_cond_wait + 3114

2 retropds.23 0xb816831a catch_exception_raise_state_identity + 318

3 retropds.23 0xb8167856 CallPPCFunctionAtAddressInt + 177220

4 retropds.23 0xb816774d CallPPCFunctionAtAddressInt + 176955

5 retropds.23 0xb8168418 catch_exception_raise_state_identity + 572

6 retropds.23 0xb8204814 pthread_create + 1124

 

Unknown thread crashed with unknown flavor: 1

state_count: 16

 

Binary Images Description:

0x1000 - 0x1afff retropds.23 /Applications/Retrospect Client.app/Contents/Resources/retropds.23

0x8fc00000 - 0x8fc50fff dyld 46.1 /usr/lib/dyld

0x8fe00000 - 0x8fe49fff dyld 46.1 /usr/lib/dyld

0x90000000 - 0x901c0fff libSystem.B.dylib /usr/lib/libSystem.B.dylib

0x90218000 - 0x9021dfff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib

0x907e6000 - 0x908bdfff com.apple.CoreFoundation 6.4.6 (368.27) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

0x90904000 - 0x90904fff com.apple.CoreServices 10.4 (???) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

0x90906000 - 0x90a0ffff libicucore.A.dylib /usr/lib/libicucore.A.dylib

0x90a60000 - 0x90ae3fff libobjc.A.dylib /usr/lib/libobjc.A.dylib

0x90b0c000 - 0x90b7efff libstdc++.6.dylib /usr/lib/libstdc++.6.dylib

0x90bf1000 - 0x90bfcfff libgcc_s.1.dylib /usr/lib/libgcc_s.1.dylib

0x90c01000 - 0x90c76fff com.apple.framework.IOKit 1.4.6 (???) /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

0x90c8c000 - 0x90ca0fff libauto.dylib /usr/lib/libauto.dylib

0x90ca6000 - 0x90f71fff com.apple.CoreServices.CarbonCore 682.15 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore

0x90fce000 - 0x91047fff com.apple.CoreServices.OSServices 4.1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices

0x9108a000 - 0x910cbfff com.apple.CFNetwork 129.19 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork

0x910df000 - 0x910f3fff com.apple.WebServices 1.1.3 (1.1.0) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/WebServicesCore.framework/Versions/A/WebServicesCore

0x910ff000 - 0x91190fff com.apple.SearchKit 1.0.5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit

0x911cc000 - 0x911ecfff com.apple.Metadata 10.4.4 (121.36) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata

0x911f9000 - 0x91208fff libz.1.dylib /usr/lib/libz.1.dylib

0x9120b000 - 0x913c0fff com.apple.security 4.5.2 (29774) /System/Library/Frameworks/Security.framework/Versions/A/Security

0x914bd000 - 0x914c6fff com.apple.DiskArbitration 2.1.1 /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

0x914cd000 - 0x914f5fff com.apple.SystemConfiguration 1.8.6 /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration

0x9b8de000 - 0x9b8e0fff Interposers.dylib /usr/libexec/oah/Shims/Interposers.dylib

0xb8000000 - 0xb82d9fff retropds.23 /Applications/Retrospect Client.app/Contents/Resources/retropds.23

 

Translated Code Information:

 

Rosetta Version: 17.15

Args: /Applications/Retrospect Client.app/Contents/Resources/retropds.23

Exception: EXC_BAD_ACCESS (0x0001)

 

Thread 0: Crashed (0xb7fff8c8, 0xb808a9fc)

0x900cbed0: /usr/lib/libSystem.B.dylib : _statx_np + 0x40

0x900a5964: /usr/lib/libSystem.B.dylib : _acl_get_file + 0x38

0x0000a1dc: /Applications/Retrospect Client.app/Contents/Resources/retropds.23 : _aclHasNodeAcl + 0x68

0x0000b2dc: /Applications/Retrospect Client.app/Contents/Resources/retropds.23 : _fscImportCatInfo + 0x258

0x0000b79c: /Applications/Retrospect Client.app/Contents/Resources/retropds.23 : _FSCEnumDir + 0x184

0x00004b38: /Applications/Retrospect Client.app/Contents/Resources/retropds.23 : _volScan + 0x2b4

0x00004000: /Applications/Retrospect Client.app/Contents/Resources/retropds.23 : _TransMain + 0x158

0x0001113c: /Applications/Retrospect Client.app/Contents/Resources/retropds.23 : _ServMain + 0x1d0

0x00003758: /Applications/Retrospect Client.app/Contents/Resources/retropds.23 : __start + 0x188

0x8fc01048: /usr/lib/dyld : __dyld_start + 0x3c

0x00000000: /Applications/Retrospect Client.app/Contents/Resources/retropds.23 : + 0x0

 

PPC Thread State

srr0: 0x00000000 srr1: 0x00000000 vrsave: 0x00000000

cr: 0xXXXXXXXX xer: 0x00000000 lr: 0x900cbefc ctr: 0x90006160

r00: 0x00000000 r01: 0xbfffed90 r02: 0xbfffee3c r03: 0x00000117

r04: 0xbffff020 r05: 0xbfffee3c r06: 0x004035f0 r07: 0xbfffedcc

r08: 0x00000002 r09: 0x004035f0 r10: 0x00502070 r11: 0xa0006088

r12: 0x90006160 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000

r16: 0x00000000 r17: 0x00000000 r18: 0x00000000 r19: 0x00000000

r20: 0x00000000 r21: 0x00000000 r22: 0x00000000 r23: 0x00000000

r24: 0x00000003 r25: 0xbffff020 r26: 0xbfffedcc r27: 0x00403530

r28: 0xbfffee3c r29: 0x0000000c r30: 0x000001ac r31: 0x0000a184

 

 

 

-Popak

Link to comment
Share on other sites

Quote:

This is the log that I recieve from client side and It was in /Library?logs/CrashReporter/retropds.23.crash.log

 


 

Only the first few lines of that are needed, but you've confirmed that the Retrospect OS X Client is crashing on your Intel Mac. I believe that since pitond is running under Rosetta, that there's not too much information available for debugging (but I could be way wrong about that).

 

I don't have an Intel OS X Server machine to poke at, so I can't try any tests that come to mind. If you can stop services on the server and re-test, that might yield something helpful.

 

It might very well be a defect with the old pitond and the new hardware/OS. I'd suggest at this point a call into EMCInsignia might be your best course of action.

 

Dave

Link to comment
Share on other sites

I am having the same problem at a client. I can Back up The Start Up Mirror drive but the XRAID through the fiber Card cannot be backed up. It looks as though any of the attached volumes cannot be Backed Up On This intel Xserve. This is an intel XServe with Retrospect 6.1.26 with client 6.1.30

Link to comment
Share on other sites

Quote:

I am having the same problem at a client. I can Back up The Start Up Mirror drive but the XRAID through the fiber Card cannot be backed up. It looks as though any of the attached volumes cannot be Backed Up On This intel Xserve. This is an intel XServe with Retrospect 6.1.26 with client 6.1.30

 


 

- Is retropds.23 crashing with Exception: EXC_BAD_ACCESS (0x0001) as in the orignal poster's report?

 

- The original report made clear that the Intel XServe was running the Retrospect OS X Client software, while Retrospect was running on a G5; your report is less clear about your configuration.

Link to comment
Share on other sites

  • 2 weeks later...

I have Desktop 6.1 on an iMac and the latest client on my MBP. I used to use the PC version 7.5.

From the PC version it backed the MBP up perfectly, my PC died so I switched to an iMac. Now whenever it tried to access the MBP I get the retropds.23 crash (same as shown above).

I went into the packahe (retrospect client/contents/resources and did:

sudo rm retropds.23

sudo cp retropds.22 retropds.23

and it seems to work now!!

(I manually tried running .23 from terminal and got the bus error and just out of desperation tried .22 - it worked so I wondered if I could make it work by copying it to .23).

Not a very good solution and no idea what is going on - or the difference between .22 and .23, but it might be worth a try?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...