Jump to content

Retrospect 5.1 cannot write to Mammoth Tape Drive


jfreund

Recommended Posts

I am at wit's end!

 

Retropect Backup Workgroup 5.1 ( Retrospect 5.15)

Exabyte Exb-8900 Mammoth Tape Drive SCSI

SCSI Controller Adaptec AHA-2940UW

Driver - Microsoft 5.0.2195.6717 (6/17/03) mammoth.sys

 

--- The Problem

I had been using this system as our backup server for almost two years without a problem. On day, my tape backups started to fail. No error was posted, the backup would simply ask for another tape, it would wind through it without copying a file, then ask for another tape.

 

Performing an Immediate Backup with an erased tape it will sit with 1 file completed on its status dialog box until it reacjes the end of the tape which takes a long time.

 

--- Nothing wrong with Drive

I long ago determined that there was nothing wrong with the tape drive (long story). At this time, if I restore the Removable Storage service I can use Ms Wibdow's Backup to write tapes.

 

--- Reinstall of Windows Fixed problem for a short time

I recently did a clean install of Windows 2000 Pro. After re-installing Retrospect the tape drive worked!! Of course I was installing other software including the Windows Updates. When I nexted ran the backup, it was back to its old tricks.

 

--- everything else works

In every other way retrospect seems to work. It erases tapes. It can read and restore from my past tapes.

 

---Suspected Problem

I suspect the driver. Its dated 6/2003. This problem first surfaced in 10/2003 (yes I have been working on this a while. Retrospect does not seem to install its own driver, but it does disable the Removable Storage service.

 

--- Help

Is there anyone who can give me a clue?

 

Thanks for your Help

John Freund

Link to comment
Share on other sites

I never had to disable the driver in the past and as far as I know retrospect does not install another driver for this (Exabyte Mammoth) tape drive.

 

I do suspect the driver. As I mentioned in my original post the driver is dated 6/2003. Perhaps this is a driver that was downloaded in an windows update and has compatibility problems.

 

I tried running with the Tape Driver disabled. I was surprised that retrospect saw the drive. As in the recent past, it seems to perform all functions except being able to write to the tape.

 

Thanks for the suggestion!

 

John

Link to comment
Share on other sites

Hi

 

Retrospect supplies its own drivers for all tape drives.

Dantz hasn't made any changes to Retrospect 5.1 or its drivers for a long time. It is unlikely that something just broke in Retrospect.

 

Double check any changes you have made to the system. As a test you might want to re-enable the windows driver and try to backup using NTbackup. That will tell us if there is a problem with the drive or not.

 

Thanks

nate

Link to comment
Share on other sites

The drive is working. With the Removable Storage service restarted I have been able to run full backups using NTBackup.

 

I just performed a clean install of Windows 2000 Pro on this machine. After that and re-installing Retrospect the drive worked. But shortly thereafter it started the same behavior as before. Thinking I had fixed the problem I did not keep track of my other re-installations. Again, I suspect the Windows updates from Microsoft.

 

I suppose my next experiment will be to re-install the old mammoth.sys driver ( assuming there is on the CD) to the pre 6/2003 version to see if the drive starts working again.

 

Thanks for continuing to try to help Nate.

 

John Freund

Link to comment
Share on other sites

Looks like the problem has finally been solved.

 

Nate thanks for the hint that brought me to the solution!

 

As you recommended I looked in the retrospect folder. I did not run aspiinst.exe which would have installed the old 4.60 version of aspi32.sys. I did run aspichk.exe which told me I had aspi32.sys version 4.71.1 installed. It also indicated that I had an older version of the software installed. Noticing that this was an adaptec utility I went to their web site to check for the latest version. It was there that I learned that a newer version 4.71.2 was available.

 

Once I downloaded this and run the new aspiinst.exe it installed version 4.71.2, this was confirmed by the new aspichk.exe. Once I rebooted Retrospect worked as before and could write to my mammoth tape drive.

 

Thanks again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...