Jump to content

ZoneAlarm Pro Hangs Backup

Recommended Posts

I have been using the free version of ZoneAlarm with Retrospect without problems. When I upgraded to ZoneAlarm Pro (ZAP), Retrospect hangs when backing up the boot volume.




The only way I can get around this is to uninstall ZAP. I’ve tried shutting down ZAP but it still hangs.




The hang comes when building the snapshot. The last thing that shows up when Retrospect hangs is “IIS MetaBase”.




I have the same problem with ZAP v3.0.118.1 and 3.0.134 and Retrospect Desktop v 5.6.132.




Any help much appreciated.







Link to comment
Share on other sites

I'm running ZAP 3.0.133 and RDB5.6.127 on a W2K SP3 without problems. I was having problems with RDB5.6 for a while (with W2K SP2 and with ZAP 3.0.133--not sure when the problems started vs. when I installed ZAP) that didn't involve a "hang," but instead "-102 trouble communicating" errors. I didn't uninstall ZAP, just disabled it, but the problems continued. It wasn't until I updated from SP2 to SP3 that the errors went away.




What OS are you running?



Link to comment
Share on other sites

Sorry I forgot to mention I'm running W2K SP2. No improvement with SP3.




The update to SP3 took HOURS. What's up with that? It ran with high disk activity and the progress bar moved regularly until about 1/3 on the progess bar. Then disk activity was minutes between short blips. When the progress bar showed complete, it did not give an indication it was complete




I left it over night. Seemed OK when I manually rebooted.

Link to comment
Share on other sites

My SP2->SP3 update was pretty quick (10s of min?). Of couse that's *after* downloading the full SP3 update file (100MB over a cable modem so that didn't take too long either) and running it locally rather than doing the net/web update.




My SP3 issue with RDB5.6 may not have been the same as your problem. And given your slow update, you might want to run some more general diags (e.g. Norton Util, OnTrack, MCAfee, etc. and some anti-virus software checks, etc.) just to make your system is OK in general.

Link to comment
Share on other sites

I didn't think a virus was likely but worth a check. Of the several programs I mentioned, I like Norton Utilities (I actually have Systemworks Pro 2002, which includes Utilities, AntiVirus, Ghost, Cleansweep and WinFAX). It always finds issues with the Registry, file issues, etc. It's worth having in your toolbox (and the non-Pro Systemworks is cheaper if you don't need Ghost).




With all of that in mind, I don't know that it will cure your issue and I wouldn't want you to shell out $50 to find no diff (although, as I said, NU is worth having in general). And the slowness on SP update may have nothing to do with your Retro problem.




A couple of other thoughts. I actually leave NAV *off* (background scan) and only allow it to run on incoming & outgoing email and via manual scans. Do you leave the AutoProtect on? Do you have any other background stuff running (e.g. one of the autorestore programs such as GoBack that might be creating system config backups during an SP update)?

Link to comment
Share on other sites

Yes, I leave Auto-Protect on all the time. I get occasional Klez attacks and I don't want to take the risk of forgetting to turn it on, especially with my wife using this box.




All I have is RegClean. No other backup is running unless the built-in Windows restore stuff is doing something during the SP upgrade. I do critical updates frequently. This leaves a bunch of NT install directories in WINNT.




BTW I just ran a partial backup of my boot partition using CDRs (my tape drive is temporarily down) and got the same error. I don’t have problems backing up the other partitions.




I'll rate this as a very strange bug indeed.




Any other ideas?



Link to comment
Share on other sites

Klez will probably come in thru email, so you can turn off AutoProtect but leave email scanning (in and/or out) on if you're using Outlook Express, Eudora, etc. That's how I run. Nothing to "forget" but less of a chance of a slowdown or for with NAV conflicting with a program.




Have you tried disabling (quit ZAP or prevent load at startup) ZAP? Not as a permanent thing but just to see if it makes a difference with Retro. The next step would be to deinstall ZAP.




Although I have ZAP for local and outgoing monitoring, I'm firewalled with a hardware box so it's safe to do a temp disable of ZAP. You may not want to do that unless you pull your Enet cable first.

Link to comment
Share on other sites

Thanks, I did not realize turning off auto-protect does not effect e-mail protection.




Yes, I set ZAP not to start on boot. Still have the same problem.




When I uninstall ZAP Retrospect works fine. The last good backup I have is 77 days ago.




I like ZAP (except for this problem). I sure don't want to uninstall it everytime I do a backup.

Link to comment
Share on other sites

Well, it looks like we're back to where we started. You can't run ZAP3 + RDB5.6 on a W2K SP2/3 system whereas it works for me (slightly different software versions as noted previously). The mysterious world of Windows and PC software...




I wouldn't put up with uninstalling & reinstalling ZAP, esp. since I have RDB5.6 set up to back up my system nightly. My advice would be to either revert to ZA (assuming it was working for you), find another SW firewall, or drop ZA/ZAP/other and put in a hardware firewall (Linksys 4-port for $50 or so with some effort) between your PC(s) and the internet (DSL or cablemodem. Won't work with a modem).




Also FYI, I'm backing up my entire C: drive to a file backup on another ATA harddisk (either local or on another PC across my LAN).




And I would put Norton Utilities (or Systemworks 2002 now or 2003 when it comes out) on your Christmas list :-)

Link to comment
Share on other sites

It appears that I'm just about out of the woods.




The SP3 update does not complete on my machine unless I check the create uninstall directory option.




I just did an abbreviated CDR backup that did not hang during building the snapshot. As soon as I get my tape drive fixed, I should be back in business.




I'll let you know when the tape drive works.

Link to comment
Share on other sites

  • 3 weeks later...

I finally got a work around on this beast.




Before SP3 I could stop ZAP or have it not load on startup and the problem


happened. The only way I could get around it was a total uninstall of ZAP.




I had trouble with the install of SP3. It would not complete on my machine


unless I checked create uninstall directory, so much for saving time by not


checking it.




With SP3, if I do not load ZAP at startup but start it manually, the problem


goes away. If I load ZAP on startup and shut it down manually, it hangs.




Something about the way ZAP loads at startup causes the problem



Link to comment
Share on other sites

  • 2 months later...

I've just come up with a very similar problem, but in this instance with the free-download ZoneAlarm, not the paid Pro product. On the Win2k peer machine that's hosting Retrospect 5.6 Workgroup, the backup will stop while recording the snapshot after backing up the drive where the OS lives. Retrospect completely locks up, becomes unresponsive, and the only way out is to kill execution of the script. No error code is reported, and nothing shows in the log to indicate a problem. Turning off the ZoneAlarm autoload at boot-up and rebooting allows the backup to proceed. The same ZoneAlarm on client machines doesn't appear to impact the app.




Given the pervasiveness of these two apps, this would appear to be a problem.





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...