Jump to content

Retrospect Destroys Tapes!

Recommended Posts

Resrospect unexpectedly erases a valid, good tape that is in the tape drive.




Background: I do a full back of about 8gb to a 24gb Segate scsi tape drive. Then I set the script to automatically backup every night at 12:15 am. This scheme works good and I always have a full set of current data. I usually leave my computer on 24 hours a day.




However, If I shut my computer off, say to go off some place for the weekend, when I turn it back on again, Retrospect starts the scheduled backup it missed, even before the bootup process on my computer is finished. And it erases whatever tape happens to be in the tape drive and then sits at a dialog asking me to put in a new tape or to use the one in the tape drive.




Of course, this unexpected action destroys the entire month's worth of backup data on the tape. This has happened at least 3 times on my computer.



Link to comment
Share on other sites

>And it erases whatever tape happens to be in the tape drive




Retrospect can not do that. It is impossible.




Retrospect can not erase a tape with data on it, unless you are doing a recycle backup to a specific backup set and the inserted member is identically names to the one Retrospect is looking for.




When doing an automatic erase of a tape, Retrospect will only erase a tape that 1) Is identically named the tape it is looking for (1-Backup Set A) as an example, or 2) Already erased.




If Retrospect wants to erase a tape named 1-Backup Set A and you have 2-Backup Set A in the drive, the erase will NOT take place.




I do not know of any backup software that is as picky as Retrospect when it comes to erasing tapes, in fact customers often complain that we have too many safeguards.

Link to comment
Share on other sites

I am going to say it again. I have a NORMAL backup scheduled to run at 12:15 am every day. It has been running fine on a daily basis when I leave my computer on. It backs up only files I have modified or that are new since the last backup. On 7/19/02 I turned my computer off and left town. On 7/20/02 at 9:00 PM I returned and booted my computer to check my email. Even BEFORE THE BOOT-UP PROCESS WAS COMPLETE, Retrospect started AUTOMATICALLY, and attempted to do the back-up it should have done some 21 hours earlier. It processed the files to be backed up on drive C and then went looking for the tape drive. Then the message came up saying it could not find the tape named "1-07/15/2002 Full" and for me to put that tape in the machine. I stopped the back-up and looked at the tape and Retrospect says that it was erased.




Are you suggesting that some kind of little computer bugs erased my tape while the entire computer (including the tape drive) was turned off? Perhaps someone broke into my home while I was away, started my computer, erased the tape, put everything back as it was, and then left the scene of the crime?




It seems more likely that there is some interaction between a still booting computer and Retrospect trying to do a backup that we do not yet understand.



Link to comment
Share on other sites

Did the tape show as erased with a tape name or without. If the tape says erased without a tape name, then the tape hardware is having trouble reading the header of the tape. This can happen due to dirty heads, head allignment problems, damaged tapes or other hardware failures. Try this tape in a different tape drive to see if it is readable.




When Retrospect erases a tape, it must display a tape name (changing the name is the only way for software to erase a tape).

Link to comment
Share on other sites





I don't have another tape drive so I tried to read the 4 previous tapes I have made and it reads the tape name on those just fine. Then I cleaned the heads (7 times!) and then tried to read this one again. It just says "Erased".




I gave up, named the tape, and did a full backup again. I'll watch closer next time to see if I can catch the exact sequence of events. Since this PC seems to look up and down the bus several times looking for devices as it is booting up, I suspect the scsi tape drive was active when Retrospect tried to access it and the hardware screwed the tape up.




Thanks for all your help.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...