Jump to content

Unattended backup questions

Recommended Posts





Someting seems not to be working on my machine.


I've made two scripts that should be doing the following:




1) Make a backup of the server every night at 22:00


2) Backup all clients every 4 hours when connected and start the client backup as soon as a client starts his/her machine




I checked the log and nothing happened in the last two days!


I know for a fact that at least 2 clients turned on their machines (no pun intended) and well, the server is *always* on.


Nothing in the log/report shows that retrospect has done one thing. Zilch. This worries me to no end. This is not what I have this software for. What must I do to ensure that retrospect *realy* backup these systems? I've had a discussion before about leaving the retrospect gui on the desktop and not being able to minimize this to the tray. I was assured the software would run if I closed the retrospect gui. Looks like this is not true. What then? What should I do to accomplish the two thing I described above? Or is this just not possible with retrospect. Could be I'm giving this software task it's not able to perform and I ask to much from retrospect in the first place. If this is so, then it's my mistake. Could be...




Can anybody help me how to get retrospect to run in the background and execute those scripts without me manualy telling it to run them (the scripts)?




Sorry if I sound a little miffed here, but I was truly shocked not seeing backups where I expected them to be. Again, perhaps I'm asking to much of retrospect and then I shalll look further for software that does this.




Another thing that makes me nervous: whenever I try to close the gui (desktop interface of retrospect) it asks me the following question:




"Realy quit?


Quit Now - Start Server - Don't Quit"




Choosing "Start Server" starts the ClientBackup script and all is well.


This makes me believe that if I choose "Quit Now" the backup scripts won't be executed!


It's confusing :-(




p.s.: I've used the ReportWatcher and it tells me that there has *never* been a successfull backup! I'ts getting weirder by the minute folks. If I look at the utx file, it's chockfull of messages. And why o why do we have to leave this tool (reportwatcher) on the desktop to keep it running? I vote for the system tray or clearly defined Services, this is not what you want on a Server, leaving gui\s open on the desktop, think about it...









Link to comment
Share on other sites

(oops- i think my original reply was to the wrong thread- intended to reply to this one. re-replying)








I've been having the same problem, and just got an excellent piece of info from Dantz phone tech support:




The Launcher service defaults to running in the context 'local user', meaning whoever happens to be logged into the computer. Which is an incredibly stupid default setting for a server, but luckily you can change it!




Control panels, administrative tools, services, Retrospect Launcher, Log On tab, and set it to "This Account", browse, administrator, type in password, OK, stop and restart the service.




I havent actually tried a script yet, but from tech support's quick answer it sounded like this is a common problem and it makes a lot of sense on why it wasnt working before and why this should work now. Thought I'd pass it on! :)







Link to comment
Share on other sites

Hi Melissa,




Just watched the retrospect screen this morning while I booted my Client pc. All tasks for Clients were marked ASAP. I waited 30 minutes and nothing happened...


The server says (in the messagebar area) that retropspect is running in "Interactive mode" wheras it probably should say "Unattended mode". This is so weird. The software was started out of itself (retrorun I suppose) and did absolutely nothing. How could this be "Interactive"? I now shutdown the retrospect gui and I'm curious when retrorun will start the whole process again, but you can be sure I won't bet the house on it making a decent backup :-( I've kinda lost faith in retrospect. To quircky and unreliable for my taste. I need to run around this thing making sure all is well, nursing it to do what it should be doable out of itself. I find this so weird. I've heard so many good stories about retrospect, but I can't seem to get this thing to work properly, sigh.




p.s.: I just waited an hour and it did not start, the gui that is. I now started retrospect myself and bammo, all of a sudden it finds that it needs to make a backup. Never knew software could be *this* flacky!









Link to comment
Share on other sites

I had similar problems with 5.15 but only intermittently. Just upgraded to 5.6 so we will see if it helps.




I just setup ReportWatcher as a service, but I'm not sure if it will work this way. I already had it setup, configured, and working in GUI mode.




There are two files needed, one is called srvany.exe and the another is called Instsrv.exe. You can get these files from the NT/2000 resource kit.




Copy both files to C:\Winnt




Open a command prompt window.




Navigate to C:\Winnt




Type: instsrv srvany C:\Winnt\srvany.exe




Type: INSTSRV.EXE ReportsWatcher C:\Winnt\SRVANY.EXE




Now start the Registry Editor (REGEDIT) From the run box (BACKUP YOUR REGISTRY!!!!!)




Locate the following sub key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ReportsWatcher and select it.




From the Edit pull down menu select New, select Key, and then type: Parameters




Select the new Parameter key, right mouse click, select NEW, select String Value, and type: Application




Right Mouse Click the new Application String, select Modify, and type: \watcher.exe


The value should be similar to:


C:\Program Files\Dantz\Retrospect\Reportswatcher\watcher.exe




Right Mouse Click the Parameter Key again, select New, select String Value, and type: AppDirectory




Right Mouse Click the new AppDirectory String, select Modify






Should be similar to:


C:\Program Files\Dantz\Retrospect\Reportswatcher




Start the services applet and scroll down to the ReportsWatcher service. Highlite it and select properties.




Make sure it is set to Automatic. Make sure that it runs under an account that has admin access to the folder that reports are exported to.




Like I said, I'm not sure if it works this way or not. I will let you know tomorrow.



Link to comment
Share on other sites

Hi Gunney,




Thanks for the tips, will try.




Another thing I noticed: the server ;ost all connections to the Clients. It could not connect and therefore not backup. I looked at the Client definitions on the server and it tried to connect through multicast. Weird, I told it to connect thruogh a direct connection. Reset thos and it's working now. Funky software this.









Link to comment
Share on other sites

The reports watcher does work as a service.




I'd like to point out that it has to be setup in GUI mode first so it will know where the utx files are located.




I also tested the unattended issue last night. I logged out before I left work. I dialed in last night during the backup and logged in via VNC. The backup was running. I logged out and this morning the backup had finished.




I run two scripts at night, 1 to tape and one to disk. Both completed while being logged out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...