Jump to content

removable storage manager failure!

Recommended Posts

event viewer keeps giving the error "RSM was stopped" in Windows 2000. As a result Retrospect will not detect tape media. The service appears to start up (sometimes) when win2k boots, but after a few minutes it will stop, either on it's own or when the tape drive (HP SureStore 40e) gets polled in any way. We can also manually start the service and make it see the tape drive, but it will stop shortly thereafter.




The machine we're using right now is a brand new from-scratch install of Win2k on a dell optiplex gx110. The diagnostics for the tape drive all pass, the tape drive firmware is newest, the scsi drivers for the adpatec 2940 u2w are the newest, and there is a microsoft article on 4mm dat drives potentially needing a 4mmdata.sys file file, but comparing the file versions with the one on their website to the one we have shows that the article is outdated by the most recent win2k service pack (2) which we have, and the versions match.




Same result on two known good systems, both dells, though different models. Is it possible the scsi card is bad, even though the tape drive passes all its diags? If not, what the heck do we do? We gotta get our backup back up and running....what's really odd is that it had been working fine on win2k, without sp2, for almost a year, and then the "RSM was stopped" error appeared out of nowhere.




Ideas? Already talked to HP..









Link to comment
Share on other sites

It was already disabled (i think by default) which is probably why the


service kept shutting down. However, even with the service "enabled" now,


while Retrospect will let me Erase media, when i start the Backup Server


with the "run" drop down command, it still doesn't see any media in the tape


drive....arg..... help...just shows the tape name and "waiting for media" at the bottom of the running backup script window.









Link to comment
Share on other sites

Two things you could try:


1. disable the tape driver in Windows Device Manager to see if that helps.


2. switch to ASPI with-in Retrospect. (You can go to your Retrospect folder and use the ASPI installer to install ASPI). Then With-in Retrospect make sure you are using ASPI found under Configure/Devices/Environment. At the top it will say devices visible using - NT passthrough or ASPI.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...