Jump to content

Problem Using Retrospect 6.1.126 and OS X 10.4.6


Recommended Posts

When I backup my boot drive using Maxtor One Touch and Retrospect, and it has copied 399897 files, with only 4864 remaining, it freezes while presumably attempting to copy "timl24-ISO8859-2.pcf.gz". After a long timeout, it proceeds but then fails later with the message "Trouble in Retrospect Express, Internal Consistency Check Failed Assertion Check at "elem.c-928". A later search of my drive finds no file with the specified name, which may explain why it has trouble copying it. I have checked both the boot drive and the Maxtor drive using Apple's Disk Utility, and it was unable to find a problem with either. I have had the same thing happen in three of four successive attempts. What's going on?

Link to comment
Share on other sites

Hi George,

 

I'm not entirely certain what this particular file is related to, but you can see that (and a list of similar files) fairly easily by opening terminal and typing in "locate *iso*."

 

One of these files may be damaged and causing Retrospect to assert, but a good troubleshooting step for assertion failures is to remove the configuration file located in /Library/Preferences/Retrospect. The file should be called "Retro.Config (6.0)."

 

Once this is removed relaunch Retrspect, enter your license code and run another test backup.

Link to comment
Share on other sites

Quote:

but you can see that (and a list of similar files) fairly easily by opening terminal and typing in "locate *iso*."

 


Um, no. The shell does glob expansion before passing arguments on to a program. Unless the file is visible in the shell's current search path (unlikely), the suggested command won't work as intended. See "man locate" for a discussion. This is a common misunderstanding of how the shell evaluates arguments before passing them on.

 

but if you try "locate iso", you will get what you seem to expect.

 

Russ

Link to comment
Share on other sites

Hi Russ,

 

Um, yeah. I'm not about to get into an argument with you about shell commands, because it is obvious to me that you're knowledge in that field is beyond mine. The advice I gave is something that I tried out before I posted and it worked perfectly to demonstrate the point that this file does, in fact, exist on this users system alongside several other files containing the string "iso."

 

Judging by George's request for help his skills with OSX are probably fairly limited (please don't take offense George, I have very little to go on). He likely does not care one way or the other about the interpretation of command arguments. The objective of his post is to try and understand why his backups aren't running as expected. I did not have a direct solution for him, so I offered something that may help show him that he's not suffering from malicios ghost files, but from an actual file that simply cannot be located through whatever means of search he used.

 

So perhaps next time you post, instead of simply being condescending to me for suggesting a command *that does work* you could offer some useful information for George. Add something useful to the thread, this is a support forum after all.

Link to comment
Share on other sites

My apology for providing a correction to misinformation so that George might be able to locate his errant file; I had no intention of being condescending - if that had been my intention, you would have been well aware of it.

 

I thought that a side benefit of these forums was for everyone to be able to raise their level of understanding. My apology for my misunderstanding; I won't make that error again.

 

russ

Link to comment
Share on other sites

Russ,

 

You have not provided any corrections, that is why I am bothered by your post. While the information I provided may not be the most correct usage of locate, it is absolutely functional and adequate for the basic point I was making. Perhaps you could open a terminal and try it, and let me know what you see?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...