Jump to content

verification errors with an AIT AUTOLOADER

Recommended Posts





I wonder if anyone can assist me, I have an issue which is puzzling me, and i cant find a techincal solution to it.




I have a Quicksilver G4, Running OS X Server 10.1.4, With an External RAID Box, and a partitioned internal Drive Being backed up via retrospect 5.0.25 to an AIT autoloader. Connected via ribbon cable to an Adaptec 39160 SCSI card. Everything is setup ready to go, the backup runs, but on doing a verification (compare), i get hundreds of backup storageset errors, but without the verification, the backup runs fine, but nothing can be restored. This same problem occurred with a Adaptec 29160 card installed, but most technical advice stated the 39160 card was a fully compatible product, (thats why we spent £400 on the new card). I dont want to revert back to the OS 9 Appleshare IP/Retrospect 4.x scenario, as OS X Server is awesome, check it out folks, its truly stunning, but looks like im going to have to if i cant find a solution.




any suggestions where i go next u clever people?





Link to comment
Share on other sites

Well Folks,




Tried the Fix as Suggested, We are now getting further, no Bad Backup Set Header Errors this time, but when doing the compare, It hangs after comparing roughly 2MB of the files, I have tried different files, but the same thing happens. it just hangs, and can only be solved by a hard restart. ( which then brings down the other Applications ( OS X Server). Im beginning to think i have a Pig in a poke here, the Drive works Ok under OS 9.2.2, The Retrospect Software Backs up without verification, but you then cant retrieve anything from it, Ive downgraded the Adaptec 39160 driver to version 1.0.2. Who do i blame? Dantz or Adaptec? or Both? i hate blaming people, but im getting nowhere fast.




In case any of the Dantz Guru's read this, i Will give you the details again, Quicksliver G4, Running OS X Server 10.1.4, Attached via an Adaptec 39160 MAC card to A Sony L400 AIT Autoloader & an external 140GB RAID box. When Running a backup, without compare, i get a completed backup, ( but because it hasnt verified the Data, the data cannot be retrieved, from tape. therefore a useless excercise. With Verification on, It starts the compare, does approx 2MB of Comparing, then freezes. and has to be hard restarted, ( i.e. the Button on the front).




Any Further Ideas you clever people?




Doug - Scotsys

Link to comment
Share on other sites

Isn't it great to donate all that hard earned knowledge and experience to have no one contribute or respond? I've been there...




I have the same config. and am using the Adaptec v1.0.2 driver and have found that it is best to remove the RAID from the 39160 card and install it elsewhere (temporarily until Adaptec updated their driver again). OR, buy an ATTO card as I read in other threads that they work!




I am so glad I updated to Retro 5...




My config: G4 867 with 1 Gig RAM, Mac OS X 10.1.5, Retrospect 5.0.205 with driver update 2.7.102, Adaptec 39160 with LaCie AIT Autoloader on channel 1 and 36 Gig RAID on channel 2.

Link to comment
Share on other sites

Are there any other decives on that card?




Put a CD in and try backing up and comparing this to be sure that the problem does not lie with the data that you are copying.




Try a small backup to a file backup set stored locally; still see the hang?




What is the pin configuration of the card? Of the drive?




Have you tried a brand new tape?




Have you tried changing the SCSI IDs on the drive? With loaders, set the drive to 0, 1, or 2, and the library at 3 above that.




As Slaroye suggests, try taking the RAID of the card to see if that helps.




Irena Solomon


Dantz Tech Support

Link to comment
Share on other sites



Hi Irena,




Further to your Steps to try, HEre are the results.




1) Other Devices on the Card? - Yes External 180GB RAID Volume RAID 5, Hot Swappable, Set to SCSI ID 4




2) Put a CD in and Backup - This worked Ok, No errors, and Restored All files Intact.




3) Small Backup - Local file - No hang,




4) Tried New Tapes - Yes 4 AIT Tapes Tried.




5) Check SCSI ID's - RAID Volume ID:4, AIT Auto loader - ID:1




6) Remove the RAID - Not easy to do, As this is in continual Use, But i Cant see it HAving any relevance, Though i will try it After close of play today.




A Solution (or even a statement to say Yes it will work, or no it wont) is required Urgently.




We are transferrring the Backup to another Machine which will be acting ONLY as a Backup Server, this is not an IDEAL soultion, and we want this issue looked into ASAP please, Is it an Adaptec Issue? a Dantz Issue? or whose dangly bits do i get to kick?








Look forward to your reply

Link to comment
Share on other sites

Hi Irena, An update for you. I have transferred the AIT2 Drive to another G4, and mounted the OS X volumes on the desktop, Ran a backup and all worked ok, so there is obviously and issue with Retropsect 5.0.25, Adaptec 39160 cards, and OS X Server version 10.1.5. THe Temporary solution will suffice for now, but i need a resolution of this, do i send back the adaptec card, and fit another one? im loathe to do this, as i dont think the card is the issue, as the RAID volume is still available to the OS X Server. do i need an updated retrospect driver? can you escalate this to your next level of tech support please.

Link to comment
Share on other sites

Were you able to test with the RAID not connected?




Since OS X is so much more finicky about SCSI communication, we need to determine if the RAID is causing interference that is preventing the backup from verifying properly.




Mounting the server isn't really comparable, since you can't back up permissions from mounted OS X servers.

Link to comment
Share on other sites

  • 4 weeks later...

Well... it was too good to be true. I am now getting Bad Backup Header errors again and I changed nothing (to my knowledge). I am still using Adaptec 39160 with v1.0.2 of the driver, a LaCie AIT Autoloader and do not have a RAID connected. Retro 5 - the latest.




I tried a new backup set. I tried new tapes. I tried new SCSI ID (with at least 2 number gap betwen old and new SCSI ID). I reinstalled Adaptec v1.0.2 driver. Still no good. I am now going to try removing Retro Driver Update but it has been running 'fine' for weeks.




Anybody else got any ideas?

Link to comment
Share on other sites

  • 2 weeks later...

I really can't recall where I found it but I emailed a copy to you. Perhaps IrenaS could let people know where to find it as I thought I had discovered this in this forum. Perhaps you could provide a place to download this from your web site Dantz. Any news from Adaptec as to when they will fix this bug with the 39160!!??

Link to comment
Share on other sites

Hi Stephane,




got the ATTO UltraWide SCSI Card today. Snapped it into the PCI slot and voila...




the first successful local Backup of MacOS X Server with Retrospect 5.0 !




No header errors anymore!




Adaptec seems to be a crap under MacOS X.


It's funny but I saw a lot of major companies known as reliable partners under MacOS 9 who are developing shitty OS X stuff and a lot of small companies with great pices for OS X.




Greetings and thanks again,







Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...