Jump to content

cannot find Catalog File


Recommended Posts

Hello, I've imported the retrospect server configuration file from a Mac v.17 retrospect instance.  The backup sets are kept on a windows share, which the mac accessed via SMB.  The import worked fine, with all clients/scripts/etc transferring fine.  I am not able to locate the media file, either through the saved "volume" in retrospect, nor by mounting the share and trying to navigate to it directly.

I click the properties button, and it wants the location:


but it's not seeing the clearly-mounted share, "retrospect-backup1":


I also see retrospect-backup1 in the Volumes Database list:


But I don't see anyway to tell the script to use the (remote) media set file.  The mac version of retrospect appeared to be able to use/edit/save to the catalog files in a complete remote fashion, where both sets and data were kept on the remote share, and mac didn't have anything saved locally at all, aside from the scripts/server config/etc, of course.

Is there fundamentally something that I am missing?  Just out of curiosity, I went to "Create New", but when I tried to navigate to the share so I could set it as the destination, Retrospect could not see the share, as in picture 2.  That in itself is somewhat disconcerting.


And a quick aside - is there any way to make the Find dialog in the first picture resizeable, or would that be something I need to put in a feature request form?


Link to comment
Share on other sites

Oh my, billbobdole, it appears you're still using the same ancient trick with File Media Sets I described 6 months ago—except now you're trying to do it under Retrospect Windows (17?) with the File Media Sets supposed to be treated as File Backup Sets.  😢

At a minimum you need Retrospect Windows and Windows expertise, which as a Mac administrator I can't provide—but maybe Nigel Smith or Lennart_T can.  What version of Windows are you running under?  Did your 2012 Mac Mini die, or did the trick not work under Catalina?

At a maximum you need the help of Retrospect Tech Support.  If you upgraded to Retrospect Windows 17 within the last 30 days, you are entitled to free personalized Tech Support.  And IMHO you need that kind of support;  I don't even know if your trick works the same way under Retrospect Windows 17.

Link to comment
Share on other sites

Yea my kludge doesn't work with backing up to Disk rather than to File.  I have a combination of Mac & PC clients which need a full backup (and produce a subsequent backup set file) every 2 weeks, and incrementals every night.  The backup set files were saved on an Isilon file storage system (now DDN), which a Mac mini with 10.15 Catalina mounted via SMB.  AFP on Mac OS has depreciated over time, and Catalina has a documented issue with disconnecting SMB shares over a short period of time, almost always in the late pm's and early am's according to the OS logs - so it turns out my previous thread was a Mac OS/SMB issue, not a Retrospect issue.  I'm trying on a Windows server 2019 now, but I just stumbled upon a "fix" today, which involves turning on "Server Performance Mode" on mac os - something which may not work for the common user.. I will report back with results - Catalina has consistently dropped SMB(3) connections on a nightly basis.  I feel uniquely ancient in my ways, so maybe I'm serving as test case - this 'trick' oddly does not work occasionally. :D.  



Link to comment
Share on other sites

I think I'd call support on crossing platforms.  But here are two things to try if you want.

1.  Even going from one Windows system to another, the only sure fire way is to use the Transfer Backup Sets tool.  I'm successfully moved the manager server setup, configuration and catalogs.  But when you move the backup set to a new repository it won't work.  Transfer takes care of that, but I'm not sure you can do that unless you can map a drive on Windows to the Mac's SMB share.

2. You should be able to create a new catalog from a backup set, simply by using the Repair a Catalog tool.  If it repairs the catalog or creates a new one, you should then be in business.

Running either function should be expected to take hours or days.

Good luck.

Link to comment
Share on other sites


Here's a possible simple fix:  Underneath the "Retrospect" folder on each of my 3 USB3 portable destination disks, there is a zero-byte Unix executable file named "Backup Media" that was created in August 2015 (when I first started using modern Retrospect Mac with Disk Media Sets) and hasn't been modified since.  My hunch is that the lack of that file within your folder "Backup Sets" is what's preventing Retrospect Windows from locating the Catalog File; according to the first paragraph of this 2019 post, "The split catalog file will be named 'Backup Set Name.cat.'"  Do other smaller Backup Sets work?

P.S.: Fortunately for him🤣 mbennett—whose Retrospect Forums posting history only goes back to 2015—has no idea of the morass billbobdole is in.  To understand it, mbennett can first read the short section "File Backup Sets" on page 45 of the Retrospect Windows 17 User's Guide detailing why they are obsolete—and then this November 2019 post.  Finally he should read this up-thread post by billbobdole, who is fundamentally the victim of one of the multiple f**kups in macOS 10.15 Catalina.  (According to at least one knowledgeable poster on the Ars Technica Mac forum, these f**kups seem to be caused by very-centralized Apple management's concentrating on iOS—the mobile-oriented OS that provides the bulk of Apple's current revenue—and leaving "enhancements" of macOS to a basically-uncoordinated "second-string team".)   Reasoning that the SMB share disconnection f**kup is unlikely to be fixed in Catalina (maybe it will be fixed in the forthcoming macOS 10.16), billbobdole is attempting to use his existing SMB NAS share on a Retrospect Windows 17 "backup server"—running under an OS that continues to be developed by the  company that invented SMB.  He's being hit with the problem that Retrospect Windows 17 can't find his cross-graded Catalogs, which—because they are for many individual File Backup Sets—are on his SMB share.  My suggestion in the first paragraph of this post attempts to deal with that problem.  IMHO billbobdole really needs to talk to Retrospect Tech Support.

P.P.S.: billbobdole, see the only Ars Technica Mac forum discussion of Catalina SMB that I could find—this and the subsequent posts  in that Fall 2019 thread.  As for "Catalina has a documented issue with disconnecting SMB shares over a short period of time", the best thing I could find was this TechARP article, but it says to enable SMB3—which your NAS share may not support (if it uses older Isilon OneFS—see Table 2—so check with Dell T. S.).

P.P.P.S.: Once a week I run Retrospect Mac 6.1 on an old G4 Digital Audio Mac.  The GUI for Mac 6.1 is pretty much still the GUI for Retrospect Windows—although that's multi-threaded, and dialogs aren't resizable unless there is a diagonally-striped box in the lower-right corner.  IMHO putting in a Support Case would be a waste of your time, because Retrospect "Inc." is in the process of replacing the Retrospect Windows GUI with something more Mac-like.

Edited by DavidHertzberg
Add question to first paragraph. P.S.: Explain billbobdole's _fundamental_ Retrospect problem to mbennett and anyone else. P.P.S.: Links relating to billbobdole's mocOS Catalina SMB problem. P.P.P.S.: Find dialog not resizable.
Link to comment
Share on other sites

^ Hmm I will take a gander at that when I'm back in on Monday, and I might need to talk to support about possibly extended my 45-day windows trial if possible - unless there's an easy way to uninstall/reinstall the trial?  I hate being so bush-league like that, but we did just renew our ASM if that counts for anything :)

FYI about the Server Performance Mode option - it did NOT work, and the SMB share was again forcibly disconnected overnight by the macOS.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...