Jump to content

Dantz Retrospect 6.0 Locked Catalog Error

Recommended Posts

I am again having issues with locked Retrospect catalog errors. This has happened intermittently over the past few years, but generally two or three restarts cleared the problem. However, after a week of trying, I am still unable to use Retrospect to backup to this catalog. Attempts I have made to fix the solution include:


1) Checking that the catalog file is not locked, which it is not

2) Going to the Dantz Knowledge Base page and accessing the article on this problem.

3) Using DiskUtility to repair permissions, and then both TTPro and DiskWarrior (current versions of both), to attempt to repair any errors on my drive. No problems were found. I ran each several times.

4) Recreating the catalog file from Retrospect's “Tools” command


No luck after all of these. The final step in Dantz’s support article is to reformat my hard drive. Understandably, I am leery of doing this since my backup software is not reliable!


System details: G4 867MHz with 512MB RAM, OS 10.3.5, Retrospect 6.0.193, Device Access Version 1.0.105, and Driver Update Version 5.6.102


Any help in getting a functional backup program would be most appreciated. Thank you!

Link to comment
Share on other sites

- Can you post the KB article you're referencing?


An existing thread on the Forum describes an issue where Retrospect is auto-launching two copies of the program, which results in a locked catalog error.


- Is your problem happening on auto-launch, or can you confirm that the problem happens when you launch Retrospect manually and run an Immediate backup?




Link to comment
Share on other sites

I do all of my backups manually, eg launch Retrospect, choose Immediate>Backup etc. I don't run any scripts or auomated macros.


Just did a search and only found one copy of Retrospect on my HD.


Here's the KB article (vide infra).


Thank you for trying!




TITLE: Catalog locked with a Disk or Tape backup set






Article ID:






Date Created:



Date Modified:













When doing a backup on Mac OS X, Retrospect will sometimes report "Catalog locked" errors. To fix the problem, please try the following:


1) Using Apple's Disk Utility, attempt to repair the permissions on the disk containing the catalog file.


2) Use Retrospect to rebuild the catalog. Go to Tools>Repair>Recreate from Tapes (or Disk) in Retrospect and recreate the catalog file.


3) If needed, try reformatting the destination hard disk. Warning: This will delete all data on the disk and will require you to create a new backup set.

Link to comment
Share on other sites

Backup device is an Ecrix VXA-1 Firewire tape. The catalog is stored on my Macs main HD, which checks out OK with the 3 utilities mentioned above. Haven't tried storing the catalog elsewhere.


I've had numerous problems with this backup system over the years, with Ecrix pointing the finger at Dantz and v.v. It may be that this is too complex a set-up for the average non-network administrator to run reliably, so I am migrating my backup to two large external hard drives and using a simple synchronization utility. We'll see if that functions with fewer errors and less time invested.

Link to comment
Share on other sites



You might want to try the newest firmware from Exabyte for the drive. That seems to have resolved problems for a number of people.


Does the catalog locked error occur on all executions or just scripted backups?

Does it happen if you log into the finder as root?




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...