Jump to content

Access to Buffalo USB drive ??

Recommended Posts



I am on a XP PRO SP-2 updated all the time.. cool.gif

I have a 370 Dell Workstation with 2 GB RAM 130GBHarddrive

I am on a GIGA bit network and here are the NAS 300GB Gigabyte Buffalo Linkstation with a USB 2.0 300GB Drivestation connected


Buffalo comes with a crappy little backup tool that looks like software from 1980 (Space Invaders)


I have Retrospect 6.5.382 - But this fancy sofware can do everything except getting access to the USB devise that are connected to the Buffalo NAS through the USB port on the NAS (As it surpose to)


I use Retrospect to backup my computer to tapes and to the NAS

Then I wanted to backup the NAS on a weekly basis to the USB (As a mirrorcopy)


However Retrospect software can't access THE USB - it bends over and shuts down wuth a "TELL RETOSPECT ABOUT THIS ERROR" message ... computergrem1.gif


The error shows up everytime the USB devise is involved?

From HDD or from NAS


Any ideas, fix or are this a perfect reason to upgrade to 7.x?

Are this possible in the new version...? Or how to fix


Help wanted and appriciated a lot


Link to Buffalo:

NAS: http://www.buffalotech.com/products/product-detail.php?productid=107&categoryid=22

USB http://www.buffalotech.com/products/product-detail.php?productid=87&categoryid=17

Link to comment
Share on other sites

Hi Netz,


Have you tried connecting the Drivestation directly to your computer, so that it simply acts as any usb hard drive?


Have you checked the Windows event viewer to see if there are any errors reported when Retrospect crashes?


Does the Terrastation have any logging that might reflect related errors?


Can you use Windows Explorer to copy and paste a large amount of data to the Drivestation while it is connected to the Terrastation?

Link to comment
Share on other sites

Hi Foster,


Nope I havn't tried to connect the DS directly to my CPU - - The whole setup is based on that the DS sits backend to the NAS.


Can' find any files called event.log system.log or as like

But in Retrospect dir. : rthlpsvc.log

HSvcRestoreReg: FindFirstFileW(rtregrst.ini) failed 2

hsvcWin2kDbRestore: GetFileAttributes(C:\WINDOWS\ComRegBk\RtrComRg.ini) failed 3

hsvcWin2kDbRestore: GetFileAttributes(C:\WINDOWS\RSMBk\RtrRsm.ini) failed 3

hsvcWin2kDbRestore: GetFileAttributes(C:\WINDOWS\IISMetBk\RtrIISM.ini) failed 3

hsvcWin2kDbRestore: GetFileAttributes(C:\WINDOWS\WMIBk\RtrWMI.ini) failed 3

hsvcWin2kDbRestore: GetFileAttributes(C:\WINDOWS\ActDirBk\RtrActDr.ini) failed 3

hsvcWin2kDbRestore: GetFileAttributes(C:\WINDOWS\CertSvBk\RtrCertS.ini) failed 3

HSvcWriteDVDAddToReg: CreateFile(C:\WINDOWS\retregld.dat) failed 2

No work to do, quitting...


Properly not much help frown.gif


No log file for the Buffalo drive?? frown.gif


Nope... When I use Explorer to copy and paste a large amount of data... the Drivestation gives a "time out" - But this is only visuel when I compare the dirs afterwards (no warning is given) - But I managed a few times ... to copy a large amont of data.


I find myself surfing around trying other software ... A lot of trials... But they fails (due to Danish letters in favorites and so on) ... I am actually happy for my Retrospect that served me for a long time... I really would like to keep using RETROSPECT - But this is a mayor issue for me.


Hope for a solution smile.gif




P.S. I do NOT recommend investing in Buffalo drives ... It's a bad experience - But I did and I am stuck with it for a few years tongue.gif

Link to comment
Share on other sites



The log file you stumbled upon is for the Retrospect helper service, this typically will not have much of an effect on your backups, as the helper service is only responsible for a few registry interactions during backup and restore.


You can find the Windows event viewer by right-clicking on My Computer, then select Manage. You will see a section labeled Event Viewer. If you expand this you will see three logs: Application, Security and System. Errors and warnings can be picked out pretty easily by there icons.

Link to comment
Share on other sites



Thanks... Got it....

Scanned the entire log.... wow...

No trace of retrospect....

But doing the backuptime this entry might have something to do with it???


Source: CI

Error 3221225529 detected in content index on c:\system volume information\catalog.wci.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Clicking on the link... Does not give much -

Link to comment
Share on other sites



Thanks for your effort smile.gif ...


The NAS are NTFS ... And in order to be able to write files on the USB attached to the Buffalo Giga NAS it has to be formatted with the Web interface... (I was hoping it also would be NTFS... But the info screen aboit the USB states its EXT3 - Whatever THAT IS ???

Buffalos support and FAQ are to be desired ....


I'm soon igor to get my hands of some software that just EAT my files and backup them up to whatever media I want... smile.gif - My data hasn't been backup'ed since ...


But retro... has been a long good friend - hate to leave him in the dust - especially when the buffalo is far from a state of the art piece hardware/software.


I guess I in the future will read a lot more reviews and test before I deside to use an "UOFFICIAL" brand like Buffalo !! frown.gif( - But for now - I guess I'm stuck


I also begin to suspect my digitus broadband router for not keeping the connection alive? - There are a USP printerport on the router that I use and this keeps buming off 3-4 times a week.

I am now after 3 weeks still waiting for a reply from thier support... But I guess the Germans are not effective in all ways smile.gif


Have a great day and I really appriciate any help you can come up with ! smile.gif

Link to comment
Share on other sites

  • 4 weeks later...

Actually, the Buffalo Linkstations are based on unix. ext3 is a unix drive format.

I find the drives to be perfect for what they are. They are easy to set up easy to maintain. My users find them fast and dependable.


The only problem I have is that Retrospect will not back them up. I tried forcing a user in the services properties but Retrospect will not start up and automatic backup.


I can back up the linkstation using an immediate backup. I can restore the files to the linkstation.


If I use the local system account in the retrospect launcher properties, all my clients backup on the automated backup but the linkstation backup fails because of lack of permissions.


If I choose a user in the launcher properties, nothing happens until I open retropect. Then it starts the backup.


Does anyone know the secret for making and automated backup work with a mapped drive?

Link to comment
Share on other sites

  • 1 month later...

Hi gpdahl,


To backup a mapped drive:


1. In Retrospect, go to Configure > Volumes. Do you see your mapped drive under "My Network Places"? If not, click on the "My Network" button and add it to the Volumes.


2. Once it is showing in Configure > Volumes, right click the network volume and choose "Login As".


3. Enter the username and password for the Buffalo Linkstation. This will save the authentication properties of the Buffalo drive within Retrospect.


4. You should also make sure that Retrospect is running as an Admin Windows user all the time so that it has the proper permissions to access network volumes. Go to Configure > Preferences > Security > Always Run Retrospect as the specified user.


Hope this helps.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...