Jump to content

swapping disk causes scheduled exec to be deferred


Recommended Posts

Hi there,


I've got two SATA disks connected via the same external SATA port in an alternating manner.

I can hotswap these disks since the controller (RAID controller in Legacy mode for this port)

supports it and Windows itself is happy as well, except that the drive letters are different for each

drive - I can live with this.


However, what seems to happen is that backup scripts (1 duplicate and 1 backup) scheduled to run

and backup the missing drive fail (as I would expect), but the schedule entries show that the execution

is deferred and even if I swap back the disks, these scheduled backups are not happening automatically.

Sometimes I can solve this by editing|validating these scripts for the currently inserted disk.


This is a bit annoying and I assume that's something I am doing wrong rather than Retrospect.

Is there any way to get Retrospect to ignore the missing drive's scheduled backups but keep

checking so that when it is swapped back in the backups would restart automatically without me

having to touch them?





Link to comment
Share on other sites



Please see this article as a reference for "executions deferred."


Backups trying to run when the needed disks are not present should simply fail with a media request, assuming you have the option for media request timeout enabled. Configure>Preferences>Media Request.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...