Jump to content

Retro Express HD 1.0 stopped working


Recommended Posts

I have been running backups on my Maxtor external for about 6 months or so, and all of a sudden my backups have stopped. There is plenty of room on the disk, and I cannot get it fixed using any of the support options available.


When I try to open the retro express I get a Common Language Runtime Debugging Services window pop up telling me this:


Application has generated an exception that could not be handled.


Process id=0xddc (3548), Thread id=0xde0 (3552).


I get the option to debug by clicking "cancel", but then when I do that, it tells me that there is no debugger found...



Link to comment
Share on other sites



Uninstall all versions of Express HD and all versions of Microsoft .net framework. Delete the C:\documents and settings\all users\application data\RetroExp folder. Then reinstall Retrospect Express HD 1.0 using the Maxtor install CD. After that apply the Retrospect Express HD 1.1 update. If you still have trouble download and install .Net framework 2.0 from windowsupdate.microsoft.com




Link to comment
Share on other sites

  • 4 weeks later...
  • 1 year later...

I have struggled with this issue for months. I tried ALL the forum suggestions I could find, run dotnet fix, tried all combinations multiple times and I continue to get the "Application has generated an exception that could not be handled". I can not run Retrospect 1.0 or the upgrade to Express_HD_EN_1_1_127.exe.


Is there a solution?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...