Jump to content

? after Backup/Restore using FireWire Target Mode

Recommended Posts





Sorry this is so long ;)




I backed up an iBook so that I could partition its HD, then restored everything back. I ran into 3 issues. I'd like to know if the 1st 2 issues are normal (or indicative of something possibly wrong) and what to do about the 3rd issue.




a) I connected and mounted the iBook as an HD onto a G4's desktop via FireWire Target Mode. I then used Retrospect 5.0.205 to backup the mounted iBook's HD onto the G4's 2nd partition (as a Backup File). The backup was successful. Both Macs have OS X 10.1.3 and OS 9.2.2 installed (in the case of the G4, both OS's are on the 1st partition), and both were running OS X (the iBook was last booted into OS X before shutting it down for FireWire Target Mode).




B) Next, I partitioned the mounted iBook's HD using OS X's Disk Utility.




c) Then I did a Restore Entire Disk. Once it was done, I umounted the iBook's HD from the G4's desktop, powered-off the iBook, unhooked the FireWire cable, then tried restarting the iBook.










1) The iBook wouldn't startup initially; it only displayed the Flashing Broken Folder icon. I then tried holding down the "Option" key, but there were no volumes displayed in the startup volume selector. I powered-off the iBook, restarted and held down the "X" key (to force it to boot into OS X), but again it wouldn't startup. So, I started up from my OS 9.2.2 Tech CD. In the Startup Disk control panel, I could select the OS X System on the iBook. Then I restarted. But, the iBook still wouldn't startup. I restarted with the CD again and this time selected the OS 9 System Folder, then restarted. The iBook now started up fine.




2) The System Folder on the iBook's 1st partition wasn't blessed after the Restore. Opening the System Folder, then closing it, didn't re-bless it. (I know that you sometimes must open and close the System file, but I didn't bother this time.) After having selecting it in the Startup Disk control panel and then restarting successfully into OS 9, the System Folder finally displayed the blessed icon.




3) In addition to the usual OS X-related files/folders being visible ( "mach," "mach.sym," "mach_kernel" and the folder "automount"), the following files were now visible:














These files were never visible in OS 9 before this Backup/Restore. OS 9's Get Info lists them as "OS X Alias." Once I restarted with into OS X, these files disappeared; but, they will reappear each time I restart into OS 9. Also, they're part of my Backup when I view its contents in Retrospect. FWIW, I checked for the file ".hidden" (which I read stores info on which files to keep invisible), and it's present in the iBook HD's root directory. The modification date is Sept 2, 2001 and pre-dates the Backup/Restore.






So, are #1 and #2 "normal" for this kind of Backup/Restore, or do they indicated something might be wrong with the whole procedure? The iBook seems to function normally, although I haven't had time to thoroughly test it out in OS X.




And what should I do about #3?




Thanks for any input!






P.S. I just came across a possibly (un)related 4th issue? I originally wrote this in SimpleText, and when I went to save it I was dumped into the "HFS+ Private Data" directory which lists the following files:




















I don't know if this is related to everything else. Once I moved out of this directory, though, it "disappeared" from the Save As... dialog (this is all in OS 9). This directory is not visible in the OS 9 Finder, BTW.

Link to comment
Share on other sites

Since the system on the iBook wasn't active, it's likely that Retrospect could not access the permissions for the backup, thus wasn't able to restore them. You really should use the client for this type of backup, as this has been tested, and Retrospect can access all files and permissions.




The system that you were trying to back up was not running OS X (though it may have been before it was shut down, the permissions are only really assigned when the OS is active).

Link to comment
Share on other sites

I connected and mounted the iBook as an HD onto a G4's desktop via FireWire Target Mode. I then used Retrospect 5.0.205 to backup the mounted iBook's HD onto the G4's 2nd partition (as a Backup File). The backup was successful.




You probably would have had better luck doing the reverse; having the machine with the information you wanted to back up be the booted machine, and having the machine that was just dumb storage be the Target Disk Mode.




Each file has "I-node" information, that keeps track of things such as user and group ID numbers and permissions. When you log into the Aqua Finder and mount a volume on the Desktop, I'm not entirely convinced that OS X doesn't see at least some of the files on that drive differently then they would be seen if that drive were booted.




The System Folder on the iBook's 1st partition wasn't blessed after the Restore.




Yep. There's a Dantz Knowledge Base article on this at:









Link to comment
Share on other sites

Irene & Dave,




Thanks for your input. I didn't think there would a problem using the G4 as the backup machine and the iBook mounted via FireWire Target Mode since the iBook would be merely another local HD attached to the G4. I couldn't find any info either in the User Guide or here in the forums stating that you should startup from a copy of OS X installed on the very same VOLUME that you plan on backing up locally. The only requirement for a local backup that I could find was to start up in OS X on the backup MACHINE to retain permissions.




I had done a preliminary backup test before all this using the same setup: I had backed up a couple hundred MB's of OS X system-related files and also user files, checking the permissions on the master files (on the iBook volume) against the copies restored to the 2nd G4 partition, and everything looked fine.




And, i didn't think there would be an issue with making the restored iBook bootable because of an earlier post by Irena:






"Of course, Retrospect can still create bootable volumes without needing a system installed. For example, you could duplicate or restore to an empty partition on a computer that's booted into OS X, and that partition will be bootable."










As far as I can see, permissions seem to be set properly on the restored iBook, and everything seems to function fine. Am I wrong about this? Am I missing something? Is there a good way to test "correct" permissions? Launching apps, System Preferences, network services, etc. work without incident, and except for my intial booting problem, the iBook seems to boot fine.




And what do I do with the now-visible "cores," "etc," "tmp" and "var " files? According to the documentation for Carbon Copy Cloner (which I opted not to use), it's not necessary to backup these files, and so CCC skips them. Retrospect didn't (I can see them listed in my Backup Set's contents).




And can I assume the "HFS+ Private Data" directory and it's contents are normal and should be left as is?




Thanks again!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...